Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress stops emails being sent

  • Avatar of brianterry10
    brianterry10
    Member

    @brianterry10

    I’ve just installed a brand new WordPress on my site.

    I had set it up so anyone can register.

    Here’s a screenshot that shows the general settings used…

    http://img.skitch.com/20100327-fhpat1hdaawwqyf11ykisdeimf.jpg

    I tested this with a new registration.

    The email to give me my password was sent to me. The admin was also sent an email telling me that someone had signed up.

    So far so good.

    Then I installed BuddyPress 1.2.3 (the newest version).

    No other plugins were installed. Everything was fresh out of the box.

    I activated the BP theme, I changed the permalink structure to /%postname%/.

    Everything was now installed and looked fine.

    Here’s a screenshot that shows the BuddyPress general settings page…

    http://img.skitch.com/20100327-pm3at1uic66hpugante7axfas6.jpg

    Now I began testing it by creating a new membership account.

    When I create a new test account no email is sent with my confirmation email link. The admin did not receive any emails either. I created several test accounts using different email addresses on different servers.

    So it seems like BuddyPress is preventing emails from being sent out.

    Does anyone have a solution to this?

    Many thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of brianterry10
    brianterry10
    Member

    @brianterry10

    After looking into this in more detail I discovered the problem is caused by a potential hosting compatibility issue with BuddyPress.

    As soon as I turned off the BuddyPress plugin WordPress was able to send out emails again.

    I installed BuddyPress on a WordPress install on a different server with a different hosting company and it worked fine. BuddyPress didn’t stop emails being sent out from that hosting account.

    The compatibility issue is with BlueHost.com where BuddyPress prevents emails being sent out. They use cPanel whereas the other hosting company where BuddyPress works doesn’t.

    Avatar of muratk
    muratk
    Member

    @muratk

    everybody is using cPanel. that can’t be the reason.

    Avatar of brianterry10
    brianterry10
    Member

    @brianterry10

    I fixed the problem by using this plugin…

    http://wordpress.org/extend/plugins/mail-from/

    Thanks to this thread here…

    http://buddypress.org/forums/topic/email-notification-not-working

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.