Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyStream 1.03 Feedback

Viewing 16 replies - 26 through 41 (of 41 total)
  • Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    Looks like the wp-load is a path-issue for some folks… there may/should be a quick release fix for this soon.

    @pisanojm i just changed my facebook privacy settings and its working!
    so for anyone else with this issues, visit http://www.facebook.com/settings/?tab=privacy and change “Your status, photos, and posts” to everyone…

    one more thing, i need to open/refresh …/buddystream/import.php exactly five times to make it start importing from facebook, is that normal?

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    Yes, this is normal now… it helps account for server load. You can manually set your cron to a shorter time to pull the import. For instance if you set it to pull every 2minutes then it would cycle through all five imports every 10 minutes (2×5). If you set it to 5 minutes it will cycle every 25 minutes (2×5). etc. Unless you have an extremely fast site (VPS 1024 or better), I would not set it to any shorter than the 5 minute interval (cycle every 25 minutes).

    Thanks for your help in resolving the Facebook question.

    @ezeke

    Looks like the wp-load is a path-issue for some folks… there may/should be a quick release fix for this soon.

    - Thank you for looking into this Pisanojm! This is definitely the issue we are running into. We have tried reinstalling the plugin per your previous suggestion but to no avail. Thanks again!

    Chad

    yeah my main problem is that i dont have the possibility to run cron jobs on my server so im using an external page to do it for me (https://www.cronjob.de/). its free but the free version is limitated to one cronjob every 5(=25 minutes) minutes, anyway i simply edited the file so it doesnt cycle anymore… too bad i’ll have to do that every time i upgrade :(

    @pisanojm I changed filepath in import.php, but cronjob does not work still.
    I tested excluding “IF” and tried to run import.php by curl. It works.

    //import twitter
    include_once “classes/twitter/BuddyStreamTwitterImport.php”;
    $twitterImport = new BuddyStreamTwitterImport();
    $timeTwitter = $twitterImport->doImport();
    echo “Twitter imported in “.$timeTwitter.” seconds”;
    update_option(“bs_cronjob”,”twitter”);

    //import facebook
    include_once “classes/facebook/BuddyStreamFacebookImport.php”;
    $facebookImport= new BuddyStreamFacebookImport();
    $timeFacebook = $facebookImport->doImport();
    echo “Facebook imported in “.$timeFacebook.” seconds”;
    update_option(“bs_cronjob”,”facebook”);

    I looked up my database and couldn’t find the values, “buddystream_twitter_power” & “buddystream_facebook_power”.
    I think they might be added when the twitter & facebook turned on in admin menu, but database did not have it.

    @pisanojm

    if (get_option(“bs_cronjob”) == “youtube”) {
    if (get_site_option(“buddystream_twitter_power”)) {
    if (get_site_option(“tweetstream_consumer_key”)) {
    include_once “classes/twitter/BuddyStreamTwitterImport.php”;
    $twitterImport = new BuddyStreamTwitterImport();
    $timeTwitter = $twitterImport->doImport();
    echo “Twitter imported in “.$timeTwitter.” seconds”;
    }
    }
    update_option(“bs_cronjob”,”twitter”);
    }

    changed “get_option” to “get_site_option”

    Avatar of Peter Hofman
    Peter Hofman
    Participant

    @blackphantom

    Hi all,
    - The wp-load issue will be fixed very soon, just need to do some debugging on it.
    - The stats for facebook will be fixed to.
    - setting slug in the templates will be fixed to.

    New quick release will be tomorrow.

    Avatar of Peter Hofman
    Peter Hofman
    Participant

    @blackphantom

    Me again,
    I need someone who can test out a quickfix release to confirm that the wp-load issue has been fixed.
    Please send me a e-mail so i can send a quickfix release to test.
    mail me at: blackphantom25@gmail.com

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    @blackphantom did you see above by Kosuke?

    Avatar of Kevin
    Kevin
    Participant

    @kevbow

    I’ve deleted and re-installed the plugin. Still can’t get youtube videos to load. I’ve even reset user accounts and still doesn’t work.

    I installed this and I’m having quite a few problems. I can post to facebook and twitter from my site, but not the other way around. My cron job is configured correctly as far as I can tell. I did what the instructions told me to. Also in the site wide activity when I choose tweets or facebook from the drop down menu, I get none even though I’ve obviously sent tweets from the site. One of my testers also had a problem trying to use Chrome to set up his twitter app, but it worked in his firefox.

    I’ve the latest buddypress and wordpress. The php version is 5.2.14. I’ve JSON and cURL enabled.

    Avatar of Peter Hofman
    Peter Hofman
    Participant

    @blackphantom

    There is release coming today that will fix the wp-load issues.

    Avatar of Peter Hofman
    Peter Hofman
    Participant

    @blackphantom

    @Kosuke Kato did that resolve you import problem?
    @Kevin did it not import the youtube videos ? or can’t you open them?
    @Ezeke also for that we are working for a solution, more information about that soon

    Avatar of Kevin
    Kevin
    Participant

    @kevbow

    It does not import videos. What’s strange is that I installed the older version of buddystream and it will import one of my members videos but no one else. The newest version of the plugin won’t import anyone’s videos. The last.fm import works fine, just not youtube.

    @blackphantom Yes, it’s working.

Viewing 16 replies - 26 through 41 (of 41 total)

You must be logged in to reply to this topic.