Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddystrem Twitter Error

  • Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    It was working great yesterday and this morning. This afternoon, the “post to twitter” option disappeared. I went to my account settings and clicked twitter and got this error on the screen:

    Fatal error: Uncaught exception ‘Zend_Session_Exception’ with message ‘Session must be started before any output has been sent to the browser; output started in /home/housings/public_html/wp-content/themes/bp-daily-child/header.php/2′ in /home/housings/public_html/wp-content/plugins/buddystream/Zend/Session.php:454 Stack trace: #0 /home/housings/public_html/wp-content/plugins/buddystream/Zend/Session/Namespace.php(143): Zend_Session::start(true) #1 /home/housings/public_html/wp-content/plugins/buddystream/classes/twitter/BuddystreamTwitter.php(107): Zend_Session_Namespace->__construct(‘buddystream’) #2 /home/housings/public_html/wp-content/plugins/buddystream/templates/twitter/UserSettings.php(89): BuddystreamTwitter->getRedirectUrl() #3 /home/housings/public_html/wp-content/plugins/buddystream/buddystreamFunctions.php(266): include(‘/home/housings/…’) #4 /home/housings/public_html/wp-includes/plugin.php(395): buddystream_twitter_settings_screen_content(”) #5 /home/housings/public_html/wp-content/themes/bp-daily/member in /home/housings/public_html/wp-content/plugins/buddystream/Zend/Session.php on line 454

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same here!

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    @pisanojm – just making sure you saw this. :)

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    Peter and I are working to uncover what this is… I’m not overly familiar with the Zend Framework and I’m just a PHP novice. Peter is the coding brains behind this plugin… He recently has updated the code to reflect a new import and increased stability, but we are going to run it through some more tests before it is released…Everything I’ve read about the above error point to white spaces before and after PHP tags… I can’t figure out why it is so random some times.

    I recently discovered that Internet Explorer is causing some issues with OAuth Zend Connections, but this is different than the above. Are you caching anything?

    Interestingly enough, on BuddyStream.net I saw the same behavior appear today … i.e the Twitter function disappeared and I was disconnected from it. When I went to reconnect Twitter, I received the following error:

    Fatal error: Uncaught exception ’Zend_Oauth_Exception’ with message ’Authorized token from Service Provider does not match supplied Request Token details’ in /home/admin/domains/buddystream.net/public_html/wp-content/plugins/buddystream/Zend/Oauth/Consumer.php:209 Stack trace: #0 /home/admin/domains/buddystream.net/public_html/wp-content/plugins/buddystream/buddystreamFunctions.php(701): Zend_Oauth_Consumer->getAccessToken(Array, Object(Zend_Oauth_Token_Request)) #1 [internal function]: oauthcheck(Object(WP)) #2 /home/admin/domains/buddystream.net/public_html/wp-includes/plugin.php(473): call_user_func_array(’oauthcheck’, Array) #3 /home/admin/domains/buddystream.net/public_html/wp-includes/classes.php(510): do_action_ref_array(’wp’, Array) #4 /home/admin/domains/buddystream.net/public_html/wp-includes/functions.php(1504): WP->main(’’) #5 /home/admin/domains/buddystream.net/public_html/wp-blog-header.php(14): wp() #6 /home/admin/domains/buddystream.net/public_html/index.php(17): require(’/home/admin/dom…’) #7 {main} t in /home/admin/domains/buddystream.net/public_html/wp-content/plugins/buddystream/Zend/Oauth/Consumer.php on line 209

    When I went to reconnect via Twitter it would not let me, I was using IE at the time, I kept getting above, when I switched to Chrome it went right through. I would be interested to know if others with the above error switch browsers have the same success…

    I’m beginning to wonder if some of these issues are being caused by Twitter itself… we’ll get it sooner or later! :)

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    I’ve tried firefox, chrome, and safari and get the same error in all of them.

    I concur with @gregfielding

    I also just noticed that the buddypress Foursquare API isn’t installed

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: require_once() [function.require]: Failed opening required ‘./bp-foursquare-classes’ (include_path=’.:/usr/local/php5/lib/php:/home/content/76/6912176/html/ncsocial/wp-content/plugins/buddystream’) in /home/content/76/6912176/html/ncsocial/wp-content/plugins/bp-foursquare-api/bp-foursquare.php on line 24

    Avatar of Paul
    Paul
    Participant

    @paulknox

    i am also seeing the same for users

    Avatar of Ben
    Ben
    Participant

    @bgiddings

    I was also getting this error message. I had Twitconnect installed in my plugins. I tried deactivating Twitconnect and hey presto! Buddystream works fine. Either I’m lucky or there was a conflict there. Hope this helps!

    Avatar of Ben
    Ben
    Participant

    @bgiddings

    Sorry – just to clarify, I was getting the Zend_Session_Exception error as first flagged by @gregfielding

    Avatar of Paul
    Paul
    Participant

    @paulknox

    i have buddystream plugin and not twitconnect..

    Avatar of Paul
    Paul
    Participant

    @paulknox

    thats odd… disabled buddystream and then reactivated and now twitter authorsation works?

    Avatar of Paul
    Paul
    Participant

    @paulknox

    yeap double checked….. disabling and then re-enabling solved all my issues!

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.