Skip to:
Content
Pages
Categories
Search
Top
Bottom

Bug in Default Theme – Admin/Settings/Reading

  • Avatar of dlittle800
    dlittle800
    Participant

    @dlittle800

    When I set the home page as a static page, it turns the blog into a page also. How can the home page be set as a static page – while still having posts displaying in the blog?

    This does not appear intentional – looks like a bug. How to correct?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    It is not a bug, you can set static front pages.

    Login to wp-admin

    go to Dashboard->settings->reading

    Choose Front page displays, select a static page and save, It should work.

    Edit: btw, if it does not work for you, which version of bp+wp/wpmu you are using.

    Avatar of dlittle800
    dlittle800
    Participant

    @dlittle800

    Thanks for the feedback Brajesh,

    But let me clarify the problem a bit further…

    I actually have had no problem setting the homepage as a static page on Dashboard->settings->reading.

    The problem, is that once I do so, the Blog is ALSO set to the same static page.

    I need a static page on the homepage AND posts in my blog (at the same time)

    Not the same static page as homepage and blogpage.

    Any ideas?

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    If this looks like a bug, please file a ticket.

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    @dlittle800

    sorry, I was confused earlier. Thanks for clarifying.

    Yes, It seems to be a bug, but it has to deal with the buddypress theme only. I checked with older theme and the same issue as you mentioned were there too.

    Please put a trac ticket as Andy mentioned.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    I had this problem. If you choose to use a static page as front and then use another page as the blog it wont show the blog posts when you go to url.com/blog I had to name the blog page something else.

    Avatar of carolinaforestonline
    carolinaforestonline
    Participant

    @carolinaforestonline

    on my site: http://horrycountyonline.com when you login, it doesn’t show on the home page….. but if you click any of the other tabs, you are logged in….. any ideas?

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.