Skip to:
Content
Pages
Categories
Search
Top
Bottom

Cannot assign pages components

  • Avatar of johnegg
    johnegg
    Participant

    @johnegg

    Hi

    Ive installed buddypress but I keep getting the error :

    The following active BuddyPress Components do not have associated WordPress Pages: Activity Streams, Discussion Forums, User Groups, Members, Activate, Register.

    When I click fix I am take to the ‘pages’ section in Buddypress settings area but there are no page dropdowns to select pages for activity streams, user grouds etc.

    I have created the pages but they are still not showing up. Driving me nuts!

    Any ideas?

    john

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    http://codex.buddypress.org/getting-started/setting-up-a-new-installation/buddypress-1-5-installation-wizard/

    Did you run wp-admin dashboard > Settings > Permalinks and set it to other than the default “ugly” permalink? Pretty Permalinks are required for BuddyPress. Do you have mod_rewrite enabled in your server?

    Avatar of johnegg
    johnegg
    Participant

    @johnegg

    Thanks mate, yeah I have pretty permalinks set & url rewrites on.

    Avatar of johnegg
    johnegg
    Participant

    @johnegg

    Ok something very strange going on. I did a fresh install of wordpress & deleted tables in database. Went in to WP admin and all ok. Went to ‘Settings – reading’ and I can see that I can select homepage & blog page using dropdown.

    However as soon as I activate buddypress and go back in to ‘Settings – reading’ the dropdown to select static homepage is no longer there! This is obviously related to my above problem with no page dropdowns within buddypress settings.

    Also any pages I create are not showing up in my themes navigation menu. Its as if WP is not reading any pages I create and treats it as if I have no pages.

    If I deactivate buddypress the problems persists and i need to delete database again.

    Please can anyone help with this?

    Avatar of johnegg
    johnegg
    Participant

    @johnegg

    Woo hoo! Solved it. It was the exclude pages plugin causing issues. Updated to latest version and all sorted.

    Always something simple eh? Well not always.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.