Skip to:
Content
Pages
Categories
Search
Top
Bottom

Cannot change avatar

  • Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    WPMU 2.8.4, BP 1.1, running on a subdomain with default theme and stock install. No other plugins are active.

    I searched but didn’t see anyone with this issue:

    Since upgrading to 1.1, I cannot update my user avatar. Even stranger, my current avatar was switched, via the upgrade, from my photo to the avatar of one of my groups. I see this has happened to other users on my BP install. If a user has a group, their profile avatar was replaced by their group avatar.

    Changing the profile avatar or deleting it does nothing. It says “Your avatar was deleted successfully!” but really it wasn’t. Any thoughts?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    Another detail, if it helps. My large avatar and thumbnail avatar are different, each coming from a different group that I have.

    My large profile avatar is coming from:

    wp-content/blogs.dir/1/files/avatars/2/1194984513646717809chat_icon_01svghi-2-groupavatar-full.jpg

    And the smaller, thumbnail profile avatar is coming from:

    wp-content/blogs.dir/1/files/avatars/2/467b8b4b877c1_fasting-4-18-groupavatar-thumb.jpg

    It seems at least one other person is having this same problem ( http://buddypress.org/forums/topic/11-missing-avatars#post-24891 ) though there is no current solution. I’m very grateful for any suggestions.

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    hi,

    i have the same problem as you

    i related it here

    http://buddypress.org/forums/topic/where-are-the-avatars

    no solution for the moment

    Avatar of copgarden
    copgarden
    Participant

    @copgarden

    Me too… after bp upgrade custom avatars are missing. Gravatars are there, but any custom avatar uploaded before the upgrade just shows img title, no img. I was able to upload the avatar again without an error. I did the upgrade on a sandbox installation, but will wait for a solution before upgrading live site to 1.1.

    Anyone out there have a fix for this?

    Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    copgarden, I think you are having a different issue. My profile avatars are being replaced with group avatars and I am NOT able to replace or delete them.

    Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    Still having this error. I understand that avatars are no longer stored in the database, that they are now stored in the folder blogs.dir. That directory is now populated with all the old avatars, however, those avatars are still showing up in the wrong places within the website.

    If I start with an empty blogs.dir folder, I end up with the problem copgarden has only, when I upload a new avatar, it says it is successful but only an X is displayed. I look in blogs.dir and, yes, the file was uploaded correctly.

    No idea.

    Avatar of Chris
    chriscarter
    Participant

    @chriscarter

    For anyone following this and hoping for an answer, I came across a similar discussion:

    http://buddypress.org/forums/topic/surprising-avatar-behavior

    Andy said, “The quickest option is to remove the /wp-content/blogs.dir/1/files/avatars/ directory and let BuddyPress rebuild your avatars as people upload again.” Also, Andy recommended that you check your permissions.

    I did both of the above. I removed the avatar folder which did remove the mixed-up avatars. However, BP still would not correctly display newly uploaded avatars. It said the file was uploaded correctly, I see the file in the avatar folder (both bpfull.jpg and jpthumb.jpg) but BP is still displaying those files as a broken link.

    Still hoping and looking for a fix to this as more and more people are being affected by it.

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    @ chris

    it’s better to put such reflections on the trac to ensure a possible correction in next version

    I did…

    http://trac.buddypress.org/ticket/1179

    Complete it if necessary, my english is not the best

    Avatar of Dizziness
    dizziness
    Participant

    @dizziness

    Same problem here. I tried permissions correction with no success.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Those you with this problem, try the trunk as of about 10 minutes ago. I reversed some of the logic in how avatars are loaded, but since I don’t have a broken environment myself I don’t know if it will help or not.

    Avatar of gazouteast
    gazouteast
    Participant

    @gazouteast

    @JJJ – how do we “try the trunk” ?

    No idea what you mean by that, or how to do it

    Gaz

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    You need a subversion client. For Windows I recommend TortoiseSVN. It’s a way to check out the “bleeding edge” code that includes all spot fixes and patches to current versions.

    If you ignore empty lines and white space changes, check http://trac.buddypress.org/changeset/2069 for all of the edits I made tonight to the avatar upload and display process.

    Avatar of gazouteast
    gazouteast
    Participant

    @gazouteast

    Yikes – I think I’ll have to wait for the official upgrade release – way too much there for me to attempt manually without making a complete pigs ear of it – I learned that lesson with osCommerce contribution installs.

    Thanks for putting some obviously serious effort into it, even though I’ve only spotted one edit I understood (removing the <div> size from the crop tool display.

    Gaz

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.