Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can't delete forum topics

  • Avatar of Anton
    Anton
    Participant

    @antonrsaopencirclecoza

    I have a problem with my bb installation. Whenever I try to delete anything (statuses, group messages,etc) it gives me the famous “page not found 404 error” of buddypress. Where can I change the link so that it points to the correct delete function or file?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of Xevo
    Xevo
    Participant

    @xevo

    Hmm, your the third one on the forum having trouble with this.

    We might get some clarification if you answer these questions.

    http://buddypress.org/forums/topic/when-asking-for-support

    Avatar of Anton
    Anton
    Participant

    @antonrsaopencirclecoza

    I’m using buddypress 1.13. Here is the url: http://socialpress.co.za. I’ve read everywhere to disable the plugins and I have tried that and re enabled them. Same 404 error page. I have even tried other themes but it still won’t work.

    I also can’t get the RSS site wide activity feed to work: http://socialpress.co.za/activity/feed

    I had to add extra chars to that URL: http://socialpress.co.za/friends/activity/feed and then it works but I know this is not the best solution and for some reason when I add the extra chars aka “friends” to the delete link http://socialpress.co.za/friends/activity/delete/123?_wpnonce=30864bbwe2, it only works for the administrator and not always.

    Back to the topic, everywhere on the site where there is a “delete” button next to the content when clicked gives the 404 page error if I leave the link as it came with BB.

    Here is my permalink setting: /%year%/%monthnum%/%day%/%postname%

    Avatar of Anton
    Anton
    Participant

    @antonrsaopencirclecoza

    1. Which version of WPMU are you running? 2.86

    2. Did you install WPMU as a directory or subdomain install? Sub directory

    3. If a directory install, is it in root or in a subdirectory? root

    4. Did you upgraded from a previous version of WPMU? If so, from which version? Nope. Fresh install.

    5. Was WPMU functioning properly before installing/upgrading BuddyPress? Didn’t test WPMU on it’s own. Installed it to use BB

    6. Which version of BuddyPress (BP) are you running? 1.13

    7. Did you upgraded from a previous version of BP? If so, from which version? nope

    8. Do you have any plugins other than BuddyPress installed and activated? Yes. deactivated them all and the problem(s) still occurs.

    9. Are you using the standard BuddyPress themes or customized themes? Standard. Only edited the default css and added a couple of links.

    10. Have you modified the core files in any way? Yes. The delete button next to the code is not working and If I add any chars to the delete string eg: http://socialpress.co.za/friends/activity/delete/123?_wpnonce=30864bbwe2 it does delete but not always. Some members can’t delete. The default delete string does not work. I have also added those same chars to the RSS site wide activity feed as the default one: http://socialpress.co.za/activity/feed doesn’t work.

    11. Do you have any custom functions in bp-custom.php? nope

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? 1.13

    13. Please provide a list of any errors in your server’s log files

    there’s quite allot of these

    [12-Dec-2009 19:18:07] WordPress database error Table ‘socialpr_socialpress.wp_bp_activity_sitewide’ doesn’t exist for query SELECT COUNT(id) FROM wp_bp_activity_sitewide WHERE hide_sitewide = 0 ORDER BY date_recorded DESC made by require, require_once, include, bp_has_activities, BP_Activity_Template->bp_activity_template, bp_activity_get_sitewide_activity, BP_Activity_Activity->get_sitewide_activity

    [12-Dec-2009 19:18:21] WordPress database error Table ‘socialpr_socialpress.wp_bp_activity_sitewide’ doesn’t exist for query SELECT * FROM wp_bp_activity_sitewide WHERE hide_sitewide = 0 ORDER BY date_recorded DESC LIMIT 0, 10 made by require, require_once, include, dynamic_sidebar, call_user_func_array, WP_Widget->display_callback, BP_Activity_Widget->widget, bp_has_activities, BP_Activity_Template->bp_activity_template, bp_activity_get_sitewide_activity, BP_Activity_Activity->get_sitewide_activity

    [12-Dec-2009 19:18:21] WordPress database error Table ‘socialpr_socialpress.wp_bp_activity_sitewide’ doesn’t exist for query SELECT COUNT(id) FROM wp_bp_activity_sitewide WHERE hide_sitewide = 0 ORDER BY date_recorded DESC LIMIT 200 made by require, require_once, include, dynamic_sidebar, call_user_func_array, WP_Widget->display_callback, BP_Activity_Widget->widget, bp_has_activities, BP_Activity_Template->bp_activity_template, bp_activity_get_sitewide_activity, BP_Activity_Activity->get_sitewide_activity

    [12-Dec-2009 19:18:21] WordPress database error Table ‘socialpr_socialpress.wp_bp_activity_sitewide’ doesn’t exist for query SELECT * FROM wp_bp_activity_sitewide WHERE hide_sitewide = 0 ORDER BY date_recorded DESC LIMIT 0, 10 made by require, require_once, include, bp_has_activities, BP_Activity_Template->bp_activity_template, bp_activity_get_sitewide_activity, BP_Activity_Activity->get_sitewide_activity

    [12-Dec-2009 19:18:21] WordPress database error Table ‘socialpr_socialpress.wp_bp_activity_sitewide’ doesn’t exist for query SELECT COUNT(id) FROM wp_bp_activity_sitewide WHERE hide_sitewide = 0 ORDER BY date_recorded DESC made by require, require_once, include, bp_has_activities, BP_Activity_Template->bp_activity_template, bp_activity_get_sitewide_activity, BP_Activity_Activity->get_sitewide_activity

    SHouldn’t there be a table wp_bp_activity_sitewide on the installation? I’ve looked in the db but it’s not there. I did the default installation.

    .

    14. Which company provides your hosting? Hostgator

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    ‘wp_bp_activity_sitewide’ doesn’t exist anymore, not even in the deprecated code. It was dropped pre 1.0 in lieu of having one universal activity stream. A clean 1.1.3 installation shouldn’t have any code looking for those tables.

    http://socialpress.co.za/activity/feed works for me.

    I’ve created a test account on your website and confirmed that I was able to delete my own activity just fine.

    Is it possible this is a conflict with the privacy component?

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Looks like it was a bad upload of BP. Marking as resolved.

    Avatar of Anton
    Anton
    Participant

    @antonrsaopencirclecoza

    Yes thanks. I wiped everything and did a clean install and it’s working now. Thanks for the help John.

Viewing 7 replies - 1 through 7 (of 7 total)

The topic ‘Can't delete forum topics’ is closed to new replies.