Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Can't register new users on my BuddyPress site

  • Avatar of Baskers
    Baskers
    Participant

    @baskers

    Hi,

    And apologies for being a complete noob.

    I created a brand new WP & BP site today, downloaded the latest versions of WP & BP, installed them, set them up (everything from scratch) and everything seemed to be going well until I tried to create new user accounts (using lower case for the username) via the registration page when you go to create a new account (and yes I did tick the button to allow user registrations in the network settings).

    http://baskers.net/RickyTweetUp

    I had gone back to the BP default themes/settings, deactivated all plugs and tried again. Still no joy. The same issue is still present.

    I can manually add new users via the admin function, but obviously I don’t want to be having to add new users manually and would much rather they registered themselves. From my lay point of view, it’s almost as if when I click the “Complete my registration” button the page just refreshes keeping the same information in the boxes barring the password entries. It’s like the data isn’t writing back to a database and creating a new user record. There’s nothing in the Admin panel for the new user request – like the data doesn’t exist.

    Please can anyone help me?

    Thanks

    -S

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of Baskers
    Baskers
    Participant

    @baskers

    Hello? Anyone?

    Avatar of Baskers
    Baskers
    Participant

    @baskers

    Software details are:

    – WordPress Theme Custom Community By ThemekraftVersion 1.15
    – BuddyPress Version 2.3.2.
    – WordPress Version 3.5.1

    Again, I’ve tried it with just the default buddy press theme, and disabled all plugins and still can’t create new user accounts via the registration page.

    Please help

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @baskers I got a 404 page when I visited your link. Try renaming the subdirectory folder where you installed your WordPress and BuddyPress from RickyTweetUp to rickytweetup

    Avatar of msdoble
    msdoble
    Participant

    @msdoble

    I have been having the exact same issue. Clean install of both WordPress 3.5.1 and BuddyPress 1.7. Presuming you have checked the box “anyone can register” in Settings > General it’s a mystery.

    I did consider it might be a permalink issue, but have tried all combinations thereof. No joy. You might however want to try this perhaps. Also, it’s worth checking which pages are assigned to your registration and activation in BuddyPress settings.

    There are various threads on the same topic in this support forum, everybody experiencing exactly what you have mentioned, but none of them are resolved (so far as I can tell).

    Leads me to think that this is a SERIOUS bug in an otherwise fantastic plugin. It’d be nice for some of clarification on this though, even if the answer is ‘it’s a bug’.

    Avatar of Baskers
    Baskers
    Participant

    @baskers

    Hi @Mercime

    I ended up doing a complete wipe, and fresh install of WP & BP again, only this time as you suggested I had the subdirectory folder all in lower case which became http://baskers.net/rickytweetup

    and magically…. it now works.

    Was having uppercase for the URL/subdirectory folder causing the issue?

    Avatar of msdoble
    msdoble
    Participant

    @msdoble

    @Baskers Yes, that’s incredible, this has also fixed the same issue I was having. I’d never have thought the directory name would be a factor. Glad you’re all sorted!

    @mercime thank you very much for the insight.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @baskers @msdoble Glad your issues are resolved. Thanks for posting back. As far as I can recall, WordPress works in folders with lowercase names.

    Marking this topic as resolved.

    Avatar of Collectif Dont Panic
    Collectif Dont Panic
    Participant

    @collectif-dont-panic

    Hi there !

    I was exposed to the same issue today, with BP 1.7.2 and WP 3.5.2.

    Solved by checking the php version of the site, the php version should be 5.4 ( use the function <? phpinfo(); ?> to check that.

    Other thing, like have said @baskers, ensure you have only lower caps in your url.

    Hope my reply would help someone else ! :)

    Avatar of nathandboyd
    nathandboyd
    Participant

    @nathandboyd

    Although this is listed as Resolved, I will still post a reply. I had the exact same issue, and decided to try adding “www.” to the front of the URL in the WordPress address bar (instead of simply http://mysite.com) under General Settings. That fixed the issue immediately.

    Avatar of TemporalSales
    TemporalSales
    Participant

    @temporalsales

    I can confirm nathandboyd’s solution above.

    I had the same problem with activating registrations and adding “www” to my wordpress URL in the wordpress settings did the trick.

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.