Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Can't see member profile (Not found)

  • Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    “It seems we can’t find what you’re looking for.
    Perhaps searching, or one of the links below, can help.”

    Whenever I try to open a member profile, I get that error. It started after I deleted some menu links related to buddypress. Now I recreated them all, using the same pages, I can browse anything (Activity stream, Forum, members), except a single member’s page.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of danbp
    danbp
    Moderator

    @danbp

    Check BP settings and specially all components with their respective assigned pages.
    Check if you have some deleted pages in the trash. If so, clear it. For ex. if you have an deleted “members” page in the trash and a new one in your page list, this cannot work well.
    Check also your permalinks and click on update even you not change them. This normally does refresh all your links.

    Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    1 – I’m in the Pages page and I can’t find the trash, perhaps I don’t have anything in it?
    2 – How can I check the permalinks? All I can find is the permalinks settings, not the permalinks themselves.

    Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    No can do. I don’t have anything in the trash, also can’t edit the permalinks.

    It looks like the only problem is with the profile page. Whenever I click a member’s name, or click at my profile link, I get that not found message.

    Avatar of danbp
    danbp
    Moderator

    @danbp

    Yes i meant permalinks settings.

    https://codex.wordpress.org/Settings_Permalinks_Screen

    By going on the permalink page and simply clicking on update, without doing any change, will refresh the whole site urls. This is recommanded after heavy modification on pages, posts, menus.

    You can also check the permalink format on the “member” page, just in case off. Sometimes there is a number at the end of the URL which shouldn’t be…

    Activate debug mode and see if you receive somme other error msg

    http://codex.wordpress.org/WP_DEBUG

    If nothing works, read here and provide the whole bunch of information.

    Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    there is no update button, only a “save settings”, is it correct?

    Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    hey, look which errors I got:

    Notice: Use of undefined constant PLUGIN_URL – assumed ‘PLUGIN_URL’ in /home/username/public_html/wp-content/plugins/envolve-chat/envolve-chat.php on line 69

    Notice: Use of undefined constant PLUGIN_PATH – assumed ‘PLUGIN_PATH’ in /home/username/public_html/wp-content/plugins/envolve-chat/envolve-chat.php on line 70

    Notice: Use of undefined constant adcopy_wp_enable_comment_reply_reload – assumed ‘adcopy_wp_enable_comment_reply_reload’ in /home/username/public_html/wp-content/plugins/solvemedia/solvemedia.comment.inc on line 25

    Notice: bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in /home/username/public_html/wp-includes/functions.php on line 3245

    Notice: bp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 1.7.) in /home/username/public_html/wp-includes/functions.php on line 3245

    Notice: Use of undefined constant BP_PORTFOLIO_ITEMS_TABLE – assumed ‘BP_PORTFOLIO_ITEMS_TABLE’ in /home/username/public_html/wp-content/plugins/buddypress-portfolio/includes/bp-portfolio-loader.php on line 74

    Notice: Undefined variable: defaults in /home/username/public_html/wp-content/plugins/buddypress-portfolio/includes/bp-portfolio-classes.php on line 34

    Notice: Undefined variable: defaults in /home/username/public_html/wp-content/plugins/buddypress-portfolio/includes/bp-portfolio-classes.php on line 157

    Notice: Undefined variable: id in /home/username/public_html/wp-content/plugins/buddypress-portfolio/includes/bp-portfolio-classes.php on line 173

    Notice: Undefined index: workflow in /home/username/public_html/wp-content/plugins/social-articles/includes/social-articles-functions.php on line 122

    Notice: Undefined variable: sub_nav in /home/username/public_html/wp-content/plugins/social-articles/includes/social-articles-load.php on line 96

    Notice: Undefined index: general_display_media in /home/username/public_html/wp-content/plugins/buddypress-media/app/main/RTMedia.php on line 904

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    As you can read, some of those aren’t related to BuddyPress. What versions of BuddyPress, bbPress, and WordPress are you using?

    Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    bbpress Version 2.5.4
    Buddypress Version 2.0.2

    Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    Goddamn it, I solved it, you guys will never know what was it………

    Avatar of spikespiegel
    spikespiegel
    Participant

    @spikespiegel

    I knew it was something related to the pages and the buddy press pages configuration. Buddy press activity page was set to open in a parent link, while all the other buddy press was set to open in submenu links. I just had to change the activity link, and now it’s back to normal.

    In other words, it’s all related to the pages and menu structure.

    SOLVED!

    Avatar of danbp
    danbp
    Moderator

    @danbp

    Thank you for the feedback and glad you got it solved. :D

    Topic marked as solved and closed.

Viewing 11 replies - 1 through 11 (of 11 total)

The topic ‘[Resolved] Can't see member profile (Not found)’ is closed to new replies.