Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can't see 'members' page in buddypress local install

  • Avatar of vtblogmu
    vtblogmu
    Participant

    @vtblogmu

    I have buddypress working nicely on a server, however I can’t display the ‘members’ page or any individual profile page on a local webserver install I have made.

    If I try and visit /members/ I just get redirected back to th emain buddypress page.

    No idea what’s causing it, any suggestions on what I could do?

    I also just noticed online members never shows whose online, could be related.

Viewing 21 replies - 1 through 21 (of 21 total)
  • Avatar of subhramani
    Subhramani
    Member

    @subhramani

    Its the same case with me in my production site. The ‘All Members’ link the the members page links to the homepage of the website. Need help please.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Have you guys tried setting your permalinks to something other than the default?
    http://codex.wordpress.org/Settings_Permalinks_SubPanel

    When you’ve tried a different setting, also see if a .htaccess file is generated in your WordPress root directory.

    Avatar of subhramani
    Subhramani
    Member

    @subhramani

    In wordpress, I have set my Permalinks to
    /%category%/%postname%/

    Would that have any effect on my buddypress as well? How do I fix it though? :-(
    I cant really change the permalinks settings now as it will generate hundreds of 404 errors from search engines.

    BuddyPress does not work with the default, out-of-the-box permalink style from WordPress (not WPMU). Full stop.

    Avatar of subhramani
    Subhramani
    Member

    @subhramani

    Sorry I didnt really understand that :-s

    Avatar of qbuster
    qbuster
    Participant

    @qbuster

    I’m experiencing similar problems. I have BuddyPress working quite well on the Atahualpa theme at http://waterwaywatch.org but whilst I can get a list of members, clicking on a member’s profile gets me re-directed to About/Home.

    As insisted upon when I first linked in BP, Permalinks is set to something other than Default. I have tried all of the non-default options and they don’t solve the problem.

    Very frustrating!

    Avatar of revolucion
    revolucion
    Member

    @revolucion

    Exact same problem as described.
    I did a clean 1.2.3 install running on WordPress MU 2.9.2. I followed the how-to as presented on this page, and changed the permalinks setting to something other than default.

    A .htaccess file is indeed created, and the buddypress installation does run. However, when I try to visit the about page or the members page, I get a 404 error stating the page doesn’t exist. The link is correct (http://localhost.localdomain/wpmu/members/ i.e.) , but it simply doesn’t show anything.
    I can’t visit a members profile either, it simply stops everywhere outside the mainpage.

    I’m using the default Buddypress theme btw, nothing changed on my side.

    Avatar of qbuster
    qbuster
    Participant

    @qbuster

    Well, I’ve been frustrated by this now for weeks and no-one seems to want to try and help. Let me describe two scenarios that demonstrate the two problems above in the hope that someone will try to solve them:

    1. I have just installed a completely fresh WP 2.92 and BP default 1.2.3 on my local server (localhost). I followed TO THE LETTER the instructions given on http://codex.buddypress.org/getting-started/setting-up-a-new-installation/. Permalink is set to the first non-default option. The install went well and the site looks good. However, Clicking on the menu items Members, Groups, Forms, Activites etc gives:

    HTTP/404
    The requested URL alias for /members/ is not defined.

    Question: What do I do to get the pages display properly?

    2. I Have a live site waterwaywatch.org which fares somewhat better. I can get as far as Member and Group pages but if I try to click on a member to display their profile, the site re-directs to About.

    Please, please, there must be someone out there who can help me on what both seems to be fundamental path issues. In both cases .htaccess contains:

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Thanks in advance

    Will

    It’s because you’re installing on http://localhost/ — that won’t work (it might be fixed in WordPress 3.0, not sure), it needs to resemble a full domain name i.e. something.com. I have an alias setup in my /etc/hosts file (if you’re on Windows, Google for the location of this file. I think it’s in /system32/) for “example.com”.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    I have BP installed locally and it works fine. I’m using MAMP.

    Yes, but I bet you a cake you haven’t got your site on http://localhost/.

    Avatar of qbuster
    qbuster
    Participant

    @qbuster

    Paul

    Thanks for that explanation re: localhost.

    But my main issue (and looking at the earlier posts in this thread over the last few weeks, it is a problem experienced by several other posters) is the same sort of problem on my remote site, http://waterwaywatch.org . I can get as far as Member and Group pages but if I try to click on a member to display their profile, the site re-directs to About.

    I’ve been struggling with this for some time (see earlier post in this and other threads). In an attempt to isolate the problem I have reverted to a standard bp 123 theme- including choosing a non-default permalink – but the problem persists and it is a real show stopper as I can’t launch the site as is.

    Thanks for your response,

    Regards

    Will

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Avatar of Sam Munro
    Sam Munro
    Participant

    @samuelmunro

    I think I’ve solved this problem the same as every here has been describing.

    After about 3 re-installs and 10 cups of tea, I finally dawned on me like a chisel falling from the grasp of a tired granite mason.

    You do indeed need to install at the domain level, this also includes as I have found, the sub-domain level.

    1) Create sub-domain. http://www.SUB.DOMAIN.com
    2) Fresh wordpress install to your new sub-domain
    3) Then Buddypress install

    Hey Presto works, get your self one final cup of your favourite beverage, that you can now take the time to enjoy.
    Then get some sleep, you’ve earned it.

    my twitter is @samuelmunro if it worked for you or didn’t I’d like to know either way.

    The above steps takes into account the understanding that you already know your way around cPanel, at least to the same level as me, which boasting aside is about one level higher than that of a monkey with lobotomy.

    Avatar of dagicueppers
    dagicueppers
    Member

    @dagicueppers

    Hey Will,

    did you ever find a solution to that problem? I tried everything suggested in this thread and nothing has worked for me so far. I’m still re-directed to the “Home”-Page when I try to access the member pages. And you’re right: It is a real show-stopper :)

    If you solved this problem, I would very much appreciate if you could share it here.

    Thank you!
    Dagi

    Avatar of qbuster
    qbuster
    Participant

    @qbuster

    @dagicueppers Mostly fixed with WP 2.9.2 by creating pages called Members, Groups, Forums, etc but there are still issues.

    I’m now testing everything with WordPress 3.0 RC1 (on a remote Linux server) and oddly enough the same issues arise and, sadly, don’t appear to be solved by the above solution.

    Avatar of wirawit chaochaisit
    wirawit chaochaisit
    Participant

    @nabito

    Bump with exactly the same problem.

    It happened to be .htaccess did not update because of file permission. Did manual update, adding mod_rewrite rule and everythings work!

    If not in your case, try checking if mod_rewrite module of apache is enabled?

    http://nabito.wordpress.com/wp-admin/post.php?post=60&action=edit&message=1

    @qbuster Did you find a fix for this?I’m using the latest version of bp and wp but gives me the same error,
    I can get to members list but when I try to see user profile it gives me an 404.

    Avatar of Clint
    Clint
    Member

    @clintonb11

    @muhang I also am having your same issue. I can see member list, but no profiles. The list shows all the members, but when I click on one I get a 404. Very weird. Do you have any special membership plugins installed?

    @clintonb11 nop nothing, I even tried a clean install and still gives me this error. Don’t have a clue why.
    It all started with using cache.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    If you’re using an older BP theme or bp-default child theme, check out section on Theme Information on this page http://codex.buddypress.org/releases/1-5-developer-and-designer-information/

    @mercime This error is giving with fresh install, with bp 1.5.1 and wp 3.2.1, not with old themes/plugins. Its a clean install.

Viewing 21 replies - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.