Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Change avatar crop feature not working

  • Avatar of applegateian
    applegateian
    Participant

    @applegateian

    Hi

    I’m running WordPress 3.5.1 and Buddypress 1.7

    The crop avatar function is not working. Uploading the picture works, and previews the image, but there is no way to crop – the crop icons do not appear and dragging the image does nothing.

    Any ideas?

    Thanks,

    Ian

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of bp-help
    bp-help
    Participant

    @bphelp

    @applegateian
    See:

    http://buddypress.org/support/topic/when-asking-for-support-2/

    You need to supply more info than just what version of BP and WP your using like theme, plugins, etc.
    I had this issue once and it was a theme that conflicted with js so if your using anything other than twenty twelve or bp-default then activate one of those instead to test if the crop works and if so then you narrowed it down to a theme.

    Avatar of applegateian
    applegateian
    Participant

    @applegateian

    Ok thanks – I’m using Reverie theme and upon changing to Twenty Twelve, cropping does work.

    Any ideas on how I can debug and potentially fix it?

    Thanks

    Avatar of bp-help
    bp-help
    Participant

    @bphelp

    @applegateian
    I would contact that themes author and explain the situation and see if they can help. I am not familiar with that theme but maybe someone else here may have more insight.

    Avatar of applegateian
    applegateian
    Participant

    @applegateian

    OK thanks, here is the link in case someone does know:

    Reverie Framework

    Avatar of applegateian
    applegateian
    Participant

    @applegateian

    Ah found this, might be useful for others:

    http://buddypress.trac.wordpress.org/ticket/4899#no1

    Reverie loads jQuery 1.9.1 from Google. We load jCrop 0.9.10 from WordPress core, and it seems these versions don’t work with each other.
    Upgrading to WP 3.6 trunk/beta 1 should resolve the issue, or you can just change Reverie to stop it loading jQuery from Google.

    Avatar of LukeQuietus
    LukeQuietus
    Participant

    @lukequietus

    Did upgrading to 3.6 beta work? I’m having this exact same problem. I just get a square in the top left corner which when dragged messes everything up BIG TIME! I’m using the GrandMag theme from IndustrialThemes (Premium) but they’ve removed the theme since and are in hiding. Also, this is a site for a client with alot of work gone into it and a week from going public.

    I knew I shouldn’t have upgraded! Idiot! There should be a rollback option in WordPress!Or a plugin test mode before you commit.

    Avatar of justintyme
    justintyme
    Participant

    @justintyme

    Having same issue. Moreover I’m running multisite in which all 5 sites have all the same plugins activated + all use the same theme. Yet, on some sites cropping works and on half of them not. All sites have exactly same setup, same settings, same extensions and same functions. Nothing modified. Along with the crop function, the buddypress register function also fails on those site where cropping fails.

    Theme issue? Don’t think so.
    Other plugin issues, nope.

    PS, on the sites that DO have a functioning cropping, when first time clicked on any area within the cropping module, the page jumps and users have to scroll up again.

    WP 3.6.1 mlti network, latest buddypress, bbpress latest, cubepoints, set permalinks on %post-name%. Activated and deactivated rtMedia (which sucks for me since it conflicts with build-in media upload) but also gives same results.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.