Skip to:
Content
Pages
Categories
Search
Top
Bottom

Comment loop gone when using /category/ permalink

  • Avatar of Seobrien
    Seobrien
    Participant

    @seobrien

    I’ve switched permalinks to /%category%/ and the comment loop on posts has vanished. Any idea how I get it back? I do not want to revert to default permalinks, they are not SEO friendly. Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Are you using the bp home theme?

    Avatar of Seobrien
    Seobrien
    Participant

    @seobrien

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I\’ll take a look at it.

    EDIT: I tried to get to one of your blog posts but can\’t seem to. It\’s waiting forever for something called l.sharethis.com? That site is down, busy, something? Don\’t know what that is. I\’ll go look at what could stop comments from showing up based on a permalink change.

    You have existing posts that were created under one permalink structure and then you changed it? Those are the posts that suddenly don\’t have commments? If you create a new post using the new permalink structure do the comments work?

    What version of bp and what version of wpmu? There was an issue with RC1 and changing the permalink structure. Specificly with the %category% type.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you using RC1 or trunk version of BP?

    This was a problem with RC1, should be fixed in trunk.

    Burt, I need to read what you say more thoroughly haha. :X

    Avatar of Seobrien
    Seobrien
    Participant

    @seobrien

    I’m on RC1 with MU 2.7 (sharethis must have been on their end, I’m not having problems)

    Figured out the the /category/ permalink issue was that it wasn’t identifying the /blog/ slug so when you use the custom permalink, it tries to pull root.com/category/post instead of root.com/blog/category/post

    Might that be the problem? I’d love to upgrade with the trunks but have no idea how to do so.

    That said, these were posts with comments with which I changed the permalink. But that shouldn’t cause problems (at least, it doesn’t in WP) and new posts don’t work either.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I’m not sure what you mean by “sharethis must have been on their end”. I can’t access any blog post on that site or even /blog without sharethis running and stopping me from getting anywhere. Whatever that is, it’s not operating correctly and is shutting down that site.

    Avatar of Seobrien
    Seobrien
    Participant

    @seobrien

    I am too confused

    ShareThis is a 3rd party app, a javascript on the posts. I’m on boruma.com on two different computers without a problem.

    My response meant that I assumed sharethis was a problem at the time (their server down as you implied) as I am not having problems now.

    Regardless, I’ve disabled the plugin so ShareThis is off. Still inaccessible?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    That\’s better. Looking around.

    EDIT: I took a look at that trac ticket and it specifically mentions changing the permalink structure to /%category%/ and that RC1 has problems loading the proper templates. It looks to me like that is what is happening in your case. It\’s like the comments.php template isn\’t being loaded. I\’m not finding any html structure from that template under your blog posts. No template no structure. http://trac.buddypress.org/ticket/554

    The only solution I can suggest to you is change the permalink structure back or install the trunk version of bp. Installing the trunk version means upgrading wpmu to the svn branch of 2.7, deleting bp from /mu-plugins and moving it to the new location in /plugins.

    Avatar of Seobrien
    Seobrien
    Participant

    @seobrien

    Thanks; over my head, I haven’t even figured out how to get an svn branch

    Any recommendations on folks to hire for such a task? I can hack things together but those changes are out of my reach considering I don’t know where to start learning.

    I have another, perhaps more complex project beyond this. I’d like to get the same instance of BP working across domains to another site. I’ve talked to a few who think its possible but have yet to track down someone capable and available.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    There is a job board in the dev section. Nothing but a wire now. http://buddypress.org/groups/buddypress-job-board

    Emails go out to all those who are members of that group. You could also post a topic here since the job board doesn’t have a forum yet. Post it here and one of the mods will close it after posting. People can contact you through your profile in a PM.

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.