Skip to:
Content
Pages
Categories
Search
Top
Bottom

create account or register – 500 error

  • Avatar of John Horniblow
    John Horniblow
    Participant

    @johnhorniblow

    I am facing an issue that I cannot get to the bottom of.
    - When a user tries creates a new account e.g mysite.com/register they get a 500 error .
    - I can add users or new accounts in the admin interface for Users.
    - Existing members can log in without problems
    - Profile Field Setup in BP general settings – renders an empty page
    - I am running BP Version 1.2.5.2, WordPress 3.0.1
    - I used WP Mass User Input to import / migrate users off NING. and it worked very well.

    thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    500 is an internal server error or misconfiguration it might be caused by to low a php script memory value judging by the sound of the profile field page error.

    As always to troubleshoot first disable BP confirm that WP works as expected without issue, in this case that you can register accounts without issue, when that is confirmed as ok proceed to enable/activate BP but no other plugins just plain vanilla BP along with the default theme NOT a custom one, confirm whether issues arise.

    You might possibly have syntax errors in .htaccess but if so I would expect issues from the get go as it’s read on page load .
    If possible confirm the amount set for PHP script memory in php.ini.

    Avatar of John Horniblow
    John Horniblow
    Participant

    @johnhorniblow

    Hi, hnla, thanks for the advice . I will deactivate BP, I have ascertained that WP is working as I can create user accounts , publish etc ( no issues ) I had already created a php.ini with 20 mb, its single line of code reading as follows memory=20MB so I will go back through the plugins to see if there’s a conflict. Unless you think I need to increase the memory allocation. I am hosted on 1and1 , which has caused a few headaches in setting it up , that’s been corrected by adding the handlers into .htaccess as follows
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    What I saw in the .htaccess was that W3 total cache plugin had written a lot code into it , as far as I can see its working.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    20mb is far to low – try 64 or 96 or as high as you can provide but not so high that you allocate all your available system memory if a script does misbehave as that will result in the OS crashing

    I’d agree at least 64Mb. I think you can get away with 32Mb if it’s a low-traffic site, but it depends on how much code is loaded from any other active plugins and themes.

    Avatar of John Horniblow
    John Horniblow
    Participant

    @johnhorniblow

    ok. cool , thanks Paul and HNLA..

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.