Skip to:
Content
Pages
Categories
Search
Top
Bottom

Custom HTML in posts

  • Avatar of GamerRigz
    GamerRigz
    Member

    @gamerrigz

    I have noticed that custom HTML is accepted in any post using Buddypress. Is there a way to block custom html allowed in posts, but yet allow ‘oEmbed for WordPress’ to still fully function?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Please would you clarify what exactly you mean by “[posts] in BuddyPress”? When I read that, I immediately think of writing blog posts, which is part of WordPress core.

    Avatar of GamerRigz
    GamerRigz
    Member

    @gamerrigz

    Oh, I mean posts in the activity area; posting an update.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    The word ‘custom’ needs clarification, markup is allowed in much the same manner as would be in posting comments to a blog post there are a series of allowed tags – but not many – such as <blockquote>, <code>, <p>

    These tags should not present an issue, they are simple markup tags (most users will be unaware they can use them)

    If you have something else being allowed then you must specify clearly what the conditions are that you refer to i.e What tags?! Are you running plugins which are altering the default behaviour?

    Avatar of GamerRigz
    GamerRigz
    Member

    @gamerrigz

    Oh, I have that fixed now but I am having a different issue. When both the JS/AJAX and CSS compatibility are enabled, my reply button is not working I click it, I see the box for a split second, and it removes itself again

    Avatar of GamerRigz
    GamerRigz
    Member

    @gamerrigz

    Also, there is alot of bad pixelation when a transparent background avatar is uploaded; is this a bug or is it automatically like that?

    Avatar of GamerRigz
    GamerRigz
    Member

    @gamerrigz

    @Paul Gibbs and @hnla One more thing, there is an unwanted question mark after the @username when I have disabled the JS / AJAX compatibility because of the reply button not working. Sorry for the hassle

    Avatar of GamerRigz
    GamerRigz
    Member

    @gamerrigz

    Okay, I have found the problem, I was using a cuf√≥n font over the ‘Reply’ text so it wasn’t working

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.