Skip to:
Content
Pages
Categories
Search
Top
Bottom

Custom Profile Fields not shown on members profiles

  • Avatar of abbersbolton
    abbersbolton
    Participant

    @abbersbolton

    Can someone please help with how to show up the custom profile fields that we make for registration? I don’t understand to be honest, why they are called “profile fields” if they are not for showing up automatically on the profile, but I’d greatly appreciate if someone could tell me if it’s some sort of code I need to enter and where exactly I need to enter it to make them show up?
    I’d like all of my base profile fields to show up as I’ll be running a private site.

    P.S. (off topic) Is it just me or is the buddypress.org site search facility just completely broke? It just always sends me to the blog….
    Many thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of CJ Kruger
    CJ Kruger
    Participant

    @cj-kruger

    They will be there under Profile>Public

    Where is it you would like them to show up?

    For example these are custom fields being called in the group header, same thing can be done with the members header

    Avatar of abbersbolton
    abbersbolton
    Participant

    @abbersbolton

    Well (I’m sorry I don’t have a clue how to insert a pic like you have) I’d like them to show up on the member’s profile page, i.e. when they click on your name. I want it to be in the header I suppose, or just somehow accessible. At the moment, when I click on a member, there is no “public profile” tab or anything like there is on my own, so all you see is the activity module.with activity, groups, forums etc.
    I just want other people to be able to access this info even if it means an “info” tab a la Facebook!

    To briefly explain, I have a similar set up to yours – Twitter button and klout score and a user location map so these things are in the header already, but other info like for example, Facebook page url, web address – I want these custom fields to also show and not just serve as input for plugins etc.

    Thanks

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    BuddyPress profile fields do show by default when you visit a profile. So, it sounds like either your theme, or a plugin is causing the problem.

    Did you create your profile fields from the BuddyPress menus in wp-admin?

    The most likely candidate for the problem sounds like the plugin you are using to add buttons and maps to the user profiles.

    Try deactivating that plugin – do the profile fields show?

    Try switching to bp-default theme – do the profile fields show?

    If they are still not showing — deactivate all your plugins except BuddyPress, use the default theme, and go to the Profile Fields section in wp-admin … are they definitely set up correctly in there? Are privacy settings correct? Do the profile fields show now in the front end?

    By breaking your search down for a solution step by step like this, you’ll be able to determine what is causing the problem (your theme or one of your plugins).

    Avatar of CJ Kruger
    CJ Kruger
    Participant

    @cj-kruger

    Im guessing from what you have said you are using my twitter and klout plugins, what I could do is build a custom plugin for you – having all your requested features in one interface..

    It will not be free though it wont cost a arm and a leg, if you are interested contact me at nit3watch@gmail.com

    Avatar of abbersbolton
    abbersbolton
    Participant

    @abbersbolton

    @RogerCoathup Thanks for that I will look in to it- it didn’t happen to me when I built first edition on local server. It may be one of a number of plugins, I will test each one to see if they cause problem and then try another theme. Shouldn’t be the theme because custom community theme is supposed to be compatible with BP but hey ho you never know.

    @cj-kruger Yes I think I am, BP Klout and BP Twitter. I’ll look to see how it goes but at the moment the two plugins seem to be fine together unless of course they are causing the problem.

    I will test this week and report back. Thanks all.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.