Skip to:
Content
Pages
Categories
Search
Top
Bottom

Digest Emails not Being Sent

  • Avatar of brentjacobsen
    brentjacobsen
    Member

    @brentjacobsen

    Hi Boone,

    Love the plugin!! It’s working great when set to send all e-mails, but none of the other settings seem to be working. Specifically, the daily digest is what I need to be working the most. Any direction on where I should begin troubleshooting?

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of crazycoolcam
    Cam
    Participant

    @crazycoolcam

    I am having a similar problem.
    WP 3.2.1 — BP 1.2.9 — Plugin Version 2.9.1

    Normal WordPress emails are sent correctly.
    All Emails option sends properly.
    Daily/Weekly Digests don’t send.

    When I look in the message queue it has errors interspersed with messages. The two errors that repeat themselves in numerous places are:

    ‘Warning: Wrong parameter count for in_array() in /[mysite]/wp-content/plugins/buddypress-group-email-subscription/bp-activity-subscription-digest.php on line 211′

    and

    ‘Warning: Invalid argument supplied for foreach() in /[mysite]/wp-content/plugins/buddypress-group-email-subscription/bp-activity-subscription-digest.php on line 225′

    Any help would be appreciated. Thank you in advance.

    ~Crazycoolcam

    Avatar of crazycoolcam
    Cam
    Participant

    @crazycoolcam

    New Topic Emails are not being sent either. (I’ve only successfully seen emails sent with the “All Mail” option.

    Avatar of crazycoolcam
    Cam
    Participant

    @crazycoolcam

    As a testing measure (did this for another plugin I am having issues with), I created a test server. Default everything on a different webhost. I created groups, new users, and subscribed to some group groups email notification.

    This is a new install with WP 3.2.1 — BP 1.2.9 — Plugin Version 2.9.1 and multi-site is enabled.

    The error message that I get is the
    Warning: Wrong parameter count for in_array() in ... bp-activity-subscription-digest.php on line 211?
    that I received above.

    Any thoughts, ideas, or possible solutions. I would love to get this plugin working again.

Viewing 3 replies - 1 through 3 (of 3 total)

The topic ‘Digest Emails not Being Sent’ is closed to new replies.