Skip to:
Content
Pages
Categories
Search
Top
Bottom

Does BP 1.1.3 work on WP 3.0+?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    BP 1.1.3 will not work with WP 3.0. You need to use BP 1.2.4.1. Before you do any updates to a production site, read the upgrade instructions, the readme.txt files, and throughly search these forums for discussions of issues people have had with upgrading to not only BP 1.2.x, but also WP 3.0. Of course, WP 3.0 is not yet an official release. It is an RC2 at this stage.

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    Why will 1.1.3 not work? What changed in WP 3.0 that breaks it? File names, hooks, functions? Or more fundamental things like database structure? How difficult will it be to make 1.1.3 work on WP 3.0?

    I’m not planning to upgrade to 1.2…

    Then your site will be open to hackers. Security holes have been fixed since 1.1

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Here’s what has changed in BP 1.2.x: http://trac.buddypress.org/query?groupdesc=1&group=milestone&milestone=1.2&milestone=1.2.1&milestone=1.2.2&milestone=1.2.3&milestone=1.2.4&order=milestone&col=id&col=summary&col=status&col=owner&col=type&col=priority&col=milestone

    You can do a similar search in WordPress Trac and see how much has changed in WP 3.0.

    The moral of the story: you are on your own if you decide to stick with older versions of WordPress and BuddyPress. As Paul states above, there are important security fixes (as well as changes in functionality) that are not supported in older versions. It’s your choice.

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    A custom site will be less of a target than out-of-the-box Buddypress, so I’ll take my chances. If I can get it working on WP 3.0 of course, which is a big if…

    It depends on what will take the most work; getting 1.1.3 to work on 3.0 or going with 1.2 and having to strip out all the forum integration and confusing “changes in functionality”. Either way my sites will require loads of custom coding for privacy/security and integration with event management and other scripts.

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    I just upgraded a test install of my custom BP 1.1.3 version to WordPress 3.0. It went surprisingly well. I think everything works. I’ll test more over the coming days and will report back.

    If anyone else has the chance to try, please post your finding here…

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    Just created a group and a blog with 1.1.3 on WordPress 3.0. Still no problems so far. :-)

    Jeff Sayre, which parts of 1.1.3 will not work on WP 3.0?

    Paul Gibbs, can you point out which security holes have been fixed. Can’t I just patch them without upgrading to 1.2+?

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    Avatar upload seems broken. During the registration process I get this:

    “Upload failed! Error was: Could not calculate resized image dimensions”

    When I try again in an active user account, nothing happens at all. The page just refreshes when I try to upload a new avatar.

    Any suggestions where to start to fix this? Does WordPress have a new improved avatar upload function I could leverage?

    Avatar of dralamir
    Dralamir
    Member

    @dralamir

    Any idea whether it is a good idea to start with the newest releases of WP and BP and if upgrading into upcoming releases of BP would work smoothly? I’ve been waiting for WP 3.0 to arrive before creating my community site and I’m hesitant to jump with the current releases if the later versions are might not work straight off.

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    @dralamir, if you want to put bbpress forums at the center of your site, I would just follow the official releases. My test install of BP 1.2.5 on WP 3.0 worked fine.

    My custom site is build around groups, group blogs and P2 front end posting and I want to keep develop it along those lines. The biggest problem was changes in the avatar system. I managed to get that working fine by copying code from BP 1.2.5 following instructions posted here.

    Avatar of dralamir
    Dralamir
    Member

    @dralamir

    Cheers @peterverkooijen. I think I’ll try it out then. :)

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.