Skip to:
Content
Pages
Categories
Search
Top
Bottom

Email Notificaition Not Working

  • Avatar of sam_tots
    sam_tots
    Participant

    @sam_tots

    I have WPMU and Buddypress set up on MAMP, local testing environment. When I sign-up a new test user, and activation email does not get delivered. What needs to be done to get this to work. I obviously want to test it all before going live.

    I did get an email when the admin user was created in the intital install, etc…

    Any help! thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Xevo
    Xevo
    Participant

    @xevo

    Local and you can send mails? Unless you have a smtp your bouncing it off, that’s impossible.

    Otherwise, no idea.

    Hi.

    I have the same problem.

    I’ve set up a smtp and a pop server on local, as Sam has done.

    It means that I am able to send and receive e-mails using a virtual domain on my local server.

    I’ve installed:

    -WPMU

    -BP 1.1.3

    THE PROBLEM IS:

    When I register a new user using the regular sign up form, I receive the check e-mail message, but no message is sent to my mail account.

    I’VE TESTED the forgot your password WPMU function by using my admin account data to retrieve my e-mail and it works instead.

    So:

    1) Sign Up message does not work.

    2) Forgotten password message works correctly.

    The way I’ve done it is by creating a virtual domain directed to 127.0.0.1; and using it also as pop and smtp server address. Messages are received via that address by a SMTP/POP3 server installed on my PC.

    I can send e-mails using thunderbird (or any other e-mail client) without any problem.

    All this mess is working under Windows Vista and LAMP.

    Of course, I appreaciate any help.

    I’ve added this information in order to make more clear the first message on this thread.

    Thank you very much.

    I have tested the site and I’ve found that this is not a BP problem.

    I believe that the problem is caused because WP checks that the e-mail account is valid.

    Being a local/virtual domain, I think that WP does not find some kind of record (on Internet) and this avoids WPmu to go on with the sign up process.

    I will come back to share the solution when I success fixing it.

    Greetings.

    Ok. I’ve fixed it.

    The mailer checks the domain name used. I won’t exted on this issue.

    To let our local mailserver work correctly, we can do it by changing the validate_user_signup() function.

    This function is located in: /wp-signup.php file, check it at the line 267 or something similar.

    We must tell wordpress to consider valid our mail domain name without restrictions.

    This can be done by modifying the user account check line:

    We must replace the sentence

    if ( $errors->get_error_code() )

    by

    if ( $errors->get_error_code() && $_SERVER['HTTP_HOST']!=“localhost.YOURDOMAINNAME” ).

    Doing this, WP will accept any mail and user name if sent from our local domain.

    Notice that WP won’t warn us about any registration error by doing this.

    If you create by mistake an account, you can erase this sign up by editing the signup table in your wprss database using phpmyadmin.

    I hope it can help anyone else.

    When the BP plug-in is installed instead, I believe we should change the function bp_core_screen_signup() from the file: /wp-content/plugins/buddypress/bp-core/bp-core-signup.php in order to tell BP to accept our local mailserver in a similar way that the one described just before. Since I don’t need to do this for now, I haven’t written exactly the php sentences.

    Best regards.

    Avatar of oopp
    oopp
    Participant

    @oopp

    hello, i had same problem on buddypress plug in too.

    this is how I solved the problem.

    1. php.ini

    open php.ini , around line 1110 theres codes following.

    ; For Unix only. You may supply arguments as well (default: “sendmail -t -i”).

    ; http://php.net/sendmail-path

    ;sendmail_path = “”xamppsendmailsendmail.exe” -t”

    change only 3rd line

    ;sendmail_path = “”xamppsendmailsendmail.exe” -t”

    to

    sendmail_path = “”xamppsendmailsendmail.exe” -t”

    yes, it says unix only but it worked on my server (windows XP).

    and reboot Xampp or apache and try it.

    If you ste up xampp and still have problem try this out too.

    2. deactivate mailserver “Mercury”, and install another mailserver.

    I changed mailserver to ArGoSoft Mail Server.

    http://www.argosoft.com/rootpages/MailServerNetFree/Default.aspx

    you just need to set up only DNS server (router side) , your domain and user account.

    it was very easy even for me. so try it out!

    Avatar of abc30
    abc30
    Participant

    @abc30

    hello. I had same problem too.but i found a solution.

    this is the easiest and the most simple way to solve the problem.and it works perfectly.

    because this plugin is using gmail SMTP server.

    http://wordpress.org/extend/plugins/cimy-swift-smtp/

    downlod this plugin and upload in “/wp-content/plugins/”.

    and activate the plugin.

    this link below is way of setting.

    http://www.marcocimmino.net/wp-content/uploads/cimy_swift_smtp_122.png

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.