Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error 500 on fresh install of BP with WP3.0

  • Avatar of Laurent Alquier
    Laurent Alquier
    Participant

    @lalquier

    Something is going seriously wrong when I try to activate BP on a fresh WP3.0 blog (with PHP5.2.13 on Windows/IIS).

    Like a few others on this forums, I am experiencing a total breakdown of the WP admin interface when I try to activate BP.

    I found out how to enable error logging and found out a few interesting things in the logs.

    - BP relies on a global variable $wpdb as a glbal database object from WP, which seems to be missing from my blog (PHP notice: undefined variable wpdb).
    - I am getting additional notices from bp-loader, bp-core, bp-xprofile-classes.php and a few others.

    From the look of the errors, it seems that BP (or even WP) is not playing nice with PHP 5 (my log is full of warnings about the use of deprecated methods as well).

    Does anyone know if there is any known issue / special settings to make BP and / or WP run smoothly with PHP 5 ?

    I have not found anything on the subject yet but I am still looking.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    BP doesn’t play nice with IIS. Not with PHP 5.

    I haven’t read of the missing $wpdb variable before. Do you get any errors with just a plain install of WP 3.0?

    I Just installed a fresh copy of wp 3.0.1 and bp 1.2.6 and received a 500 error using

    System Linux
    PHP Version 5.2.12
    Server API CGI

    When I switch my php version to 4.4.8 buddypress installs fine then I switch back to 5.2.12 I start to get the 500 errors again.
    I am running this install on a shared hosting platform which I do not have access to the apache error logs to really figure this out. I was wondering if anyone else is having this same issue.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.