Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error Message Help! Making a theme BP compatible

  • Avatar of BW Marketing & Design
    BW Marketing & Design
    Participant

    @bwmarketingdesign

    I installed and activated the bp-template-pack and am on step three of Making Your Theme BuddyPress Compatible. When I got the following:
    Fatal error: Call to undefined function: bp_core_is_multisite() in /homepages/8/d212150488/htdocs/thebeerbuzz/wp-content/plugins/bp-template-pack/bp-template-pack.php on line 188
    Anyone have a suggestion of how I can create a fix?

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the same problem with theme “grid focus.”

    Any ideas?

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    I think bp-template pack is not compatible with mutlisite.

    I’m not using multisite.

    Anyone?

    Is the main BuddyPress plugin active? Which version are you using?

    @johnjamesjacoby We probably need to update Template Pack to check it works ok with the current point release, but as far as I know it still should work.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Silly question, but you do have BuddyPress activated on your site right? This is one of the first things that is fired when you have BP activated.

    *Edit – Paul, you’re one step ahead of me!

    Avatar of somoso
    somoso
    Participant

    @somoso

    i’m trying to install buddypress and i get this error on the bottom of my screen during step 3: “Fatal error: Call to undefined function bp_core_is_multisite() in /home2/ihearta1/public_html/wp-content/plugins/bp-template-pack/bp-template-pack.php on line 188″ Please help!

    Avatar of dains
    dains
    Participant

    @dains

    Welp, too late for the OP but in case anyone else gets this error when trying to get the BP Compatibility Pack working, here’s what fixed it for me.
    1. Multisite enabled on your WP installation. You need to add a line to your wpconfig.php file to do so (unless there’s an admin menu I’ve missed). Here’s the directions: http://codex.wordpress.org/Create_A_Network.
    2. Buddypress installed and activated. However, if you’re using the BP Compatibility Pack, it’s because you want to use your WP theme, so do not enable the Buddysite-specific theme.
    3. BP Compatibility Pack installed and enabled, then you can do the walkthrough to set up BPCP and you won’t get the error.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Walkthrough using BP Template Pack to make WP theme compatible

    http://codex.buddypress.org/theme-development/bp-template-pack-walkthrough-level-easy-2/

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.