Skip to:
Content
Pages
Categories
Search
Top
Bottom

Facebook Error

  • Avatar of Josh Frank
    Josh Frank
    Participant

    @iamjoshfrank

    When I try to add Facebook to my profile/stream by clicking on Authorize Facebook, I get a page with the following error:

    {
    “error”: {
    “type”: “OAuthException”,
    “message”: “Invalid redirect_uri: Given URL is not allowed by the Application configuration.”
    }
    }

    Any advice?

Viewing 20 replies - 1 through 20 (of 20 total)
  • Avatar of Josh Frank
    Josh Frank
    Participant

    @iamjoshfrank

    I was confused during the Facebook Create an Application step. On the Facebook side, I listed a directory and I think that caused the problem. I went back and created a new application at my site’s root, grabbed the new API and key, and now I am set.

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    Josh,

    I am going to be posting a walkthrough of the Create APP within the plugin… so is it importing for you now as well?

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Ok, I got past an issue by creating another site and discovered the cause of the above error I was receiving was that the website URL was incorrect. Once fixed to match the website name at which BuddyStream is installed I did receive the facebook page asking me to Allow the application to access my data. I click Allow and then get a white page with this in the address:

    http://the604adventure.org/?social=facebook&code=e36c042876e48a379674b54d-1352883706|BqdzXXFpXGqIB4JaCTSkbTBFjEI

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Thank you for the quick reply. I did all that. Can you review this http://the604adventure.org/phpinfo.php?
    I think all requirements are met, but you could probably tell quicker than me if possible.

    Also, twitter works just fine, facebook just gives me a white screen after clicking Allow.

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    On another bare bones site at demo.ardee.com I get the following when I click the link to Authorize with facebook. Does that help?

    Fatal error: Uncaught exception ‘Zend_Http_Client_Adapter_Exception’ with message ‘Unable to Connect to ssl://graph.facebook.com:443. Error #115406224: Unable to find the socket transport “ssl” – did you forget to enable it when you configured PHP?’ in M:websdemo.ardee.comwp-contentpluginsbuddystreamZendHttpClientAdapterSocket.php:235 Stack trace: #0 M:websdemo.ardee.comwp-contentpluginsbuddystreamZendHttpClient.php(969): Zend_Http_Client_Adapter_Socket->connect(‘graph.facebook….’, 443, true) #1 M:websdemo.ardee.comwp-contentpluginsbuddystreamclassesfacebookBuddystreamFacebook.php(161): Zend_Http_Client->request(‘GET’) #2 M:websdemo.ardee.comwp-contentpluginsbuddystreambuddystreamFunctions.php(743): BuddystreamFacebook->requestAccessToken() #3 [internal function]: oauthcheck(Object(WP)) #4 M:websdemo.ardee.comwp-includesplugin.php(473): call_user_func_array(‘oauthcheck’, Array) #5 M:websdemo.ardee.comwp-includesclasses.php(510): do_action_ref_array(‘wp’, Array) #6 M:websdemo.ard in M:websdemo.ardee.comwp-contentpluginsbuddystreamZendHttpClientAdapterSocket.php on line 235

    Avatar of Josh Frank
    Josh Frank
    Participant

    @iamjoshfrank

    @Pisanojm – I was able to set up the App through Facebook successfully, but my Facebook activity isn’t being imported to my Activity stream. I haven’t had a chance to verify my site meets all the requirements.

    Twitter importing is working like a charm!

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    @roydeanjr

    Looks like you are good to go on the PHP info… and you are using WordPress 3.0+ and BP 1.2.5.2+ and default theme for testing?

    That being said… you are having a pretty serious issue…
    Try making a New Facebook App.

    Be sure to make sure that you are including the Application ID and the Secret Key NOT-THE-API when you enter this in the back-end.

    Peter is reviewing your ticket to see if he can make anything out of the above…

    @iamjoshfrank This will be fixed in the upcoming release…. (Facebook import)

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    @iamjoshfrank Can you please elaborate what you did to fix the Facebook error? Was it simply a bad/wrong ID and Secret? Did you make a new one?

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Thank you for the reply. I was beginning to wonder if I was just being ignored. I appreciate you trying to figure this out. I do hope there is an answer.

    I will try what you suggest and let you know.

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Ok, created a new app . . just the two fields it asked for. All good on that end.

    Entered the two items mentioned and shown on the subsequent page. All saved.

    Went to my profile, settings, facebook, clicked on authorized with facebook. Got the Allow page. Clicked Allow and then this:

    Fatal error: Uncaught exception ‘Zend_Http_Client_Adapter_Exception’ with message ‘Unable to Connect to ssl://graph.facebook.com:443. Error #151276496: Unable to find the socket transport “ssl” – did you forget to enable it when you configured PHP?’ in M:websdemo.ardee.comwp-contentpluginsbuddystreamZendHttpClientAdapterSocket.php:235 Stack trace: #0 M:websdemo.ardee.comwp-contentpluginsbuddystreamZendHttpClient.php(969): Zend_Http_Client_Adapter_Socket->connect(‘graph.facebook….’, 443, true) #1 M:websdemo.ardee.comwp-contentpluginsbuddystreamclassesfacebookBuddystreamFacebook.php(161): Zend_Http_Client->request(‘GET’) #2 M:websdemo.ardee.comwp-contentpluginsbuddystreambuddystreamFunctions.php(743): BuddystreamFacebook->requestAccessToken() #3 [internal function]: oauthcheck(Object(WP)) #4 M:websdemo.ardee.comwp-includesplugin.php(473): call_user_func_array(‘oauthcheck’, Array) #5 M:websdemo.ardee.comwp-includesclasses.php(510): do_action_ref_array(‘wp’, Array) #6 M:websdemo.ard in M:websdemo.ardee.comwp-contentpluginsbuddystreamZendHttpClientAdapterSocket.php on line 235

    D – again – I had such high hopes that it was gong to work! Oh well, ’til next time.

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Is it really an ssl thing? The ssl port on the server is being used by mailserver.ardee.com rather than demo.ardee.com. Does that make a difference?

    The issue I have with myrelative.org is a bit different in that after Allow all I get is the white page. Is that also requiring the ssl port? O shall I try to create the app again?

    Avatar of Raymond
    Raymond
    Participant

    @twinfinity

    Great plugin !!!

    Authorize with Facebook, on the other hand doesn’t work. When I click the authorize with Facebook link, it just refreshes the page. Nothing else.

    I have ID and API keys correct. I have a Sociable Facebook Connect plugin on my site. It is for the Facebook App side of my site. I thought maybe it was blocking the BuddyStream plugin, so I deactivated it. There was no change, the page refreshed with no change in the authorization of Facebook.

    The users I tried to authorize are already authorized by Facebook and my site. FB ids are stored in the user table of my home db. I tried already logged in to Facebook and not logged in. Same result was the answer.

    I have a Wibya toolbar that has a Facebook comment publisher on it. when a user is connected to Facebook, to publish from the toolbar it is only a matter of pressing the connect button to login through Wibya. No connect or Facebook login screen appears. It logs you in directly because you are logged into the site.
    I will need this function on Buddystream if possible.

    Tweetstream logged in automatically ( there was no separate log in to post on twitter after initial authorization and log in to site ). I couldn’t never get Facestream to work, it always white paged, even with a new clean install. So, I don’t know exactly how Facestream worked, ie. as TweetStream did or not.

    Any help will be greatly appreciated .

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    @twinfinity I’m not sure what you have going on… You need to test this with the Wibiya bar off and your other plugins off… then make a NEW facebook ID app… you can have more than one. Make sure you copy the ID and keys correctly… no spaces after…

    Then… you will HAVE to reset a user from the admin to test this… that being said we are working on fixing the Facebook import problems that some users are having… expect a bug-fix release in 3-10 days… you might want to just wait for that…

    It would be next to impossible to connect the BuddyStream functionality to that of Wibiya’s….

    Facestream and Tweestream are deprecated… please make sure they are disabled. Much of the issues with those plugins have already been corrected in the current BuddyStream Beta.

    In a future release BuddyStream we will likely have Twitter Connect and Facebook Connect (and maybe other connects)…this is part of the overall plan for this plugin and will be one less plugin for you to need and possibly conflict with…

    We are actively seeking funding for the continuation of this plugin… please consider donating to our startup of this plugin. Also, very specific requests can be initiated and funded by contacting us at BuddyStream.net. All client funded upgrades and developments will be released to the general public in the next update of the plugin when finished…but client funded requests will get a priority in development and the integrations they are looking for… this plugin is in the early BETA process and may not be suitable for some live sites yet.

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    @roydeanjr I’d love to be on here 24/7 answering questions… but it’s just one super-small part of what I do… I’m still waiting to see what @blackphantom thinks about the above…

    In the meantime you can check this:

    http://www.kernelbd.com/blog/php-scripts/php-fsockopen-openssl/

    You may have to try recompiling your Apache to include the mod-ssl and curl with ssl options… If you are unfamiliar with this… send the above link to your Host and see if they will check in to it for you… Please let us know the results…

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Ok, I appreciate that.

    I am hosting these sites on my own Windows 2008 server with wamp installed alongside IIS7 for Exchange Web Access. There might be a conflict there, I don’t know for sure. I will check when I learn how to verify the installation. Everything seems to work with the exception of the facebook hookup.

    I did test on another site that is on a unix server and it almost works, but not completely. I will post some of those anomalies in the support section of buddystream.net.

    Thanks for the suggestion.

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    Ok… I think the oAuth errors are corrected… let’s see what version 1.02 does for you… should be available in a couple of days…

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Looking forward to it! Thanks.

    @iamjoshfrank @Pisanojm

    Hi,

    I had the same error as describe in the first post. To fix this, I had to configure my website link in FB app.

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Not sure what exactly fixed this, but I for sure did the following and oauthcheck error no longer occurs:
    1 – uninstalled wamp
    2 – installed xampp
    3 – reset all other web servers to different ports so xampp runs on 80 and 443
    4 – open ports 80 and 443 through the windows firewall
    5 – authorized httpd.exe as a server program in the windows firewall
    6 – entered facebook API key and secret
    7 – visited profile/settings/facebook/Authorize with facebook and returned to the facebook settings page to save the settings.

    All ok, close this issue.

Viewing 20 replies - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.