Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fatal Error activating Invite Anyone

  • Avatar of mikehenrysr
    mikehenrysr
    Participant

    @mikehenrysr

    When I activate the plugin, I get the following error.

    Fatal error: Call to a member function get() on a non-object in /home/leadchg/public_html/wp-includes/query.php on line 27.

    I also get it (or something like it) when I try to load the site from scratch. When I delete the plugin everything works just fine again.

    I’ve had the problem for a couple of versions and I figured .0.9.3 would fix it so I hadn’t reported it until now. I’m running WP 3.1.2 running the following plugins:

    AddThis, Akismet, Author Avatars,
    Buddypress, Buddypress Links, Buddypress Group Management,
    Buddypress Humanity, Buddypress Shareit,Buddypress Verified
    Comment Reply Notification, External Member Blogs, Google Analytics for WordPress,
    Grab and Save, Gravity Forms, nRelate, S2Member (Pro), SI Captcha,
    The Events Calendar (with Eventbrite Add On),
    User Role Editor, W3 Total Cache, Welcome Pack, Woopra,
    WooTumblog, WordPress.com Stats, WordPress SEO by Yoast,
    WP Mail SMTP, WP Render Blogroll Links, and WP Smush It.

    Any ideas? If not, I’ll disable everything this weekend and put them back one at a time and see what happens. I just thought I’d try this route first. Thanks for a great plugin.

    Mike…

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    I haven’t seen this exact problem, but I do know that it’s an ugly WordPress bug that is causing it. Am I correct in assuming that you see this error on the Dashboard only? That is, does the public side of your blog load OK?

    I’ve been meaning to send a patch to the WP folks to fix this, but it’s a pretty complicated problem, so I’ll probably have to find a stopgap solution. I’ll let you know what I can figure out.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Also, can you tell me your WP/BP versions?

    Avatar of James Thomson
    James Thomson
    Member

    @james-thomson

    @Boone I see this hasn’t got a response from the original poster. I’m getting the same error message, would like to use the plugin so am happy to provide you as much information as you need to fix it.

    To start with, I’m running a WPMU installation v3.3.1 with Buddypress v1.5.4….

    Can I do anything else to help?

    Thanks.

    I get this error too, but it affects the front end too. I’m using WordPress 3.3.2. BuddyPress Version 1.5.5
    The error made it difficult to uninstall the plugin too – had use the file browser to go into wp-admin/plugins/ and delete the invite-anyone folder (just in case anyone is stumped). WordPress gave a little message saying the plugin had been deactivated because the files were gone, but all seems to be working now.

    Avatar of dlangford
    dlangford
    Member

    @dlangford

    I have the same problem and am using WordPress 3.3.2. BuddyPress Version 1.5.5. Thanks for the deletion tip.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.