Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum Integration…

  • Avatar of Hempsworth
    Hempsworth
    Participant

    @hempsworth

    Hi all,

    I’m using WPMU 2.8.1, BuddyPress 1.0.3 and bbPress 1.0.1.

    I’ve installed WPMU, which is working fine, and then integrated bbPress, which is also working fine. I’ve done all of the integration settings, and mapped the following user roles:

    WP Admin -> bbPress Key Master

    WP Editor -> bbPress Moderator

    WP Author -> bbPress Member

    WP Contributor -> bbPress Member

    WP Subscriber -> bbPress Member

    I’ve then installed BuddyPress, and everything works fine; until it gets to forums! I entered all of the forum information in ‘Forums Setup’ under BP, but when I get to creating a group and trying to add forums to it I get the following message:

    Attention Site Admin: Group forums require the correct setup and configuration of a bbPress installation.

    What could I be doing wrong?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of Hempsworth
    Hempsworth
    Participant

    @hempsworth

    The same happens even when I haven’t mapped any user roles by the way :)

    Avatar of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    I am still on 2.71 and 1.01 so can’t help directly with version issues but have you definitely put the correct details in the Forums Setup within the BuddyPress dashboard area?

    Avatar of josemv
    josemv
    Participant

    @el_terko

    To begin with, I would start by following these tutorials:

    http://buddypress.org/forums/topic/bp-103-and-bbpress-which-version-plugins-cookies

    http://theeasybutton.com/blog/2009/07/17/integrating-buddypress-wordpress-mu-and-bbpress/

    BTW, regarding user mapping, the only setting I changed was WP Admin one, mapped to bbPress Key Master. The other four settings remain untouched.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    WPMU 2.8.1 and BuddyPress 1.0.3 have a few issues at the moment. Would be best to use WPMU 2.7.1, or wait until 1.0.4 is released.

    If you need to use 2.8.1, then as much as I usually never like to say so, you might be better off using the latest trunk version. I’ve been running it for a few days now fully integrated with no issues that are obvious or apparent.

    My recommending to use the trunk always comes with the assortment of warnings that it might be broken in some places or unfinished in others, so be careful of that too. Trunk versions aren’t really meant for public use, but it seems everyone is becoming more comfortable doing it recently.

    Also, for group forums to work, your hosting package must allow for XMLRPC, as well as having them both turned on in each *press platform. More than likely something is out of alignment somewhere and even though you swear it’s not, it really is. :)

    Avatar of Hempsworth
    Hempsworth
    Participant

    @hempsworth

    Thanks for your help – I didn’t realize extra steps were required! Got it working using the tut on ‘The Easy Button’.

    Avatar of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    That Easy Button tutorial is great and Chris replies with great comments really quickly.

    Avatar of Doug Daulton
    doug.daulton
    Participant

    @dougdaulton

    @hempsworth – I expanded on the previous tutorials here:

    http://www.dougdaulton.com/2009/06/26/complete-bbpress-integration-for-buddypress/

    This was done with SVN checkouts just before the most current stable builds, so there may be conflicts, but it steps you through a things that were unclear in previous walkthroughs.

    Let me know if it helps.

    Doug

    PS: Upon reread, I just realized that the Easy Button tut is newer and probably more accurate than mine. Will need to do an update. :)

    Avatar of gerikg
    gerikg
    Participant

    @gerikg

    I had the same problem. I also refused to use a version that is non stable.

    I read everything over and over. Mostly everything point to three major “integration” blogs.

    I almost gave up until I was looking at my FTP and noticed the read “installation-readme.txt” in the bp-forums folder in BuddyPress plugin.

    This line—-> Also check the “Enable Pingbacks” option just below.

    That’s the only thing that wasn’t in the instructions. I enable in both WPMU and BBPress and it worked!

    Avatar of Creative Vibrations
    Digital Soup
    Participant

    @peterjeshua

    I have bbPress installed here: http://students.expression.edu/forums. I’m trying to integrate into BuddyPress. Where is “Forums Setup”? It’s absolutely not under my Site Admin sidebar in the dashboard for BuddyPress.

    Avatar of Creative Vibrations
    Digital Soup
    Participant

    @peterjeshua

    Okay… I re-uploaded the BuddyPress plugin. Maybe I was out of sequence where I did bbPress last instead of the BuddyPress plugin last on my install? Who knows, but now the elusive “Forums Setup” is showing up where it should in my Dashboard.

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.