Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forums setup is empty

  • Hi, after installing Buddypress on a single WP with a Buddypress supporting theme (came along in the budypress download) I was installing/setting up the Forums Setup. This couldn’t go automaticly, so it said:

    “A configuration file could not be created. No problem, but you will need to save the text shown below into a file named bb-config.php in the root directory of your WordPress installation before you can start using the forum functionality.”

    I didn’t know where to find this file (what is a root directory?) and my provider said it was the httpdoc folder. So I created a new php file with the text shown and uploaded it into that folder. Now, when I go to Forums setup it says:

    “bbPress forum integration in BuddyPress has been set up correctly. If you are having problems you can re-install
    NOTE: The forums directory will only work if your bbPress tables are in the same database as your WordPress tables. If you are not using an existing bbPress install you can ignore this message.”

    Below this text there is nothing to see or do. IS this correct or not? Somewhere I need to setup the forums don’t I?

    Any reply is welcome, the more the better. A Dummy like me needs that :-(

    Thanks

Viewing 21 replies - 1 through 21 (of 21 total)
  • Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    I guess It is correct. Go , create groups and check forum is active or not, that would be the best thing for you.

    Avatar of Patrick
    Patrick
    Participant

    @sagelives

    I am having the same issue. Followed all of the install steps for WPMU & Buddypress. Activated bbpress from within Buddypress. Says it was successful and everything else works fine.. except no forums. I have the link but just get the white page of death. Same happens when I try and access from groups. Anyone have an idea what the issues is?

    Well, I can create groups, and add topics on the forum on the front side. But on the dashboardside there is just nothing in the Forums Setup page. Somehow I need to be able to adjust if a member may or may not comment in a forum that is not his group and all that stuff. And for that forums setup page is empty my question is: Is this normal? What do you see when you select Forums Setup in the Buddypress menu in the Admin panel? (after complete install)

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    @sagelives
    Can you provide the error log. That can help to resolve the issue for you.
    @quirhijn
    It means forum is working well for you. Yes, that is normal. Once setup is complete you will always see “forum is successfully installed, if you have trouble….” message.
    To disable activity commenting on forum post, go to wp-admin->BuddyPress->general settings.
    And if you are expecting a forum backend, Internal bbpress setup for buddypress does not provide that.

    thx

    Avatar of Mika H
    Mika H
    Participant

    @suprmario

    I´m getting a blank page also when trying to set up the forum part of the buddypress.
    First i get this message:
    http://yfrog.com/5sbuddy1j

    Then i reinstall and follow the steps to come to this:
    http://yfrog.com/0zbuddy2lj

    As you can see, i cant make any groups or nothing in the setup, any suggestions what i can look for?

    Regards

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @suprmario-

    The screenshots that you linked to are normal. You mention that you are “getting a blank page … when trying to set up the forum.” Where is this blank page?

    BuddyPress uses an internal install of bbPress. It allows you to add forums to groups. It does not create a sitewide forum. To see the forum in a given group, the “Enable discussion forums” checkbox must be checked in each group’s admin panel.

    Avatar of Mika H
    Mika H
    Participant

    @suprmario

    Thanx for reply

    When i go to: Buddypress>>Forums Setup
    I cant do anything there, shouldnt i be able to set up all the forums there or have i missed where to do this?

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    hi Mika
    As Jeff says above, you have done everything correctly.

    In buddypress forums are associated with groups. To enable forum for a group, go to any group->admin->settings and enable forum for the group.
    You don’t need to do anything with forum setup, as forum is already setup correctly. Just go and enable it for groups.

    Avatar of Mika H
    Mika H
    Participant

    @suprmario

    Hi again

    Sorry to be stuborn but cant find anywhere where to set up groups…
    Anyone?

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    No prob :)
    Please Go to your site. When you are logged in and are visiting the group directory[Yoursite->groups] you will see an option to create Group.
    create group and you will see the option to enable/disable forum while creating group.
    If you have existing group, go to group page->Click on Admin button, In the settings submenu you will see the option to enable enable/disable forum.
    hope it helps.

    Avatar of Patrick
    Patrick
    Participant

    @sagelives

    @sbrajesh

    @jeffsayre

    Okay I did the internal install of bbpress and it said successfully installed. I have a group and in the group admin the enable forums button is selected. When I click on forum I still have a blank page.

    Any advice?

    Avatar of Mika H
    Mika H
    Participant

    @suprmario

    HI again and thanx for supporting,
    I really dont see where u say i can find the ” groups” in my admin panel of wordpress site.
    See picture, where should i go exactly to find this though i cant find anything in the logical place for me to look, as in “Buddypress>>Forums setup”

    see picture:
    http://yfrog.com/jqwpproblj

    Please advice.

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    @sagelives Try deactivating and activating forum for the group again(from Group->admin->settings), sometime It happens, If it is not solved, please do provide errorlog

    @supermario
    It is not available in the wp-admin. Check the front end of your site. If you are using bp-default theme, you will see a group link in the top menu . Click on that and you will see options to create.

    Avatar of Mika H
    Mika H
    Participant

    @suprmario

    ok, i looked on the frontend of the site and have the buddypress menu on the top.
    ” My account, notifications, Chat “

    Under ” my account ” i have “groups”>>my groups and invites

    If i go to “groups” i cant find a way to create any group either.
    See picture: http://yfrog.com/3zwpprobl2j

    But where can i create groups?

    thanx in advance

    Avatar of Brajesh Singh
    Brajesh Singh
    Participant

    @sbrajesh

    ok, I see you are viewing your own profile. I am not aware of your site.
    So, replace yoursite.com with your site name in the link and try this link

    http://yoursite.com/groups

    I mean append “/groups” in the url of your site and you will see the group directory.You can create groups from the group directory link. There should be option for that.

    Avatar of Patrick
    Patrick
    Participant

    @sagelives

    Okay I got it to work!

    Here is what I did:

    1) Deleted bbpress everywhere.
    2) Removed everything bb from my database.
    (bbpress inside buddypress wasn’t adding tables for some reason)
    3) Removed bb-config.php
    4) Loaded new bbpress install in htdocs
    5) Installed bbpress and changed bbpress folder name to forum
    6) Loaded new bbpress into plugins/buddpress/bp-forums
    7) Used Buddypress – Forum Set Up in Dashboard to set up bbpress.
    **still mia**
    8) Went to Groups>Admin – Turned “Enable Forums” off refreshed then “Enable Forums” back on and refreshed.

    BINGO! It’s working.

    Avatar of Mika H
    Mika H
    Participant

    @suprmario

    Found it, thanx for info all. Will try to configure now.

    regards

    Avatar of Mika H
    Mika H
    Participant

    @suprmario

    I really dont understand though why have to set up some groups to set up a forum on the site, is there a logical explanation for it?:-)
    When i go to “buddypress>>forum setup” it´s still empty and no forums there to configure.

    I dont know – have to sleep on this to know what to do

    Avatar of josemv
    josemv
    Participant

    @el_terko

    Do not worry, I don’t understand it either.
    To have standalone forums, you have to mess with a standalone bbP installation, which I think will be less integrated than the default groups+forums setup.

    I am not sure, but with previous BP versions you could have standalone forums AND group forums, visualized all together. How I miss those days…
    Several coders such as @nuprn1 and @sbrajesh have expressed intentions of developing plugins/hacks for standalone forums for the actual BP versions.

    Avatar of Scott
    Scott
    Participant

    @brownbuc

    in response to the original poster. how do I place that file in my wordpress root directory, and where is the directory?

    Thanks

Viewing 21 replies - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.