Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fresh New Install Error 404 Not Found

  • I’m sorry for posting this but I haven’t found an adequate answer to the problem. I keep getting 404 Errors for all of the urls with the exception of the blog but even that seems to be having some problems.

    404 Not Found

    The requested URL /members does not exist.

    To see it : http://www.sportssonet.com

    I have uninstalled/reinstalled over a half dozen times.

    Any help would be greatly appreciated.

    Thank you so much!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Do you have an .htaccess file?

    Yes

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you using the included bphome theme? Which links specifically are or are not 404′ing?

    Yes I’m using the bp home theme (see link in first post) and all the links are 404ing.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Not all of them..

    http://www.sportssonet.com/?p=1

    http://www.sportssonet.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.sportssonet.com

    It’s just the BuddyPress ones. Does your theme have the functions.php that came included with the bphome theme still there?

    Can you copy/paste the contents of your .htaccess file here within code tags? Also, what are your permalink settings set to, or are they still just the default?

    Yeah I adjusted the permalinks for the blog other wise it nothing worked. It was on custom structure (/blog/%year%/%monthnum%/%day%/%postname%/) when I changed them to the default.

    Yes the functions.php file is located at wp-content/themes/bphome/.

    htaccess file:

    # Use PHP5 as default

    AddHandler application/x-httpd-php5 .php

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    That’s your problem.

    Take the contents of your .htaccess-dist file, and put that at the end of your existing .htaccess file.

    There also seems to be a htaccess.dst file contents below:

    RewriteEngine On

    #RewriteBase BASE/

    #uploaded files

    RewriteRule ^(.*/)?files/$ index.php [L]

    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteCond %{REQUEST_URI} ^.*/wp-admin$

    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule . – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]

    RewriteRule . index.php [L]

    <IfModule mod_security.c>

    <Files async-upload.php>

    SecFilterEngine Off

    SecFilterScanPOST Off

    </Files>

    </IfModule>

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    That’s what I meant. Take all that stuff, and put it at the end of your .htaccess file. Should work like magic then.

    SWEET JEBUS! That did the trick!

    I can’t thank you enough JJJ

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    You’re welcome. Flip the switch up top to resolved and we’re good to go until next time. :D

Viewing 11 replies - 1 through 11 (of 11 total)

The topic ‘Fresh New Install Error 404 Not Found’ is closed to new replies.