Skip to:
Content
Pages
Categories
Search
Top
Bottom

GD library

  • I have set up BuddyPress and it’s 99% working perfectly! Just one problem… with the images.

    When we upload an image, we see it straight away and we can resize it. But then after the resizing/cropping, the image turns into a small grey box. :(

    I went to “view image” to see the path (I thought it might be a permissions issue) but I saw it simply links to “The GD image library is not installed”.

    I guess the problem is I do not have the GD Image Library installed on my server? :)

    Can anyone advise me how to fix this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • To clarify, it’s only a grey box in firefox. It’s a broken link icon in other browsers. Basically the site is linking to “mydomain.com/The GD image library is not installed” instead of the image file.

    Also to clarify, the image is actually there on the server, uploaded correctly. It\’s been uploaded to mydomain.com/wp-content/blogs.dir/1/files/avatars/1/photo.jpg

    Most likely I just need to install the GD image library thing. Can anyone advise how? I am running PHP Version 5.1.6.

    If your web server is hosted, talk to your host.

    If it’s your own server – what OS are you on? Reinstalling PHP to support GD is pretty much beyond the scope of this forum, but we might be able to point you in the right direction

    It\’s a dedicated server (Linux/CentOS). The support they offer is truly awful so I really hope you can help me.

    I’ve uploaded a myphpinfo.php file with the <?php phpinfo()?> command. It told me (among other things):

    GD Support enabled

    GD Version bundled (2.0.28 compatible)

    FreeType Support enabled

    FreeType Linkage with freetype

    FreeType Version 2.2.1

    GIF Read Support enabled

    GIF Create Support enabled

    JPG Support enabled

    PNG Support enabled

    WBMP Support enabled

    XBM Support enabled

    So it looks like it *is* enabled.

    What I don\’t understand is why the script links to an error message \”mydomain.com/The GD image library is not installed\” without even trying the actual file. The file is there on the server.

    What are the permissions, owner/group of your /wp-content/blogs.dir/ folders? The user the webserver is running obviously needs to have access.

    It works now. I had to enable the GD library *and* re-upload the pics.

    Thanks for your help.

    good job

    To clarify for future questions around this area: did you have GD disabled, then you enabled it, and then you also had to re-upload the pics?

    Or did you just re-upload the pics without making *any* changes?

    I didn’t have GD enabled to begin with. I enabled it, restarted the server, then reuploaded the pictures. :)

    Ah hah :)

Viewing 9 replies - 1 through 9 (of 9 total)

The topic ‘GD library’ is closed to new replies.