Skip to:
Content
Pages
Categories
Search
Top
Bottom

General Settings Change Password Broken

  • Avatar of Svenl77
    Svenl77
    Participant

    @svenl77

    I don’t know why, all is running well.

    I just have a big problem with changing the password.

    If I try to change my password under

    My Accound

    -Settings

    –General

    after pressing ‘save changes’, i just get a blank page.

    The General Settings page is not in the member theme. it is in the core so I don’t know why i get this error.

    Somebody any idea what to do ?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    bp, wpmu versions. themes being used?

    Avatar of Svenl77
    Svenl77
    Participant

    @svenl77

    bp 1.0.1

    wpmu 2.7.1

    my own theme based on the bpmember from a earlier version of bp.

    But I did al needed changes with every update, so the theme works all around. just this part is lost and I don’t see the bug in the theme, because there is no template file for the general settings page. or I don’t know…

    Test with the default home and member themes – does the problem still occur?

    Avatar of Svenl77
    Svenl77
    Participant

    @svenl77

    yes, still occurs…

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    A blank page is an error happing. Check your error logs.

    Avatar of Svenl77
    Svenl77
    Participant

    @svenl77

    Hi Burt Adsit, here the error, i just don’t know what to do with it….

    [Sat Jun 20 21:00:59 2009] [error] [client 62.143.147.16] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer: http://rheinrauschen.de/members/svenl77/settings/general

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Do you have any plugins other than BuddyPress installed and activated. If so, you need to distill your environment down to the lowest common denominator: Use the default BP themes that come with v1.0.1 and deactivate all other plugins.

    What happens then? If you do not have any more issues, then you know it has something to do with your custom theme, one of the plugins, or some combination.

    You then start going back up the ladder one step at a time. Switch the default BP themes for your custom themes. Does the problem return? It not, then is has to do with your plugins. Activate one plugin at a time until the issue returns.

    Here’s a thread where Paul talks about a similar error message and plugins: http://buddypress.org/forums/topic.php?id=2802#post-15313

    Let us know how your testing goes.

    Avatar of Svenl77
    Svenl77
    Participant

    @svenl77

    hi Jeff Sayre, I did the hole thing…. but I still can’t change the password.

    I copied the db and data to a new working domain for messing around.

    I switched to the default home and member theme. Turned off all plugins and deleted all mu plugins.

    Any idea? the rest of mu and buddypress is doing his job correct…..

    Avatar of Svenl77
    Svenl77
    Participant

    @svenl77

    Ok, I really want to know it. It is already a test for me.

    What, if this happens to me on a live site. I want to handle this error without loosing the running installation.

    I deleted all buddypress files and renewed all with a fresh download of buddypress. The error is still there.

    The same I did with mu. I deleted all mu files except the wp-content folder.

    but the error still accursed.

    So I think it must be the db.

    I tried to change my password from the admin aria, there I can change my password without problem.

    But from the profile site, I get a blank page.

    Some idea ?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Okay, since this seems like a test site, I would start from scratch and test one more time. This caught me eye:

    I copied the db and data to a new working domain for messing around.

    If you are going to start from scratch, you need to get rid of everything. This means dumping the MySQL DB and creating a brand new one. Do not import your old data into the new DB. There could be something in the DB that is causing this issue–that is my guess.

    BUT–emphasis added on purpose–please keep a copy of your old database if there is data you need to save. If not, then just get rid of it all together.

    So, with a brand new install of everything–new blank DB, WPMU, BP, default BP themes, no other plugins–how do things work?

    Avatar of Svenl77
    Svenl77
    Participant

    @svenl77

    I found the problem, but I do not understand it.

    Could somebody please give me some information about way it is working now?

    If I go to wp-content/plugins/buddypress/bp-core/bp-core-settings.php

    on line 27 an comment out require_once( WPINC . ‘/registration.php’ );

    All is running without error.

    I can change my password.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.