Skip to:
Content
Pages
Categories
Search
Top
Bottom

Gpress PHP warnings

  • Avatar of Anton
    Anton
    Participant

    @antonrsa

    When I activate the Gpress plugin I get tons of PHP warnings in the dashboard.

    Warning: Invalid argument supplied for foreach()…
    Warning: uasort() [function.uasort]: The argument should be an array in…
    Warning: Invalid argument supplied for foreach() in…..
    Warning: uasort() [function.uasort]: The argument should be an array in….
    etc, etc

    All these errors seems to be generated by the tpp_options-class.php

Viewing 14 replies - 1 through 14 (of 14 total)
  • Avatar of Mark Smalley
    Mark Smalley
    Member

    @msmalley

    Sorry about that – I do not have the same errors on either my local or online test-bed.

    Could you provide a copy and paste of the errors, screen-shot, or something a bit more for me to investigate…?

    Avatar of Anton
    Anton
    Participant

    @antonrsa

    Thanks @msmalley – here’s all the errors – http://pastebin.com/zutNjTku

    Avatar of Mark Smalley
    Mark Smalley
    Member

    @msmalley

    Just to confirm, are you running into any other problems are a result…?

    Does everything else with gPress appear to work…?

    Do you happen to know what server, version of PHP and MySQL you are running…?

    Is this a local, online (or both) problem…?

    With single blog set-up or MS set-up (and if MS, on Blog ID 1, others, or all)…?

    Avatar of Anton
    Anton
    Participant

    @antonrsa

    Nope doesn’t work and it is online running on normal WP

    Avatar of Mark Smalley
    Mark Smalley
    Member

    @msmalley

    If I was able to re-create the problem I could help debug it myself.

    Have you tried the “emergency Foursquare deactivation” …?

    The only thing I can think of at the moment is Foursquare, as I must admit that the libraries used by Foursquare for their oAuth are VERY unstable and require lots of different server configurations – they may not work well on Windows Servers, or without the right CURL settings and other stuff I do not know much about, so any help on this matter would be HUGELY appreciated…

    The emergency Foursquare deactivation can be set in “gPress Options > Advanced Settings > MISC Settings” – if this doesn’t help, I may need to get access to the server / control panel if you are still interested in trying to solve the issue – unless anyone else having similar problems is able to provide some insight…?

    Avatar of Mark Smalley
    Mark Smalley
    Member

    @msmalley

    Could you please confirm if this has been resolved or not with the recent versions of gPress…?

    Avatar of Travel-Junkie
    Boris
    Participant

    @travel-junkie

    Well, I’m having the same errors, but they have nothing to do with the 4square options (don’t even know what that is :), but all to do with the latest SVN of BP, especially the way page creation is handled. Everything works fine with BP < 1.3-bleeding. The latest BP SVN throws the uasort errors on my test install.

    Avatar of Mark Smalley
    Mark Smalley
    Member

    @msmalley

    The joy! Something new to test… Yay! :-)

    To be honest, I think I am going to have to wait until 1.3 goes LIVE before worrying about it, as I really do not have time to download and install bleeding edge versions prior to their features and functionality being set in stone – but nonetheless, thanks for the warning and feedback.

    If you are able to isolate where the problems are coming from, I may be able to preemptively help, otherwise I’m afraid you’re going to need to wait until 1.3 is stable…

    Avatar of Anton
    Anton
    Participant

    @antonrsa

    @msmalley – Still getting the same errors with the latest version of gpress. Will wait until 1.3 is out and test again.

    Avatar of Anton
    Anton
    Participant

    @antonrsa

    @msmalley Seems as thought 1.3 is quite far away. Still getting those errors

    I’m interested to know why, as no one else has reported them and I myself have not seem them on anything of my demo sites. The only thing I can think of is the Memory Limit.

    Do you have the following in your wp-config.php file…?

    `
    define(‘WP_MEMORY_LIMIT’, ’64M’);
    `

    If not, please do so, and see if that helps, otherwise we are going to need to find out what is unique about your set-up and work from there…

    Forgot to mention you – @antonrsa – try the following:

    `
    define(‘WP_MEMORY_LIMIT’, ’64M’);
    `

    Add it to wp-config.php

    Avatar of Anton
    Anton
    Participant

    @antonrsa

    @msmalley – still getting those errors. Added the memory limit to wp-config.php

    When activated and on the dashboard settings for Gpress it gives this error as well: These options are only available to super admins

    @antonrsa – I’ve got to be honest; I’m running out of ideas – sorry :-(

    Neither my online or local set-ups run into this problem and don’t know how else to test…

    It simply has to be something in your environment, and without knowing what, I can’t re-create the problem and trouble-shoot it…

Viewing 14 replies - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.