Skip to:
Content
Pages
Categories
Search
Top
Bottom

Great new version!! But New user email password "still" does not work : (

  • Avatar of dlittle800
    dlittle800
    Participant

    @dlittle800

    LOVE new version 1.2, but….

    Login password “still” does not work in 1.2 – just like it didn’t in the previous version 1.1.3.

    No point in reporting it as a bug since I already did so for the previous version

    Here’s the sign-up email…


    Dear User,

    Your new <domainname.com> blog has been successfully set up:

    <domainname.com/blog>

    You can log in to the administrator account with the following information:

    Username: xxxxxxxx

    Password: fbff9b74 <<<


    What is this? Where does it come from? It does not work! (Just like 1.1.3)

    LOGINLINK <<<


    There’s no login link

    We hope you enjoy your new blog.

    Thanks!


Viewing 25 replies - 1 through 25 (of 36 total)
  • Avatar of stwc
    stwc
    Participant

    @stwc

    I assume that people told you this before when you reported, but just in case: this is a WordPress issue rather than a Buddypress issue, I’m pretty sure.

    Reporting the bug here won’t help much — if nobody has an answer on the forum here, you’d be better off seeking some help through the WP/WPMU support system.

    Exactly. I believe this to be off-topic, but try disabling BuddyPress. If the issue still occurs, then it’s a WordPress problem. If it only breaks *when* you enable BuddyPress, file a report on http://trac.buddypres.org/ using your username and password from this site.

    Avatar of Mike Pratt
    Mike Pratt
    Participant

    @mikepratt

    Please correct me if I’m wrong, but that email is no longer sent by BP is it? You set your own password in the sign up process and BP no longer emails passwords (there has been a few threads arguing with Andy over the merits of this but that’s a diff topic)

    Which certainly means it’s WPMU sending the email. Question is why, I guess.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    This should not be happening, and it is not happening on my test installs. Try this on a fresh installation (and database) and try again.

    Avatar of jfigura
    jfigura
    Participant

    @jfigura

    This has been happening with me, repeatedly, on fresh installs and databases with all versions since 1.1.3. I tried to find help with this at WPMU Dev who told me it was a BP issue.

    This does not happen to me on standard WPMU installs.

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    It has happened to me before, so I’ll put it on my “to test” list.

    BuddyPress totally overrides this email. Something is not right on your install. Anything in your error log?

    Avatar of jfigura
    jfigura
    Participant

    @jfigura

    There are no issues in my logs

    Avatar of Mike Pratt
    Mike Pratt
    Participant

    @mikepratt

    like DJPaul said, BP does NOT send you a password via email

    Avatar of dlittle800
    dlittle800
    Participant

    @dlittle800

    It sure would be great if WPMU sent the BP password created at new user sign-up.

    Is there any hope for making that happen in the future?

    >>The folks at WPMU tell me I’ve got a BP problem and vice-versa : (

    Avatar of jfigura
    jfigura
    Participant

    @jfigura

    @ Mike Pratt — I honestly don’t care if BP sends the email or not. The issue here is that BP DOES override the password by allowing the user to create their own. Therefore, either BP needs to remove this feature and allow WPMU to set the passwords, OR, BP needs to override the email itself with the correct password that the user selected.

    Having a user create a password then receive an email with a random generated one is confusing.

    Avatar of Mike Pratt
    Mike Pratt
    Participant

    @mikepratt

    @jfigura I agree. That would be maddening in addition to confusing! The point we’re trying to make is that BP lets you set your password. That’s it. No email. Just login after you activate. When WMU sets the password, you have to wait and hope it wasn’t caught in spam and all the other associated issues. If you are receiving the email then something isn’t working correctly for you.

    My own opinion is this way is much better (what are the chances you immediately forget the password you chose?) I hate it when I get generated passwords as I then have to go in and change them all over again.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    http://trac.buddypress.org/browser/trunk/bp-core/bp-core-activation.php#L79

    There are two ways for this email to still get sent:

    1.) Your active theme does not have either /register.php or /registration/register.php in it.

    2.) You are an admin that has just added a user to your site.

    If either of those things are true, the email will get sent out.


    If you are hard pressed to make this issue go away, try adding this to your functions.php or bp-custom.php.

    /* Unhook BuddyPress wpmu email blocker */
    remove_filter( 'wpmu_welcome_user_notification', 'bp_core_disable_welcome_email' );

    function block_wpmu_email() {
    if ( is_admin() && $_GET['e'] )
    return true;

    return false;
    }
    /* Rehook custom function */
    add_filter( 'wpmu_welcome_user_notification', 'block_wpmu_email' );

    The above routine doesn’t help us test this issue any, but it does stop the email from going through unless you add a user yourself.

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    I always use the confirmation emails in my inbox as a way to keep track of passwords I used on sites I signed up with. Sending the login credentials in a confirmation email, including the password, serves a real purpose. That’s why most websites still do it that way.

    I understand there are security objections to sending out passwords, but I am not running a banking site. Making it easier for members to access my site is a higher priority. Not being able to send them the password in a confirmation email is very annoying.

    Also, if you run a community that actually does stuff, like organize events, you want to send new members a friendly welcome mail with some practical info. Why the hell disable the welcome email as a “core feature”?!

    Avatar of abcde666
    abcde666
    Participant

    @erich73

    @Peter

    totally agree !

    How is Fakebook running this process ?

    Avatar of jfigura
    jfigura
    Participant

    @jfigura

    @ John – Wouldn’t it be easier to just remove the “PASSWORD” reference in the WPMU email signup options? It could be amended with “Please use password you created at time of sign up.”

    @Mike – Ok if something is working correctly, then where does one begin to try and figure out the problem? There isn’t any option available to an admin to turn these emails off, only to manipulate what the email says. In that case I am assuming it is making a call to the database for the password which is somehow getting read wrong. But then again I am new enough to WPMU and BP not to know where to yet look to solve the issue.

    I REALLY want to use BP and WPMU, but I am finding so many quirky things. Especially with the templates at WPMU DEV, what a waste of money that was.

    Avatar of dlittle800
    dlittle800
    Participant

    @dlittle800

    @jfigura – thanks for the tip about avoiding WPMU DEV templates, lol.

    Re: too many quirky things in BP – I’ve found that a software program is ‘nothing but’ a bunch of quirky things. But it sure would be great if some brilliant programmer could create a plugin to solve this issue – I would certainly DONATE!

    @Peter – you are definitely right about the trend to store sign-up email password notifications – In fact, I have a folder in my Gmail labelled ‘passwords’ full of logins including the one for Buddypress and WPMU! (I’d be resetting my password everyday if I didn’t)

    @Mike – I would be willing to live with the current BP password situation because I sometimes forget (or delete) my own passwords and need to reset them and never even bother creating a password I can remember.

    Where I’m at now, is trying to figure out how the frig to change the message from WPMU so I can eliminate the password that does not work (it actually sends the correct username).

    I tried changing the text in the WPMU Admin panel, but this seems to have no effect at all – So I’m posting at the WPMU forum trying to find out which file to change.

    Any ideas would be welcome : )

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    @dlittle800, the welcome email text in under Site Admin -> Options -> Welcome User Email

    Avatar of Mike Pratt
    Mike Pratt
    Participant

    @mikepratt

    @jfigura I am happy to help figure out your problem but yo u have not given us enough information. The fact that this occur for you in v1.1.3 obviously points to the fact that you have had issues independent of v1.2. What version of WPMU? Are you setting the password during registration AND receiving an email with a DIFFERENT password? Are you expecting to receive an email with a password (if so, why? given that’s not how BP works – in spite of @Peter‘s incessant protests) Does anyone have passwords that work? Did they receive them in an email or are they using the one they set on registration? These questions should help us figure out this dilemma.

    Avatar of jfigura
    jfigura
    Participant

    @jfigura

    @ Mike—

    “The fact that this occur for you in v1.1.3 obviously points to the fact that you have had issues independent of v1.2. What version of WPMU?”


    2.9.1.1

    “Are you setting the password during registration AND receiving an email with a DIFFERENT password?” — Um yes, that’s obvious and it is what the thread is about.

    “Are you expecting to receive an email with a password (if so, why? given that’s not how BP works – in spite of @Peter‘s incessant protests” —- If BP ASKS the user for a password, then the email SHOULD state that password, not something different. This is confusing the user and you already agreed with me on this earlier in the thread.

    Using WPMU alone, you are not asked to set a password, therefore when the email arrives from WPMU, the password works. Not so with BP because the user has already set a password.

    If this is not how BP is supposed to work, then how IS it supposed to work? You have stated previously “That’s it. No email.” —- Then why are my users getting emails to activate, then another email with a password after?

    Again, there is no option for an admin to turn off BP overriding the password, or WPMU NOT to send the emails out. So obviously this is an underlying code issue somewhere involving BP since IT IS SUPPOSED to override WPMU.

    It is apparent I am not the only one experiencing this and I think the issue is quite clear right from the OP’s first post.

    Avatar of Mike Pratt
    Mike Pratt
    Participant

    @mikepratt

    @jfigura While you don’t seem to be the only one experiencing this, you are in the minority. We’ll try and help you. Can you point me to your site and let me see what’s up? I have done dozens of BP installs and not once experienced this issue. I am sure it’s just something gone wrong in installation.

    There’s plenty of room for debate on whether BP should send an email reaffirming the password you just chose but that’s different from us getting your current install to work as advertised. Let’s keep the discussions separate.

    Avatar of PH (porsche)
    PH (porsche)
    Participant

    @porscheheritage

    gotta say that this password-email issue is persistent — i have experienced this on several installs..

    i myself just changed (reworded) the template email-copy thats sent so it doesnt mention the password at all.

    Avatar of dlittle800
    dlittle800
    Participant

    @dlittle800

    Here’s the solution I’m going with. Gets the job done and will work fine until something better comes along.

    Changed text under Site Admin -> Options -> Welcome User Email


    Dear User,

    Your new account is set up.

    You can log in with the username and password you created.

    If you forget your password, visit the following page and click “Lost Your Password?”

    http://wordpress.com/wp-login.php

    Thanks!

    –The Team @ SITE_NAME


    Avatar of jfigura
    jfigura
    Participant

    @jfigura

    @Dlittle — That’s pretty much what I have already done.

    @ Mpratt — “There’s plenty of room for debate on whether BP should – let’s keep the issue separate”


    I am not debating it. I DONT CARE whether it does or doesn’t. What do I care about is IF it does, then it needs to be correct. Reread the post as you seem to have misunderstood what I communicated.

    And if you’re not on the dev team, I am not sure what it is you are going to help with….

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I’m somewhat at a loss as to why people debate this issue or try and state it’s a WP issue as logically that doesn’t make sense?

    As jfigura posts this is an inherent problem, I have it on a production install and it must be hugely confusing for users, and yes the only approach so far has been to modify the text and remove the WP password from the confirmation emails.

    Further testing points to the initial blog registration as being possibly the issue:

    Clean install of WP MU 2.9.1 & BuddyPress 1.2 no significant further plugins activated.

    Test Condition 1:

    WP MU with BuddyPress disabled – admin options -> Allow New Registrations ->’Only user account can be created’

    Register new user

    Receive confirmation email of new registration along with Activation key

    Activate registration

    Receive second email with account username and pass

    All as expected!

    Test Condition 2:

    WP MU with Buddypress activated – admin options for registration still set as ‘User Account only’

    Register new user

    Receive confirmation and activation key

    Activate registration – screen message stating ‘you can now login with user name and password you set’

    No further emails sent!

    Test Condition 3:

    WP MU BuddyPress still activated – admin options -> Allow New Registrations -> ‘Enabled. Blogs and user accounts can be created.’

    Register new user as well as a blog!

    Receive confirmation and activation for account and new blog

    Activate registration – screen message ‘you can now login with password you set etc etc’

    Receive further email from WP! (copied below)

    Dear User,

    Your new *********.co.uk Blogs blog has been successfully set up at:

    http://eggs.********.co.uk/

    You can log in to the administrator account with the following information:

    Username: eggbert

    Password: 5f112917

    Login Here: http://eggs.**********.co.uk/wp-login.php

    We hope you enjoy your new blog.

    Thanks!

    –The Team @ ********.co.uk Blogs – Sent via Site Admin options email

    So having new accounts and new blogs enabled at initial registration triggers the sending of the ‘Welcome Email’ noted above.

    clearly this is confusing as it contains the WP generated password.

    Why is it that BP registration doesn’t disable / override the WP registration completely? To my mind this IS a BP issue, but I may very well be wrong on that score as I don’t profess to have a deep understanding of the core coding involved here.

    On a sidenote:

    Testing this and the slightly odd behavior of ‘Allow New Registrations’ where option for ‘only logged in users can take a blog’ actually seems to prevent all registrations. It occurred to me that on a social community ,and from our experience, blogs are not necessarily what users register for and that I would prefer the option to have a blog be only available for registered users from their account options. what actually happens is that registration is disabled completely! Not the effect I desired. I realise this IS a WP MU issue but is simply daft behavior and that set of options needs to be re-worded to be a lot clearer as to what it really does.

    It would be great to be able to restrict blog signup to users already with account set up and remove, completely, the option to take a blog on initial signup, I have done this by simply scripting out the option / section for registering a new blog in BP register page but feel it’s not the best approach?

Viewing 25 replies - 1 through 25 (of 36 total)

You must be logged in to reply to this topic.