Skip to:
Content
Pages
Categories
Search
Top
Bottom

Group activity emails/notifications not being generated/sent

  • Avatar of OA
    OA
    Participant

    @caoaadvisors

    Hi! New user running the latest version of your plugin with a WP site I just launched and the plugin isn’t working the way that it should- how can I figure out where it’s breaking?

    I can send email notifications to all group members successfully as a group admin, but none of the group members are getting email notifications when new forum activity is happening- regardless of email notification preference. This appears true for both batch subcriptions as well as instant notifications.

    These are the plugins I’m running on my site hosted on Bluehost:

    WP version 3.0.1

    Akismet Version 2.4.0

    BuddyPress Version 1.2.5.2

    BuddyPress Group Email Subscription Version 2.7.1

    BuddyPress Restrict Group Creation Version 0.2.2

    Constant Contact API Version 1.1.2

    Contact Form 7 Version 2.3.1

    Google Analyticator Version 6.1.1

    Invite Anyone Version 0.6.5

    Mail From Change Version 1.0.1

    Surveys Version 1.01.6

    Transposh Translation Filter Version 0.6.3

    WebPurify Profanity Filter Version 2.5

    WP-Mail-SMTP Version 0.8.6

Viewing 25 replies - 1 through 25 (of 32 total)
  • Avatar of OA
    OA
    Participant

    @caoaadvisors

    Just tried to deactivate and reactivate the plugin from the dashboard with no luck… :/

    Any help or advice @dwenaus? @boonebgorges?

    Avatar of idealien
    idealien
    Participant

    @idealien

    I’m also having similar issues. What logs (and location) might one look to see if the emails are attempted / failed? Perhaps a feature I recall some other contact forms having where you can test / configure the email account to be used from admin console?

    Add me to the list – no emails being received on forum activity.

    Also, when setting group email options, my settings are not sticking when I save them. They go back to No Email (which is probably the problem causing no emails to be sent.

    I should also add that I’ve changed “groups” to “circles” using bp-languages.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Are all of you having exactly the same problem – no emails whatsoever? So it’s not just a problem with digests, but also the emails you should get when signed up for All Mail or for New Topics?

    Also: Is the problem only with group forum posts, or are you also having problems with other group activity? Eg new members, new activity updates, etc.

    In my case, no email from any activity, though I’m most concerned with group forum stuff. I’ve got this plugin set up right, I think. The group member can set preferences in the yellow dropdown window. The setting stick there, but not in the options menu found on the group menu bar. That’s odd.

    I’ve tried, also, activating the plugins Mail From and WP-Mail-SMTP. Using the latter, I can receive test email (using the default PHP mail).

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Thanks for the feedback. Are normal BuddyPress emails being sent? For instance, notifications of private messages, or that someone has mentioned you in an update?

    Avatar of idealien
    idealien
    Participant

    @idealien

    Yes – Notification for lost passwords are being sent and received.

    Avatar of techguy
    techguy
    Participant

    @crashutah

    My emails weren’t being sent, but when I upgraded to the latest version, the emails started flowing. Last night it actually flowed in duplicate. If tonight it’s still duplicate or moves to triplicate, I’ll let you know.

    Avatar of idealien
    idealien
    Participant

    @idealien

    Updated to WP 3.0.1 and my existing BP version 1.2.5.2 and plugin 2.7.1 were still current.
    No noticeable affect on emails.

    Is there some form of log or status message that is updated when sends are attempted (either wp_mail or smtp) that I could review to see if any information helpful to the debug process?

    Avatar of Dwenaus
    Dwenaus
    Participant

    @dwenaus

    @idealien while logged in as admin you can put ?sum=1 at the end of any URL and you will see what is in the queue. There is no log however that is a good idea. One more thing to add to the list of things to do. :)

    Also make sure you are running the latest version of the plugin.

    Avatar of idealien
    idealien
    Participant

    @idealien

    @Dwenaus That’s useful info to start – Majority of my forum pages seem to have queue. How do I choke them out :P

    Avatar of idealien
    idealien
    Participant

    @idealien

    Hopefully the following information might be useful to someone to help resolve the issue.

    In ass_digest_schedule_print() of bp-activity-subscription-digest.php I manually triggered a test of wp_mail as well as ass_send_multipart_email and both messages are sent / received successfully.

    Using core control – http://wordpress.org/extend/plugins/core-control/ – I can see that there are 2 relevant cron events scheduled.

    Reoccurring Task
    Once Daily 2010-10-09 05:00:00 -0 ass_digest_event
    Hooked functions: ass_daily_digest_fire()

    Reoccurring Task
    Once Weekly 2010-10-14 05:00:00 -0 ass_digest_event_weekly
    Hooked functions: ass_weekly_digest_fire()

    If I make the following modification it is also successfully received when I manually trigger those events.
    `function ass_weekly_digest_fire() {
    ass_send_multipart_email( ‘youremail@yourwebsite.com’, ‘Test from ass_weekly_digest_fire manual’, ‘message plain’, ‘message html’ );
    //ass_digest_fire( ‘sum’ );
    }`

    However just having ass_digest_fire run when triggered doesn’t generate output even though I have added content which should trigger it if messages were to generate successful. Further debug into there has not yet given any additional info.

    Likely unrelated to issue question that I’m curious about – Is there a reason that ass_send_multipart_email uses phpmailer instead of wp_mail?

    I am also having this problem. I am able to send admin notifications to the group I have set up, and those arrive successfully. However activity notification, such as forum topics, updates to topics you’ve started, new members, etc, is not arriving in any format.

    I’ve noticed that while on the front end of the site, when I change people’s email setting, it shows as “daily digest” on the front end, but when I look at the settings in the WP Admin area, they are set as “None”. Guessing this might be related to the issue.

    I am using the most recent version of the plugin, Buddypress, and WordPress. If there’s anything I can give you, facts wise, that will help chase it down, please let me know. I am unfortunately not a PHP wiz yet, or I’d do more.

    Hoping to use this in a client’s set up, so hopefully we can all work together to solve the problem soon. Thanks in advance for your time and work!

    Add me also to the list, we have the same problems as jolaedana. VERY interested to solve this problem.

    We are currently testing Group Email Subscription . Crossing fingers… and we will keep you posted.

    Avatar of Bowe
    Bowe
    Participant

    @bowromir

    Same problem here.. I would love to use this plugin, but somehow emails are not being sent out on BP 1.2.6 and WP 3.0.2. :-(

    Avatar of Dwenaus
    Dwenaus
    Participant

    @dwenaus

    i’ll look into it.

    Avatar of Dwenaus
    Dwenaus
    Participant

    @dwenaus

    what emails are not being sent out? instant emails, digest emails?

    Avatar of Dwenaus
    Dwenaus
    Participant

    @dwenaus

    i’ve updated to version 2.7.2 which fixes some issues with cron misbehaving. but this may or may not fix the issue discussed above.

    Avatar of Dwenaus
    Dwenaus
    Participant

    @dwenaus

    @bowromir @uferrpi without more details about exactly which emails are not getting sent – instant ones, digest ones, etc. I cannot help. Version 2.7.3 will have a few features that allow you to see the emails in the queue from the admin page. you can do it now with the current version by adding ?sum=1 to any url of your site.

    Avatar of junger
    junger
    Participant

    @junger

    @Dwenaus

    Thanks for this awesome plugin.

    We’re having one issue — weekly emails are not being sent. “all activity” is working and daily emails are too, but weeklies aren’t.

    Any idea how to fix this?

    Thank you!
    Jason

    I have the same problem that Jason!!!

    I hope it isn’t too late to join this discussion: I am running WordPress 3.0.1; Buddypress 1.2.6; and using the Buddypress Group Email Subscription 2.7.8.

    I’ve installed the Group Email Subscription plug-in, but emails are not being sent. I’ve had no problems to date with sending/receiving email notifications from the site. I have tried the All Email and Daily Digest options, without success. In both cases, the ?sum=1 page shows nothing in the queue (great idea to include this Dwenaus!).

    Any thoughts? Is there anything else I can try or additional information I can report? I hope I’m not overlooking something obvious …

    Avatar of moongoose
    moongoose
    Member

    @moongoose

    I did make the changes per http://trac.buddypress.org/changeset/3375/ to add the notification preferences to each user, without which you really can’t get the plugin to work because the options to show the subscription choices doesn’t display in BP 1.2.6.

    I also installed the Mail From plugin http://wordpress.org/extend/plugins/mail-from/.

    I also realized that people needed to post in the Forum’s tab, not on the HOME tab of the group. Home tab updates are not emailed, only Forum topics. Also, I realized that my OWN Forum topics posts are not emailed, only other people’s posts and responses to my posts. I don’t know if that helps anyone.

    I am receiving the individual emails, but there are still NO EMAILS for the Daily and Weekly queue, so I’m thinking that what’s not working are the digests.

    Avatar of Dwenaus
    Dwenaus
    Participant

    @dwenaus

    yes, you’re not going to get notifications of email you yourself send. If you are having other problems, it is probably a conflict with another plugin. No one else is now having problems anymore. If you need one-on-one support, i can do it for a fee, email me at deryk@bluemandala.com for more info. @moongoose

Viewing 25 replies - 1 through 25 (of 32 total)

You must be logged in to reply to this topic.