Skip to:
Content
Pages
Categories
Search
Top
Bottom

Group Blog Error

  • Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    I’m getting an error when I create a group blog:

    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/housings/public_html/wp-includes/wpmu-functions.php on line 107

    I have other group blog set up, but I created the bog first, then linked it to the group at set-up.

Viewing 21 replies - 1 through 21 (of 21 total)
  • Avatar of Mariusooms
    Mariusooms
    Participant

    @mariusooms

    Hi greg, I have someone mention this error before. We ourselves have not encountered it yet. We will continue trying and see if we can find out why. Your explanation to the error could help, thanks for reporting. I will keep you up to date on the progress in regards to this error.

    Avatar of Mariusooms
    Mariusooms
    Participant

    @mariusooms

    Okay…we can verify this error and will try to fix tomorrow. We have a good idea why this is happening and should be resolved soon. It happens indeed when trying to select an existing blog for groups. We additionaly found another issue related to this, so thanks again for bringing this to our attention.

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    I just tried it again, linking to an existing blog and got the same error message…so that isn’t the issue.

    Strangely, group blogs created in the past are still operational and can be reached from the Group menu.

    Maybe it has something to do with the groupblog folder…

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    @Mariusooms

    New error….when uncheck “blog redirect” in the Admin Group Blog SetUp, this message pops up when you click “blog” from the group page

    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/housings/public_html/wp-includes/wp-db.php on line 488

    Avatar of Mariusooms
    Mariusooms
    Participant

    @mariusooms

    This shoulb be fixed in 1.4.4.

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    An interesting situation occurs on a Win2k8/IIS7/PHP5.2.13/MySQL5.0.51a install in that as I am creating a new group

    1 – if I elect to create a blog for a group while I am creating the group then I get an error written in the blog id field of the blog_metadata table that indicates the blog exists.

    2 – if I elect to not have a blog while I am creating the group and then I go back to admin/blog and check the box to have a blog for the group then the blog gets created correctly.

    Any ideas?

    Avatar of Mariusooms
    Mariusooms
    Participant

    @mariusooms

    The groupblog_blog_id should hold a single value. If this isn’t the case it is misfiring somewhere. Did the following post help at all? Please follow the instructions there and see if you can clean up the meta table. This should not be a problem in 1.4.4, but 1.4.3 causes issues.

    http://wordpress.org/support/topic/371370?replies=6#post-1427856

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    If the blog setting is to Redirect to Blog Front/Posts Page and the user clicks on Blog in the group then all the links at the top buddypress menu map to the subdomain.domain.tld linkw and when a user clicks on one of the menus they get a 404 error.

    What is the normal setting?

    I also have tried the setting that is not checked but that does the same thing for the pages under the group description.

    Which setting is most used in the world?

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    I would like for the pages under Blog to open in place using ajax rather than generate a whole new page. Is that possible?

    Avatar of Mark Schafer
    Mark
    Participant

    @markschafer

    I just got the following error and resolved it by following the directions to clean up the meta table. Thanks for posting the steps. Since I’m not sure if the thinking was that this error was no longer occurring in 1.4.4, I’m passing this update along. I’m using 1.4.4 with BP 1.2.2.1 and wpmu 2.9.1. The groupblog was created during group creation and appeared to be fine although no blog could be found and the group blog tab only produced this error:

    Catchable fatal error: Object of class WP_Error could not be converted to string in /public_html/wp-content/plugins/bp-groupblog/bp-groupblog.php

    Avatar of Anointed
    Anointed
    Participant

    @anointed

    same exact issue here. Same setup, in fact tried it on 4 complete virgin wp/bp installs today and all of them caused this error on trying to create/access a second group blog. It works for the first blog created, but none of the others work, they all produce this error.

    I can also report that there is no extra info in the db tables, they are clean. Zero clue where to go from here.

    Avatar of Mariusooms
    Mariusooms
    Participant

    @mariusooms

    @Mark Schafer Are you using subdomains as well?

    The work around for now is as follows, please test this and let me know if that works for you as well. Create the group as usual, but do not create a groupblog. Then visit the group admin and click “Group Blog”. Enable the groupblog and let it create a new blog. Don’t worry about the address we mention (we just show that as information anyway), we just never took subdomains into account, sorry about that. Check your wp-admin and notice the blog is now created successfully as a subdomain blog and the group will work accordingly.

    This worked for me, if that works for you I’m pretty sure where it is going wrong and we will fix this in the next release.

    Permalinks are also still an issue…if people can share code fixes releases will come quicker, just tight up a bit at the moment. However bugs have major priority and we will try to get it resolved asap.

    Avatar of Mariusooms
    Mariusooms
    Participant

    @mariusooms

    Please post errors in this thread related to 1.4.4 as the other thread is for review of the dev version of the plugin. Thanks.

    Avatar of Anointed
    Anointed
    Participant

    @anointed

    sorry about that.. i will keep new posts here from now on. I reported in the other thread that your workaround ‘kind of’ worked for now. At least I managed to get far enough to create the blogs that I need to get finished by this weekend for the church.

    thanks again.

    I do have to send a HUGE thank you though. Without this plugin, my entire concept for the current site would not really be possible. You have been a huge blessing.

    Avatar of Mark Schafer
    Mark
    Participant

    @markschafer

    @Mariusooms – yes, using subdomains. I can/did create a groupblog via the Group Admin page (after group creation).

    Avatar of study
    study
    Participant

    @study

    I am getting the same error msg, but it is returned when trying to upload any kind of avatar:

    Catchable fatal error: Object of class WP_Error could not be converted to string in /path/to/wp-content/plugins/buddypress/bp-core/bp-core-avatars.php on line 281

    Line 281 is:

    $bp->avatar_admin->image->url = str_replace( WP_CONTENT_DIR, BP_AVATAR_URL, $bp->avatar_admin->image->dir );

    I had previously had trouble with avatar uploads and found the advice on changing the small code segment “if ( !$path = get_option( …”

    That worked sort of — couldn’t get avatars to align without forcing some things into the various loop php files — but now I can’t get any files uploaded.

    The change is that I installed the newest beta of WP 3.0 so I don’t know if this new “catchable error” report is of any assistance at all.

    I had found some similar references, not specifically to BP and avatars, but people having problems uploading files into posts and I recall some references made to ms-sites.php.

    I have only one site, the base site, build is configured to use folders not subdomains, and I am seeing lots of problems with pathing to the elusive uploads directory.

    I do know that I was not getting a BP-related error until I upgraded my install from MU 2.92 to Beta 3.0.

    Avatar of study
    study
    Participant

    @study

    Anyone have any advice for me on this line 281 problem?

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    @study You might have more luck finding help if you post your question in a new forum topic. This thread has to do with the BP Groupblog plugin, which seems unrelated to your problem.

    Avatar of Avatar
    Avatar
    Participant

    @avatarrocks

    AH! @MariusOoms the Work Around for Sub Domains Worked!

    Looking forward to the Latest Info, Permanent Resolutions, and Developments.

    ~ Cheers ~

    - Jeff -

    .

    I’m running 1.4.4 and still getting the “Catchable fatal error: Object of class WP_Error could not be converted to string in…..wp-includes/wp-db.php on line 488″ whenever I click on the “blog” link with-in the group. I created the blog added an avatar, set member permissions, etc. with no problems.

    WPMU 2.9.2
    BP 1.2.4.1

    *update*
    When I check the box “redirect to blog” in the admin panel I get a new error after clicking the blog tab

    Catchable fatal error: Object of class WP_Error could not be converted to string in…….wp-includes/wpmu-functions.php on line 107

    Any ideas??? Thanks in advance

    Simon -
    Have you gotten a response to your post about – Catchable fatal error: Object of class WP_Error could not be converted to string in /web/sites/wordpressmu292/wp-includes/wp-db.php on line 488.

    I’m having the same issue.

Viewing 21 replies - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.