Skip to:
Content
Pages
Categories
Search
Top
Bottom

Groups busted in trunk 504?

  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Mornin’ Andy. It’s 5a EST and I see you just posted. :)

    I can’t seem to get Groups to do much in 504. I create one and get the white screen of death at the end. It seems to be created. I can go back to member admin my groups and see the group just created. Click on the link to get to the group home pg and it dumps me into my theme with a 404.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    On another note if I try to access mysite.org/members I get a little notification screen that tells me I need to put plugin-template.php and plugin-sidebar.php into my theme dir. I found these in the buddypress-home dir. Putting these in the appropriate theme folder gets rid of the error msg but doesn’t get me anything.

    All I get is a wp page with the permalink mysite.org/membership

    Once again, changing my permalink from mysite.org/membership to ‘registering-and-membership’ solves the prob. Now I get the member directory wonderfully sandwiched between my theme header and footer. However, it still says 404 in the FF tab and no actual members are listed. I get the abc’s, search box and a h2 Members title header. Nothing else. I’m gonna turn on the bp home theme and see what havoc I can cause with that.

    Is this a blown regex in wpmu .htaccess rewrite rules or bp hijacking behavior? I haven’t modded the .htaccess rewrite rules at all. It’s exactly what wpmu installs.

    Glad you showed up so early?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Ok the saga continues. I turned on the bp home theme and now I see that I don’t have any members. Am I not a member? I can play in my profile. I created a new wpmu blog under a new username ‘becky’. becky can edit her profile but her blog doesn’t show up under ‘my blogs’. This is driving me nuts.

    becky can create a blog through bp and it shows up in ‘my blogs’. Let me guess. I’m missing something. Am I the only one who doesn’t get this bp behavior? becky is the admin of both blogs in wpmu. wpmu is happy with becky.

    Since becky created a blog through bp, bp is now happy with becky. She’s a member now in the listing.

    I created a blog as admin in wpmu. My new wpmu created blog shows up in ‘my-blogs’ but becky’s didn’t. bp still doesn’t seem to think I’m a member even though it likes my newly created wpmu blog.

    (sigh)

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Hooray. I’m now a member. I gave myself a first and last name and now bp thinks I’m a member. Didn’t I read something about some controversy over usernames/first last names? Must be I gotta have a name to socialize. admins don’t socialize anyway.

    It would help if you guys turned on search in bbpress. Ya, I know where it is by URL but I get frustrated and don’t think of that. :)

    Mornin’ people!

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    So where exactly are you now in the whole situation? Are groups working? If you upgraded from an earlier revision, make sure you log in as admin and visit wp-admin to upgrade the DB tables.

    Users wont show in BuddyPress until they have at least *some* profile information (unless you dont have bp-xprofile installed). Usually this means a first and last name.

    Only your own blogs show in my blogs, so if becky creates a blog, thats not going to show in your “my blogs” menu. Unless I am misunderstanding something. :)

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Just installed trunk 509. I’m running out of steam people. Don’t even wanna complain anymore. However I gotta get one about 509 in: Trying to go to a specific group page gets the now familiar white screen of death. WSOD from now on. I’m tired of typing it. Gonna go have a smoke and install trunk 510 when I get back.

    You know what we need? An FTPinglist. Kinda like a mailing list only one way. From bp to the rest of the universe. I’ll just create another ftp user account for the bp ftpinglist. I’m getting tired of all this downloading, installing, playing, uploading, playing and complaining. Let’s just cut right to the complaining.

    :D

    I need a smoke and a nap.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Your best option by far is to use SVN. If you’re not using SVN then running the trunk is going to be a nightmare.

    If you can check out a copy using SVN then you can simply do a “svn up” on the BuddyPress files and they will update.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Can anyone else confirm problems with groups in r509+ ?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    So here here we go. Trunk 509.

    Running my theme:

    Going to a specific group from member bar gets WSOD.

    Creating a new group gets me a 404

    Running bp home theme:

    Going to a specific group gets the group home pg.

    Creating a new group gets me back to the bp home theme.

    I just noticed that the URL up at the FF bar says mysite.org/groups when done creating a new group. Shouldn’t we go to the new group home page after creation? How come we aren’t going to mysite.org/groups/myfancynewgroup ? or /members/admin/groups or /members/admin/my-groups (which gets ya to the same place) ?

    Goin’ to /groups is gonna get me a 404 in my theme. 404.php in the bp home theme is not being launched when invoking /groups. 404 is being launched in the bp home theme cause I just tried /gibberish and it gets me a 404 msg.

    I’m too tired to look at bp-catchuri.php to find out why.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Thanks Andy. I’ll play with the SVN stuff. I’ve just gotten into bp hot and heavy since you pointed out the errors of my ways when it came to me *not* having to run the bp home theme in the wpmu root blog. Got me kinda excited, ya did. Yah.

    Never really worked in a team programming environment. I never had the opportunity. So I have no experience with SVN but I will within an hour. Thanks. I *was* gonna get some sleep. :D

    Tally-ho.

    (what the hell does that mean?)

Viewing 9 replies - 1 through 9 (of 9 total)

The topic ‘Groups busted in trunk 504?’ is closed to new replies.