Skip to:
Content
Pages
Categories
Search
Top
Bottom

Having trouble changing an Avatar with POST method

  • Avatar of Hadar
    hadar
    Participant

    @hadar

    1. Which version of WPMU are you running?

    2.8.4 (running under PHP-5.3, under PHP-FPM)

    2. Did you install WPMU as a directory or subdomain install?

    Directory

    3. If a directory install, is it in root or in a subdirectory?

    Root

    4. Did you upgraded from a previous version of WPMU? If so, from which version?

    No, this is clean install of both WPMU and Buddypress

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    Both are still basically functioning correctly, with one currently known problem

    6. Which version of BuddyPress (BP) are you running?

    1.1.2

    7. Did you upgraded from a previous version of BP? If so, from which version?

    No, clean install

    8. Do you have any plugins other than BuddyPress installed and activated?

    Yes, video_widget, everything else deactivated for now.

    9. Are you using the standard BuddyPress themes or customized themes?

    Standard, slight css tweaks in custom.css

    10. Have you modified the core files in any way?

    No

    11. Do you have any custom functions in bp-custom.php?

    No

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

    Not running, not installed

    13. Please provide a list of any errors in your server’s log files.

    Most things seem to work fine. I suspect I have NginX rewrite rules that are causing the problem, but I’m using the same templates that others are claiming success with, and they do seem to do exactly what the .htaccess rewrite rules for Apache are intending to do.

    It seems that all of my GET’s work fine.

    I am trying to change the Avatar for the admin account. That uses a POST. That POST traces through the rewrite rules and gets passed to PHP rewritten as:

    /index.php?q=/members/admin/profile/change-avatar/

    and it seems that the appropriate payload for the POST is indeed being passed along.

    Document root is set correctly as well, so /index.php should be found. In fact, in all GET methods, it is correctly found, and renders the page correctly.

    On the POST, I get a 404:

    [26/Oct/2009:19:13:03 -0400] “POST /members/admin/profile/change-avatar/ HTTP/1.1″ 404 5 “http://songsandjingles.com/members/admin/profile/change-avatar/”

    Any hints would be greatly appreciated.

    I also run normal WP on the same server, different domain, under NginX, with PHP-FPM and that runs perfectly.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of Hadar
    hadar
    Participant

    @hadar

    I just jumped through a ton of hoops to set up a Virtual Machine running CentOS to install a fresh WPMU and BuddyPress (2.8.5.2 and 1.1.2) behind APACHE this time (instead of NginX) to test the Avatar change, and watch the RewriteLog in Apache to see if I had a logic error in NginX.

    Even under Apache2, when I try to upload a new Avatar, it fails with the same 404. Looking at the Apache Rewrite log, I see that the URI gets rewritten as follows:

    /{DocumentRoot}/index.php

    The parameter is “members/admin/profile/change-avatar/” (but I actually see that the leading “/” was stripped, but the log doesn’t actually show what’s passed). It has to be passed, because index.php alone does bring up the site homepage correctly…

    Avatar of Hadar
    hadar
    Participant

    @hadar

    I just looked at the php error log (which was not generated on the production host) and it has the following error in it:

    [01-Nov-2009 10:12:23] PHP Catchable fatal error: Object of class WP_Error could not be converted to string in /var/www/html/wp-content/plugins/buddypress/bp-core/bp-core-avatars.php on line 264

    Avatar of Hadar
    hadar
    Participant

    @hadar

    Last update, then I’ll stop. :-)

    I read Trac ticket 1184. I changed permissions, that didn’t help, the correct permissions/owner was already there. I saw another forum thread about incorrect avatars ending up in the directory.

    I deleted all directories under blogs.dir (none had files in them, just directories). After attempting (unsuccessfully) to upload an avatar again, I end up with the following directory structure (all blanks, no files in any directory). So, it doesn’t appear to be a permission issue, since the directories get created just fine:

    wp-content/blogs.dir/1/files/avatars/1/

    Now I’ll just wait…

    Hello! Checking package php_gd.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.