Skip to:
Content
Pages
Categories
Search
Top
Bottom

HELP!!! Site dead… update trouble with buddystream???

  • Avatar of oldrow
    oldrow
    Member

    @oldrow

    Fatal error: Call to undefined method wpdb::WPDB() in /home/oldrow0/public_html/postgradjam.com/wp-content/plugins/buddypress/bp-forums/bp-forums-bbpress.php on line 144

    I just upgrade the buddystream plugin, then updated wordpress to the most recent version. Both said they were successful, but now I get this line when going to my site http://www.postgradjam.com and when I try to get into wp-admin… I am effectively locked out of making any changes!!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    And did you update BP according to all the notices about the upgrade to WP 3.2, I’m assuming you’ve updated WP to 3.2.

    Avatar of oldrow
    oldrow
    Member

    @oldrow

    I just updated WP to 3.2 that was the last thing I did before this error.

    Avatar of oldrow
    oldrow
    Member

    @oldrow

    How the hell do I fix my site to be able to even log in to wordpress?

    http://awesomescreenshot.com/046g2dy96

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    rename the BP folder to force deactivate BP then you should be able to get back in to the dashboard, having got back in try upgrading BP to 1.2.9

    Avatar of oldrow
    oldrow
    Member

    @oldrow

    K I did that, but still cannot get in… this is the new error:

    Warning: require_once(/home/oldrow0/public_html/postgradjam.com/wp-content/plugins/buddypress/bp-loader.php) [function.require-once]: failed to open stream: No such file or directory in /home/oldrow0/public_html/postgradjam.com/wp-content/plugins/buddypress-like/bp-like.php on line 17

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/oldrow0/public_html/postgradjam.com/wp-content/plugins/buddypress/bp-loader.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/oldrow0/public_html/postgradjam.com/wp-content/plugins/buddypress-like/bp-like.php on line 17

    Avatar of oldrow
    oldrow
    Member

    @oldrow

    Just realized buddypress isn’t upgraded to 1.2.9 and that might be the problem… how can I manually upgrade since I can’t access wp-admin?
    == Upgrade Notice ==

    = 1.2.8 =
    Compatibility with WordPress 3.1

    Avatar of Virtuali
    Virtuali
    Member

    @virtuali

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    That’s why I asked if you had upgraded to BP. Look at the error messages and deactivate the plugin that it’s referring to , same method as BP rename the folder, when you are cleanly back in the WP dashboard set buddypress directory back to correct name so that it is listed correctly in plugins , don’t activate it but run the auto upgrade to take it to 1.2.9

    Avatar of oldrow
    oldrow
    Member

    @oldrow

    fixed. Thanks.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Glad it’s sorted.

    The moral of the story is never update / upgrade without first checking the support groups for any issues or particular instructions that might be given, it’s hugely important; try never to blindly upgrade, I know the auto upgrade buttons are tempting but resist until you are sure things are going to be ok .

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.