Skip to:
Content
Pages
Categories
Search
Top
Bottom

HELP: Upgrade issues – Slugs & Missing content

  • Avatar of benjjamieson
    benjjamieson
    Participant

    @benjjamieson

    Hi All,

    I ran the upgrade to 1.2 last night.

    I’m using the default theme, and certain areas are missing completely

    ACTIVITY:


    In the nav, the link to activity is:

    http://domain.com/BP_ACTIVITY_SLUG (I’ve hidden this for now)

    Activity streams won’t show anywhere on the site. there’s no option for them under profiles, and accessing http:// mydomain.com/actvity/ leads to a (themed) Page Not Found notice

    MEMBERS:


    The link in the main navigation to /members/ leads to a Page Not found error – its not a themed error page, just a blank page with Page not found” and instructions to use the (non-existant) links in the navigation above

    BLOGS:


    Similar to the activity issue, the main “Blogs” link points to:

    http://www.mydomain.com/BP_BLOGS_SLUG/

    and manually entering http://www.mydomain.com/blogs/ leads to a page not found (Themed)

    Can anyone help me resolve these issues?

    Ben

    shoottheislands.com

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of benjjamieson
    benjjamieson
    Participant

    @benjjamieson

    Anyone? <sigh>

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    What version of BP did you upgrade from?

    Also, do you have pretty permalinks enabled?

    Avatar of benjjamieson
    benjjamieson
    Participant

    @benjjamieson

    r-a-y,

    Upgraded from 1.1.3. Using WordPressMu, so not sure there’s an option for pretty permalinks in Mu

    Should the slugs names be defined by default?

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    What about the backwards compatibility plugin?

    (and yes, MU uses pretty permalinks)

    Avatar of benjjamieson
    benjjamieson
    Participant

    @benjjamieson

    Andrea,

    Are you saying to install or not install the compatibility plug in? Isn’t this only needed if you’re using themes from older versions (We’re using the default BNP1.2)?

    For Permalinks, where are the settings for this in WPMu? They’re not under Settings as they are in WP?

    Ben

    Avatar of benjjamieson
    benjjamieson
    Participant

    @benjjamieson

    Any other suggestions?

    Getting a bit desperate now! Really need a way to display Activity streams

    Maybe I am wrong, but I think I read somewhere that BP needs you to change the link structure to anything but default.

    In WP Mu you do that in a box that looks like in WP. You just have to scroll all the way down to Settings->Permalinks. You can copy and use this link when you have changed your-domain.com to the domain where your WPMU is. : http://your-domain.com/wp-admin/options-permalink.php

    If you have no clue what to put in the field I would suggest: /%category%/%postname%/

    Avatar of benjjamieson
    benjjamieson
    Participant

    @benjjamieson

    Andrea,

    thanks, but I don’t have the menu item for permalink in the settings menu area.

    If I got the page manually, will that somehow recreate the missing slugs and make the activity stream appear?

    Ben

    Avatar of benjjamieson
    benjjamieson
    Participant

    @benjjamieson

    Nope.,

    I changed it (it wasn’t set t the default)

    but still my Activity main navigation item is a link to:

    http://shoottheislands.com/BP_ACTIVITY_SLUG/

    and my blogs main navigation item is still:

    http://shoottheislands.com/BP_BLOGS_SLUG/

    Surely these constants should have a default setting *somewhere* in the basic installation!!!!

    If I try and replace them with what appears on other people’s installs, i.e.

    http://shoottheislands.com/activity/

    then I get a page not found!

    this is driving me nuts – how can there be no activity streams when its a core part of the system!!!?

Viewing 9 replies - 1 through 9 (of 9 total)

The topic ‘HELP: Upgrade issues – Slugs & Missing content’ is closed to new replies.