Skip to:
Content
Pages
Categories
Search
Top
Bottom

How to fix the twenty eleven(with buddypress) profile header

  • Avatar of Walid
    Walid
    Participant

    @walid3

    I used buddypress template pack, the profile page and sidebar too are the problems, if you take a look at the header of the page you will understand what I mean:
    *link removed as this test install is removed now.*
    the image is way up the username as you see, how can I fix that? and why the sidebar is all at the bottom?
    p.s. please use the mention @ my name so I can find the topic.

Viewing 20 replies - 1 through 20 (of 20 total)
  • Avatar of Walid
    Walid
    Participant

    @walid3

    / / /

    Avatar of Walid
    Walid
    Participant

    @walid3

    @mercime I saw that you have css experience so I thought maybe you can help with that :) I don’t know though why buddypress template pack doesn’t fix the integration with twenty eleven as it’s the main theme of wordpress.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @walid3 I will be posting info re Twenty Eleven theme with BP Template Pack by this Sunday/Monday.

    Avatar of Walid
    Walid
    Participant

    @walid3

    @merchime thank you, certainly will be waiting for that.

    Avatar of Walid
    Walid
    Participant

    @walid3

    @merchime thank you, certainly will be waiting for that.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Avatar of Walid
    Walid
    Participant

    @walid3

    Thanks so much for great effort :)

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    There is a whole bunch of wrong with the code from the walkthrough…

    I’m guessing it should be these? (If so, it still didn’t work for me. )

    At bottom of header-buddypress.php:

    At top of sidebar-buddypress.php:

    `

        
            jQuery(document).ready( function() {
                if ( jQuery(‘div#blog-details’).length && !jQuery(‘div#blog-details’).hasClass(‘show’) )
                    jQuery(‘div#blog-details’).toggle();
                jQuery( ‘input#signup_with_blog’ ).click( function() {
                    jQuery(‘div#blog-details’).fadeOut().toggle();
                });
            });
        
    `

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    Hmm… not sure why it didn’t take that other one. Trying again.

    At bottom of header-buddypress.php:

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    Well, then.

    I added spaces between the . Let’s see if that makes a difference.

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    I give up.

    Any thoughts otherwise? My whole BuddyPress area is broken. :(

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    I feel like I need to append this to say that when I mean wrong, I mean some sort of technical glitch.

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    For anyone else having problems reading it on the other page, I found a copy from one of my other websites that I used.

    Bottom of header-buddypress.php:

    (minus the spaces – hope it works this time)

    Top of sidebar-buddypress.php:

    `

        
            jQuery(document).ready( function() {
                if ( jQuery(‘div#blog-details’).length && !jQuery(‘div#blog-details’).hasClass(‘show’) )
                    jQuery(‘div#blog-details’).toggle();
                jQuery( ‘input#signup_with_blog’ ).click( function() {
                    jQuery(‘div#blog-details’).fadeOut().toggle();
                });
            });
        
    `

    Everything in the CSS files is fine, except the top should say:

    `/* BuddyPress Component Finishing Styles
    ————————————————— */`

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    Why does it hate me so? lol

    I guess I’m doing something wrong or am somehow not understanding how the code tag works as it isn’t all coming through. Sorry, I tried. :(

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @zanzaboonda sorry, something got messed up with the sourcecodes in our codex. I’ve updated the page a few minutes ago. Btw, in case you haven’t noticed it yet, you need a closing div at the top of the sidebar-buddypress.php file. http://codex.buddypress.org/legacy/theme-dev-bp-template-pack-walkthrough-twenty-eleven-bp-1-5/

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    No worries! I figured as much. And I did, thanks. For some reason, the code tag kept stripping parts of them out here when I tried to post them. lol Ah, well.

    I think I have it working, though. Thanks so much for responding so promptly and for fixing that. I love BuddyPress, and I keep finding more ways to use it than I ever expected.

    Thanks for all that you do.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    You’re welcome. Glad you have it working in your installation :-)

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    I just realized that my individual groups do not display properly/aren’t responding to the CSS adjustments. Any idea why that could be or what I could add to the CSS?

    Thanks! :)

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    I pasted it into the WP Edit CSS section and got an error for lines 53 and 55. I think the <b and need to be deleted.

    But I’m still having the same problem. lol

    Avatar of zanzaboonda
    zanzaboonda
    Participant

    @zanzaboonda

    Aaand now it’s randomly working. LOL Maybe it just took time to update after fixing those things? IDK.

    Anyway, thanks for all of your hard work. I love BuddyPress!
    <3

Viewing 20 replies - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.