Skip to:
Content
Pages
Categories
Search
Top
Bottom

How to hide some profile fields from public

  • Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    Hi @ all!
    There is this one question I’m searching for a long time: How to hide some profile fields?!
    I can’t find a solution. E.g. there ist the profile field “country” and I just want logged in users to see them.
    I would love to hardcore it until “buddypress” is going to publish a version with privacy settings.

    I hope that someone is able to help me… ;)

    Thanks and all the best

    Philipp

Viewing 15 replies - 1 through 15 (of 15 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Use the conditional function `is_user_logged_in()` in an ‘if’ conditional before the field in question.

    Avatar of Dave Wright
    Dave Wright
    Participant

    @davetwizzlebird

    There is a plugin called profile privacy that may do what you want

    Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    Thanks for the answers. But I just want to hide one of the profile fields from public….
    But you could also help me, if you tell me this:

    Is it possible to convert a date (e.g. Birthday 12.07.1987) to an “age” “23″?! That would solve the Problem also.
    I just don’t want that anyone is able to see the birthdate of my users…

    Thanks a lot and all the best!

    Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    I just tried BP Profile Privacy. It’s not working with the latest BP release, isn’t it!? :(
    So maybe another idear?

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    I just tried that plugin and it seems to be working. What didn’t work for you?

    Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    I activated it and made my settings but nothing happens. E.g. I said “Birthday” just for “User” but it’s still visible. There are also no settings in the frontend if I use “Let user decide”.
    I already deleted all fields with “bp_profile_privacy” in the database and activated the plugin again. But it’s still the same… No idear!?

    Thanks a lot!

    Avatar of noizeburger
    noizeburger
    Participant

    @noizeburger

    BP Profile Privacy only works for fields in the fieldgroup “Base” (ID 1). In which group did you place the birthday field?

    Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    It is in the fieldgroup “ID1″.

    Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    Hi and sorry for the second post. But I’m trying to find out since one week why the BP Profile Privacy PlugIn isn’t working for me.
    If I activate it and set a field (e.g. birthdate) to “users only” – nothing happens. There are also no settings for the users in the frontend of buddypress. So there’s something wrong? Any idear what to try to fix it?

    I’m looking forward – Hopefully for an answer! ;)

    Philipp

    @philippmuenchen – it works fine. I’m guessing you’re trying to test it while you’re logged in as Admin? The privacy controls don’t apply to Admin. Admin can see everything. Log in as a regular user and then test.

    Age calculation: http://code.hyperspatial.com/all-code/buddypress-code/buddypress-age/

    @noizeburger – it works for all fieldgroups, not just Base.

    “If I activate it and set a field (e.g. birthdate) to “users only” – nothing happens. There are also no settings for the users in the frontend of buddypress.”

    If you set it to “users only” in Admin, you’re not giving your user the choice, and that’s why there is no selector in the front end. The user will only get the selector if you choose “let user decide”.

    Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    @aljuk Thanks a lot for you answer. But I also tried that and I logged out as admin and signed in as a normal user. Still the same.
    Another idear?

    Thanks a lot for the link. I’ll take a look to it! :)

    All the best!

    Hmm, that’s strange. It’s working for me exactly as advertised.
    What’s the history of your theme? Is it default, child, custom etc?

    Maybe cookies…
    In the Admin, set “let user decide” for some fields.
    Log out.
    Clear your cookies, make sure to delete all cookies from the domain, and from any test domains, and any local domains (eg. mamp wamp etc. if you’re using that) that you’re developing the site on.
    Log in as a subscriber level user.
    What result now?

    Avatar of Philipp
    Philipp
    Participant

    @philippmuenchen

    @aljuk Another 6 hours of work and sill no solution. I tried exactly what you said. And I also tried it on my development installation – There it’s working like a charm. I don’t have an idear what to do… ;(
    I use the latest versions of bp and wp. On my testdrive I use the same plugins. I also checked another theme.
    All this work just to hide ONE profile field.
    Do you have another idear? ;)

    Thanks a lot!

    Philipp

    Not sure. I just downloaded and it worked. I did notice when I was in a member profile and looked at my public profile tab the fields showed up. When not logged in or logged in as another user, the fields were not visible. I am also using Role Manager plugin, not sure if that makes any difference.

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.