Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] How to integrate buddypress with geotheme

  • Avatar of andy0007
    andy0007
    Participant

    @andy0007

    Hi there,

    I have been messing with geotheme and buddypress for a day or two but cant get things to work properly.

    I would really appreciate if some one can jot down the steps for integrating buddypress with a custom theme (geotheme)

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    You need to explain better what you have been trying to do and with what versions.

     

    Please try using BP 1.7 beta 2 and it’s theme compat template mode¬† which should seamlessly integrate the BP templates into any theme as long as the theme follows WP templating conventions and doesn’t try and do it’s own thing in this respect.

    Avatar of andy0007
    andy0007
    Participant

    @andy0007

    Hi mate,

    I tried version 1.7 beta 2 and it is working better but still the buddypress pages are extremely left aligned which makes them look awkward.

    The navigation bar and everything are somewhat center aligned but the members pages and other buddypress pages extremely left aligned.

    I believe small changes in html/css can help them align properly but I don’t know what changes to do and where.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @andy0007 site url?

    Avatar of andy0007
    andy0007
    Participant

    @andy0007

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    For starters you have a critical markup error in a misplaced closing div this will not only throw out most browsers ability to render a layout¬† but makes tracking down any other issues pointless until it’s rectified.

     

    Can you confirm that you haven’t originally attempted to run the template pack plugin on this theme to get it BP compatible as those BP pages do not feel like ‘theme compat’ ones. You don’t have any BP template files moved into your theme do you?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @andy0007, @hnla has got it right. You have BP template folders in your theme. Delete the 6 BP folders and see what happens (crossing fingers) :-)

    Avatar of andy0007
    andy0007
    Participant

    @andy0007

    solved. Thanks guys.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.