Skip to:
Content
Pages
Categories
Search
Top
Bottom

How to make 'forum' the default view for BuddyPress group

  • Avatar of jameat
    jameat
    Participant

    @jameat

    When I click on a group the default page view is the activity stream. How can I change the default page view to the group forum page?

    Thanks in advance for your guidance.

    ps I am using WordPress 3.8 running Salient theme with BuddyPress 1.9.1 and bbpress 2.5.3

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of shanebp
    shanebp
    Moderator

    @shanebp

    Over-ride this file:
    buddypress\bp-templates\bp-legacy\buddypress\groups\single\home.php

    And adjust it to make forums the default rather than activity.

    Over-riding BP templates:
    http://codex.buddypress.org/themes/theme-compatibility-1-7/a-quick-look-at-1-7-theme-compatibility/

    Avatar of jameat
    jameat
    Participant

    @jameat

    Thanks shane.

    I took a look at that doc you link but feel this is a little beyond my capabilities!
    Looking around the bbpress documentation I found this

    They tell me to add
    define( ‘BP_GROUPS_DEFAULT_EXTENSION’, ‘members’ );
    to my wp-content/plugins/bp-custom.php file. But that doesn’t seem to work.

    This is what I wrote in the bp-custom.php file:

    <?php
    define( ‘BP_GROUPS_DEFAULT_EXTENSION’, ‘forum’ );
    ?>

    Is there anything obviously wrong with this which may explain it not working?

    Thanks again.

    Avatar of shanebp
    shanebp
    Moderator

    @shanebp

    This works fine on my basic test install
    define( 'BP_GROUPS_DEFAULT_EXTENSION', 'forum' );

    Make sure that the quotes are straight verticals – not slanted or curved.

    Otherwise, it’s something about your install.
    Are you positive that your group(s) have forums ?

    Avatar of shanebp
    shanebp
    Moderator

    @shanebp

    Also make sure that your single forum slug is ‘forum’
    The settings are in Dashboard > Settings > Forums > Single Forum Slugs > Forum.

    If it isn’t ‘forum’, before changing the slug, trying changing your ‘define’ to use your current slug.

    Avatar of jameat
    jameat
    Participant

    @jameat

    Dear Shane.

    You are a genius (or I am a blockhead). It was the quotes in my bp-custom.php file! They were curved and not straight verticals, dope.

    All fine now

    Thanks again

    Avatar of Tearstone
    Tearstone
    Participant

    @tearstone

    Thank you, this was helpful. I have a site-specific plug-in that I use. I just added Shane’s line to that, and it worked beautifully.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.