Skip to:
Content
Pages
Categories
Search
Top
Bottom

I'm so new! A little help, pls hold my hand through this!

  • Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    Very new to all this. Creating a website for the family, have a rather large family and many are asking for our own private place to go.

    I’m using WordPress version 3.8.1 and installed BuddyPress version 1.9.2 and bbpress version 2.5.3. My goal is to have folks to log in to view conversation, post pictures, and chat use BuddyPress to its fullest. All my pages are messed up, the links are all screwy and bunch of other stuff.

    I’m looking for someone to help me clean this mess up so I can get the site somewhat functional, the website is http://www.hout.us.
    Thanks-
    Matthew

Viewing 24 replies - 1 through 24 (of 24 total)
  • Avatar of mcpeanut
    mcpeanut
    Participant

    @mcpeanut

    hi matthew, maybee you could you explain a little more?

    All my pages are messed up, the links are all screwy and bunch of other stuff.

    ive looked at your link and everything seems perfectly normal on the twenty fourteen theme, i notice you havent got buddypress installed?
    go to plugins and click add plugins and search for buddypress, then go to buddypress settings and tick what you will want to be using within your website, i would also suggest doing a search for rtmedia plugin for your photos. dunno if this helps as i cant see what you mean with all the links being screwy etc when buddypress isnt even installed?

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    It’s installed. When I click on register I receive a message:

    HTTP Error 404.0 – Not Found

    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

    I created a username and log in that route, i can log in successfully and see the additional pages available to those logged in but when I click on those page I receive the same message as above:

    HTTP Error 404.0 – Not Found

    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

    Avatar of BuddyBoss
    BuddyBoss
    Participant

    @buddyboss

    A 404 error is when the server cannot access a link. Usually a broken or dead link. WordPress uses “pretty permalinks” which basically means it creates virtual links for your site using a structure that you assign to it. If this system is messed up you may get 404 errors all over the place.

    First idea: Go to Settings > Permalinks and set the Permalinks to default. Test your site, and then set Permalinks back to whatever custom structure you had set up. Might fix it.

    Second idea: Make sure you have a page assigned to each BuddyPress component, at Settings > BuddyPress. If not, WordPress may not know where to access the BuddyPress pages and may return 404 errors.

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    Hi, @buddyboss I did as you mentioned. When I switched the Permalinks to default, tested the site – received the same error. I switched back to what was there and still nothing. :( I want this site to work so bad! :) :(

    Avatar of BackpackersUnion
    BackpackersUnion
    Participant

    @backpackersunion

    Hi @matthew.hout, Did you try Buddybosses Second idea? That’s what it sounds like the problem is. After you install BuddyPress you need to assign certain BuddyPress Pages to WordPress Pages (Activity Streams, Site Tracking, Members, Register and Active, are the pages depending on your Component Settings). To set these pages go to; Settings -> BuddyPress -> Pages. I don’t remember if BuddyPress creates the WordPress pages for you. You may have the create a blank page for each yourself. After you connect the WordPress pages to BuddyPress, I’d imagine it will start working.

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    @backpackersunion, @buddyboss: I did as mentioned above, correct pages are assigned. Here is what happens now:

    When at my site and I click on “register” it goes to the register page but nothing is there, only comments. If I were to add the other pages (Activity, Groups, Members, etc…) to the “main menu” where logged out users can view, I get the pages, but they are blank.

    If I log in to the website, with a login i created for testing and click on the pages / links view-able to logged in folks, I get the same error I mentioned before the 404 error.

    I also noticed after I login that user has access to WP and I think can edit the site.

    grrr
    Matthew

    Avatar of aces
    aces
    Participant

    @aces

    @matthewhout

    I think you may be running on a windows IIS server as your links are of the form http://www.hout.us/Hout.US/index.php/about/ I’m not sure, but I don’t think you are meant to have index.php in a URL –

    Also I think that capital letters in a URL are also invalid as maybe also is a dot between slashes ( in this probable context ) – ie the dot in: /Hout.US/

    Are you sure you have installed wordpress correctly with mod_rewrite or substitute.

    Does the suggestions on http://buddypress.org/support/topic/404-error-when-using-toolbaradminbar/ help?

    Unfortunately I can’t be of more help as although I run windows I use an apache server, But others may have a better idea….

    Avatar of BuddyBoss
    BuddyBoss
    Participant

    @buddyboss

    Yes this link is a dead giveaway that something is wrong with how your site is creating links:

    http://www.hout.us/Hout.US/index.php/about/

    The /index.php/ does not normally show up in a WordPress site. No .php or .html extensions are normal. WordPress creates a virtual link structure that you assign to it so everything looks pretty. Something is off.

    @matthewhout may be correct that you’re on a windows IIS server. I’ve never used one so I wouldn’t really know.

    I suggest you contact your web host and ask a few questions:

    1. Do you have a working .htaccess file? You can tell them it should be in the root directory, same directory as wp-config.php.

    2. Is the server correctly running apache?

    Avatar of mcpeanut
    mcpeanut
    Participant

    @mcpeanut

    First question would be to ask if your on shared hosting vps or private server?
    maybee this link will help you if you take a look. i dont know what hosting your with but have a read anyhows.

    http://wordpress.org/support/topic/godaddy-iis-and-removing-indexphp-in-url

    p.s i dont know if there is a solution within that post but it may help you find out a little more.

    also just found this post too for you.

    http://wordpress.org/support/topic/getting-rid-of-indexphp-from-url

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    OKAY! @buddyboss @mcpeanut @ So here is what I need. I now have a linux server! YAY ME! I’m in the process of redoing everything as I did not back it up.

    I have buddypress installed the pages work. The issue I’m having now is:

    BuddyPress is not showing in Appearance / Menus (as it did before) where I could select which pages I want only logged in folks to see.

    I appreciate everyone’s else help.
    Matthew

    Avatar of mcpeanut
    mcpeanut
    Participant

    @mcpeanut

    @matthewhout Hmm, buddypress settings are located in the settings submenu in wordpress dashboard, make sure you turn on all the options you need in there, also make sure your pages are setup in there as you want them to, also dont forget to go to settings and permalinks too, and select which permalinks you prefare, hopefully everything should be fine for you then, well if i understand correctly that the issues you where having was due to having a windows server and now you have changed to a linux server? i cant see there being any problems with a fresh install.

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    Think I’m trying to hard to accomplish what I want out of this website.

    @mcpeanut yes, the issue was resolved with the window server.

    I switch server and re-installed WP 3.8.1 and re-installed BuddyPress 1.9.2. For some odd reason: I do not have BuddyPress in Appearance > Menus

    I went through to be sure my settings are as I want them: all good there. Just need the Buddypress option in the Menu.

    M

    Avatar of mcpeanut
    mcpeanut
    Participant

    @mcpeanut

    lol im confused? what you mean? buddypress in Appearance > Menus?

    are you trying to create a custom menu in wordpress? all you have to do is name the menu then on the left handside tick the pages you want to appear in this menu, then under the menu you have created you will see these options.

    Menu Settings

    Auto add pages
    Automatically add new top-level pages to this menu

    Theme locations
    Primary Menu

    Tick primary menu option then save and your menu will appear how you want it

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    I’m trying to create a menu only accessible to those who log-in to the website.

    Before (on window server) when I go to appearance > menu I had Pages, BuddyPress, Links, Categories. When I selected BuddyPress it gave me options to click on the pages I wanted my log-in folks to only see.

    how do I get the back in to Appearance > Menu?

    Avatar of aces
    aces
    Participant

    @aces

    @matthewhout

    At the very top of the page below the admin bar on the right you should have a ‘Screen Options’ button – next to ‘Help’.

    Have you got ‘Buddypress’ ticked in the ‘show on screen’ section?

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    @aces @mcpeanut I don’t know what happened, but I re-installed BuddyPress and its now there in Appearance > Menus.

    Thanks!
    All is good for now-

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    I thought this all would be simple. LOL

    When I go to register as a test for the site I never get an email to validate and gain access.

    Several questions to follow that:
    Do folks who register to the website also have access to WP?

    Anyone interesting in doing all this for me?

    Avatar of mcpeanut
    mcpeanut
    Participant

    @mcpeanut

    @matthewhout lol matthew dont worry man we was all noobs at some point :), regarding the emails have you checked the spam folder? sometimes wordpress mails go to the spam folders, best thing to do is configure your mail to go through smpt (i guess you also wont be familiar with this either?)

    if you want help i may have a little time spare to help you set it up initially, are you on skype? you can add me if you want.

    if not set a free skype account up and post me your username and i will add you, i can help you out a little if you want seeing as your struggling setting up the basics.

    Avatar of mcpeanut
    mcpeanut
    Participant

    @mcpeanut

    btw i just registered on your website without a problem to test it for you and it is indeed going to my spam folder as i mentioned.

    also after logging in i also noticed you have wordpress set up as a multisite installation, is there any reason you have done this? are you planning having a multisite setup?

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    Interesting… skype: matthew.t.hout

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    I thought I read somewhere it was best to have WP set up as multisite. I may start another site at somepoint… you recommend it being single?

    Avatar of mcpeanut
    mcpeanut
    Participant

    @mcpeanut

    i suppose you can mark this as resolved as ive been helping him out via skype.

    Avatar of matthew.hout
    matthew.hout
    Participant

    @matthewhout

    This has been resolved. Thanks to all those help and shout out to @mcpeanut

    Avatar of BuddyBoss
    BuddyBoss
    Participant

    @buddyboss

    I thought I read somewhere it was best to have WP set up as multisite. I may start another site at somepoint… you recommend it being single?

    WP should be installed as single. BuddyPress too. Keep it simple. If you have a need for multisite you can enable it later, but don’t do it for no reason. It will add complexity to your setup for no benefit, unless you need multiple sites in one install.

Viewing 24 replies - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.