Skip to:
Content
Pages
Categories
Search
Top
Bottom

Image filename discrepancy, image not displaying

  • I’ve just installed the 0.1.8.7 version of BP-album, and when I upload a photo, it shows a broken image in the album.

    I noticed that the image file gets renamed during the upload, but the link points to a different renaming convention – ie:

    Page links to
    img src=”http://whatever/wp-content/uploads/photos/1/official_pic.jpg”
    and thumbnail
    img src=”http://whatever/wp-content/uploads/photos/1/official_pic-150×150.jpg”

    but the files are named:
    a7eb9833ae93c8fc80f5abfb6bfe5cad-bpfull.jpg
    a7eb9833ae93c8fc80f5abfb6bfe5cad-bpthumb.jpg

    This is a fresh install of the current version of WordPress & BuddyPress as of 2/13/2011.

    Any idea of what’s wrong?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of foxly
    foxly
    Participant

    @foxly

    @nunsuch0

    I’ve never heard of anything like that happening before. What’s different about your server?

    ^F^

    Never mind. I just solved this myself – a stupid mistake. My “uploads” directory had to be set to 777 permissions in order to create proper subdirectories etc. [face/palm] The randomly named files were in the *avatars* directory. That’ll teach me to never ask support questions at the end of a long work day.

    By the way, it’s a standard Redhat setup on a private server, & I had to use the image URL re-mapping too… but now everything works great. Sorry to have wasted your time.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.