Skip to:
Content
Pages
Categories
Search
Top
Bottom

Install buddypress 1.5beta2 Fatal error: Call to undefined function bp_site_name()

  • Avatar of Aronezhang
    Aronezhang
    Participant

    @aronezhang

    Fatal error: Call to undefined function bp_site_name() in /home/aronezhang/domains/oracleseeker.com/public_html/wp-content/plugins/buddypress/bp-themes/bp-default/header.php on line 28

Viewing 6 replies - 1 through 6 (of 6 total)
  • That does exist in BP 1.5.

    Did you somehow switch the theme to BP-Default *before* activating the plugin? Or, after activating the plugin, did you complete the BuddyPress set up wizard? (it should have displayed a note at the top of the screen after activating the plugin, with a link)

    Avatar of gregfielding
    gregfielding
    Participant

    @gregfielding

    I’ve got this error now as well. I activated buddypress and then activated the default theme BEFORE going through the buddypress setup wizard.

    How can I undo?

    You can see it:
    http://townswell.com/

    Thanks!

    Avatar of enderandrew
    enderandrew
    Member

    @enderandrew

    If I recall correctly, this is fixed in trunk. I think it was a conflict with bp-template-pack and BP 1.5.

    Avatar of bobbingwide
    bobbingwide
    Member

    @bobbingwide

    This problem occurred for me on a vanilla install without bp-template-pack. I believe it was because I failed to click on the Finish & Activate button. I’d read the message “The BuddyPress setup is complete, and your site is ready to go!” so I just chose something other than the Finish & Activate button.
    If anyone else gets the problem, just go back to the wp-admin page and try again – this time selecting Finish & Activate.

    Avatar of lgkevincc
    lgkevincc
    Member

    @lgkevincc

    I believe it was because I failed to click on the Finish & Activate button. I’d read the message “The BuddyPress setup is complete, and your site is ready to go!” so I just chose something other than the Finish & Activate button. yes, this is the point.

    The wording needs to be changed, or activation needs to happen after step 4. This is a major oversight, right from installation. I hope my users dont encounter such problems after I build my website. Clean design though. My second impressions of it are positive.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.