Skip to:
Content
Pages
Categories
Search
Top
Bottom

Installation of WPMU and BuddyPress on Local machine

  • Hello,

    I am trying to have BuddyPress work with my wordpress-mu installation on my LOCAL machine. I have been able to activate the BP plugin and even the BP theme.

    I can even see the BP theme actually showing up on the browser but none of the links work. For e.g the menu’s “Blog”, “Members” etc do not work and give a 404 error. This is the actually the link that gets generated.

    http://localhost.localdomain/wordpress-mu/groups

    Could somebody suggest how to resolve this?

    Regards,

    Roland

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    A couple of questions:

    1. What locahost environment (OS and server) are you running your install on?

    2. Did you install the bpmember theme folder in /wp-content/bp-themes/?

    3. Did you choose the BuddyPress default member theme, bpmember, in WPMU’s backed? You do this by logging into WPMU as site admin, then going to “BuddyPress > General Settings > Select theme to use for BuddyPress generated pages”.

    4. Do you have a .htaccess file in the directory in which you’ve installed WPMU?

    Hi Jeff, Thanks for your reply. Pl. find below my replies to your questions.

    1 I am using Windows XP and running all this off the Appache webserver.

    2 I copied the bpmember folder in /wp-content/bp-themes/

    3 Yes the same has been done.

    4 Yes I do have a .htaccess file in the dir in which WPMU is installed

    Please advise.

    Can somebody send me a link to a doc or a guide which clearly describes how buddy press has to be installed with WPMU on a local machine?

    Need help urgently.

    Regards

    I was able to resolve the problem in the following manner on my localhost:

    The issues were w.r.t the directives in the .htaccess file.

    Most of the settings were w.r.t to the httpd.conf file of Apache

    There could be security issues but AT least it worked locally

    I changed

    1) AllowOveride None to AllowOveride All (this line follows the Options Indexes FollowSymLinks line)

    2) Uncommented teh LoadModule rewrite_module line

    3) Accessfilename should point to .htaccess (its on by default)

    Hope it works for anyone else having the same issue.

    Cheers!!!

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @anthony-cajetan

    Thanks for sharing your solution. I’m setting this thread to resolved. You can always run the light red again if need be!

    Avatar of 21green
    21green
    Participant

    @21green

    Doas anyone know a good guide/tutorial for installing WPMU/Buddypress on OSX with XAMPP? I know i have to change localhost to localhost.localdomain. But where and how can i achieve this? And why isn’t it possible to run WPMU on localhost? No spamming, just for general interest.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    21green-

    This is truly beyond the scope of the BuddyPress forums. But, since I had some issues when I attemtpted to install WPMU on MAMP several months ago, I feel your pain.

    I wrote an article (months ago) for installation of WPMU on MAMP (not MAMP Pro). But, I’m not yet finished with updating my new website, so it is not yet posted.

    Here is the crux of the article. I’ve never tried this with XAMPP, so use at your own risk:

    1. Make sure you have the most recent, stable version of WPMU and that it is copied into MAMP where you want it to be.
    2. Read the readme.txt file that comes with WPMU
    3. Do not manually edit either of these two files:

      • wp-config-sample.php file
      • htaccess.dist file

      Unlike single version WordPress, the WPMU installer will take care of creating the proper files using these two as templates. If you need to make changes to either of these files, do so after the installation has succeeded.

    4. WPMU wants to run on Apache port 80. Since OS X comes with a copy of Apache set to run on port 80, you will have issues if OS X is automatically configured to start its own copy of Apache on boot. If so, you’ll have to change that. Check to make sure that the Web Sharing checkbox is unchecked in System Preferences > Sharing
    5. Now fire up your browser and go to localhost:80/index.php and follow the prompts. The path will be different if you’ve installed WPMU in a subdirectory. If so, just add the subdirectory to the url.
    6. In the field for Server Address, you will see the recommendation to use localhost.localdomain instead of localhost. That did not work for me. Instead, I found that I had to use the internal IP address of my computer (a.k.a the local IP address which is always 127.0.0.1 ). I tried the localhost.localdomain address several different times with no success. If you have already tried this, make sure that you delete the wp-config.php file and start all over.
    7. If you’ve done this properly, you should now be seeing a friendly “Installation Finished!” screen. Follow the instructions. Write down your password.
    8. Now, manually enter the address for the admin login screen into your browser’s address bar. If you just hit log in, you may have issues. So, if you are using 127.0.0.1 as the Server Address, you would enter in the browser 127.0.0.1/wp-login.php. The path will be different if you’ve installed WPMU in a subdirectory.

    Good luck!. Let me know if this works for you.

    Avatar of 21cdb
    21cdb
    Participant

    @21cdb

    Hi Jeff,

    i followed your instructions and it seems to work also for XAMPP on MAC.

    However it’s still not runnning, because i still get the following error message:

    (Redirect Loop)

    The connection attempt was cancelled because the website redirected the request so that it would never complete.

    Do you have any suggestions?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    21cdb-

    Do you have two different accounts on bp.org? :)

    As far as the redirect loop question, it could be caused by many things. So, a few questions:

    1. Did you install WPMU as a directory or subdomain install?
    2. If a directory install, is it in root or in a subdirectory?
    3. You were having install issues beforehand. When you finally got this to work, could there have been old, incomplete install data leftover in your DB? Or, did you install into a fresh, new DB?
    4. What errors are you seeing in your server’s log files?

    I did a quick Google and here are two links that explain a couple of possible causes:

    http://mu.wordpress.org/forums/topic/9252/page/2

    http://bradleyland.net/2009/04/wordpress-mu-redirect-loop-during-install/

    Avatar of 21cdb
    21cdb
    Participant

    @21cdb

    Hi Jeff,

    i set up everything again (deleted complete wpmu and database). I changed host from localhost to 127.0.0.1 as u described above, even if wpmu claims to not use localhost or 127.0.0.1 as host. Now everything ist working without a problem!

    Why does the wpmu installer mention to not use 127.0.0.1 ?!

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    21cdb-

    Congratulations! This has been a long haul for you.

    Why does the wpmu installer mention to not use 127.0.0.1?

    Haha! Good question. I have not installed a brand new instance of WPMU for awhile so I cannot remember exactly what the installer indicates. But, I don’t think it says don’t use 127.0.0.1. Does it?

    I believe it says use localhost.localdomain which if you do, the installer comes back and says, “WPMU only works without the port number in the URL.” So, when installing on a localhost environment–at least on a Mac–you’re stuck wondering what is going on.

    But, this is why using the local IP address worked. It is the actual address of the local machine mapped to the alias called localhost. So, by using this, you don’t need to include the port number.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

Viewing 12 replies - 1 through 12 (of 12 total)

The topic ‘Installation of WPMU and BuddyPress on Local machine’ is closed to new replies.