Skip to:
Content
Pages
Categories
Search
Top
Bottom

Just Installed – links aren’t working

  • Avatar of KT
    KT
    Participant

    @somethingforkaty

    Hi,
    I just installed this and seem to be having a strange problem with all the links. The blog links are working fine, however any of the links in the menu added by BuddyPress show up as 404 Page not found unless I add in index.php in the middle of the URL.
    e.g. The default Activity link in the menu is http://www.trashthestage.com/activity/ but it won’t work unless I manually change it to http://www.trashthestage.com/index.php/activity/

    This happens no matter what setting I have active in permalinks.

    How can I fix this? Thanks :)

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of clarke
    clarke
    Participant

    @clarki

    Im having exactly the same problem. ive installed wordpress and wordpress multisite on two different machines and installed and uninstalled buddypress numerous times trying to solve this problem. ive scoured the internet and a lot of people are havin the same problem but theres not a single solution???

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Not a single solution? really?

    Have you honestly scoured all the docs pages here and the WP codex ones, have you searched the posts in the support groups here?

    I know that this issue crops up often enough that there are many posts that have covered this aspect or issue, there is also WP
    codex pages on permalinks and how to deal with them which essentially is the issue you are experiencing by the sound of things.

    One last point this isn’t really a BP issue , it’s a WP one WP handles this aspect and it’s important to get WP working correctly before moving on to activating BP.

    Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    @hnla:)

    @clarki and @somethingforkaty – these are not BP issues but permalinks in WP. Go to your admin panel and set the permalinks. See step 3 here: http://codex.buddypress.org/getting-started/setting-up-a-new-installation/

    Here is the information on “pretty” permalinks: http://codex.wordpress.org/Using_Permalinks

    Watch the .htaccess after permalinks set in /wp-admin

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Thanks @lph2005 that makes me look ever the meanie ;) :)

    Avatar of clarke
    clarke
    Participant

    @clarki

    setting the permalinks was the first thing i tried. everything on the site works fine except for the BP links. ive found one solution here-

    http://cratel.wichita.edu/cratel/KMEK

    ive followed all the steps but still no joy. as for looking through the codex n support groups yes i have. that is the only substantial fix i found. surely there must be someone whose experienced this problem first hand and sorted it somehow?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Setting the permalinks, but can you confirm they were written.

    What server are you running on?

    Have you run through the WP codex guide that lph2205 linked to above.

    Avatar of clarke
    clarke
    Participant

    @clarki

    As ive read thru the codex i see theres two ways of doing the permalinks depending on your server. mine seems to have defaulted to the pathinfo version of permalinks which automatically has to place index.php before the permalink for it to work. because of this the BP links are thrown out of sync as their links do not recognise having index.php thrown in front of their link. any ideas how we can work round this?

    Avatar of clarke
    clarke
    Participant

    @clarki

    and to check to see if the permalinks have actually been written where and what should i be looking for?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    The permalinks screen would say if it could write if it couldn’t it would present you with what needs to be copy/pasted to the file manually.

    What server? IIS?

    There are threads on the forum that deal with this pathinfo situation iirc but granted sometimes they can be hard to track down.

    Avatar of clarke
    clarke
    Participant

    @clarki

    the server is zeus by the way

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Not familiar with Zeus.

    Can it not be asked to use mod_rewrite

    A lot of threads on this issue:

    http://www.google.co.uk/search?q=zeus+and+mod_rewrite&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-GB:official&client=firefox-a

    Avatar of clarke
    clarke
    Participant

    @clarki

    ive ran into this problem before on a previous site and ending up having to use a rewrite.script because zeus doesnt use .htaccess

    the question now is what rewrite do i use to get buddypress to understand my pathinfo?? this gets better by the minute!

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.