Skip to:
Content
Pages
Categories
Search
Top
Bottom

Language translation problems

  • Avatar of Kogigr
    kogigr
    Participant

    @kogigr

    Hi..

    I translated the buddypress.pot file into greek, using PoEdit, and I saved it as buddypress-el.po . I then ran a command that converted the .po file into .mo . Now I had 2 files that needed to be uploaded to /wp-content/plugins/buddypress/bp-languages, so I did that.

    Having uploaded the files, I edited wp-config.php so as to change the WPLANG value. The line looked like this \”define (\’WPLANG\’, \’el\’);\”.

    Having done all this, the language is still english and I have absolutely no idea why that happens.

    I\’d appreciate any help. :)

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Arturo
    Arturo
    Participant

    @arturo84

    do you have wpmu in greek? save the lang file buddypress-xx_XX.po and the same .mo

    xx_XX is language_COUNTRY for example it_IT (italian_ITALY).

    Avatar of Kogigr
    kogigr
    Participant

    @kogigr

    No, wpmu is in english.. I renamed the files to buddypress-el_GR.po and buddypress-el_GR.mo but still no change. The country code and language code are correct, because I found them in wordpress documentation.

    I still don’t know what’s wrong, though..

    Avatar of Bloggsbe
    Bloggsbe
    Participant

    @bloggsbe

    @Kogigr;

    AFAIK, you have to use the same language in WPMU as in BuddyPress. BuddyPress gets the language setting from WPMU. There is some info about the greek WPMU translation here, but I don’t read greek, so it’s not necessarily the info you need :-)

    But you’ve named the file(s) right, you only need the .mo file in your bp-languages folder.

    So basically you need to use the same language in WPMU that you want to use in BP. So get the greek WPMU translation, upload it to you WPMU install, and change the language in you admin section…

    HTH

    Regards,

    RuneG

    Avatar of Kogigr
    kogigr
    Participant

    @kogigr

    I followed the link you provided and they share an “el.mo” file. I guess I shouldn’t have spent 7 hours last night translating mu..

    Anyway, my problem wasn’t the file, I already had mine. The directory I’ve put it in is “/wp-content/plugins/buddypress/bp-languages/” and it’s named buddypress-el_GR.mo. I saw in another thread that the directory should be “/wp-content/mu-plugins/buddypress/bp-languages/”, is that my fault?

    I also changed the language in the wp-config.php file to “define (‘WPLANG’, ‘el’);” and it didn’t work, so I created a folder named “languages” in “/wp-content/”. It still didn’t work. =/

    Avatar of Arturo
    Arturo
    Participant

    @arturo84

    Kogigr now you have buddypress-el_GR.po and buddypress-el_GR.mo in /wp-content/plugins/buddypress/bp-languages/ right?

    in wp-config.php insert on line #77

    define (\’WPLANG\’, \’el_GR\’);

    and save…

    I think this should resolve (BP side), however, looks for the translation of MU in greek.

    Avatar of Bloggsbe
    Bloggsbe
    Participant

    @bloggsbe

    The WordPress MU language file should be in /wp-includes/languages/ and you can change the language in your admin section of your wpmu install.

    The BuddyPress language file (buddypress-xx_XX.mo) should be in /wp-content/plugins/buddypress/bb-languages/ the xx_XX should be the same as on the file in /wp-includes/languages/ since BP gets the language setting from WPMU…

    You don\’t have to edit anything in your wp-config.php file!

    All of this is for WordPress MU 2.7.1 and BuddyPress 1.0. I don’t know how it is with older versions…

    HTH

    Regards,

    RuneG

    Avatar of Arturo
    Arturo
    Participant

    @arturo84

    from the WP org codex:

    Using Localizations

    In order to localize your installation of wordpress, create a directory named languages inside of wp-includes, if it does not already exist. Then grab the appropriate localization files from the Subversion Repository as described above. The main .mo file for the language should go inside the languages directory. Set WPLANG inside of wp-config.php to your chosen language. For example, if you wanted to use french, you would have:

    define (‘WPLANG’, ‘fr_FR’);

    i’ve this configuration on my MU+BP and all works fine.

    Avatar of Kogigr
    kogigr
    Participant

    @kogigr

    I finally did it! It had something to do with the names of the files, which I thought were right!

    Thank you very much! :D

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.