Skip to:
Content
Pages
Categories
Search
Top
Bottom

members who create blogs lose all permissions on main blog

  • Avatar of circuit
    circuit
    Participant

    @circuit

    hi everyone

    i’m not sure whether buddypress or MU is causing this behaviour; i’m desperate for a fix now as it is affecting user logins.

    1. if a user creates an account (no blog) they get subscriber status on blog 1. <– correct

    2. if a user creates an account AND blog they are NOT GIVEN permissions on blog 1 (role is set to ‘no role for this blog’). roles for ‘their’ blog are fine.

    3. if an existing user creates a blog they LOSE all permissions on blog 1 (role is set to ‘no role for this blog’). roles for ‘their’ blog are fine.

    after six hours (!) reading and experimenting i found a couple of threads that are hinting at a solution, but having almost destroyed my wp_usermeta table trying to work it out, i’m starting to think i might be out of my depth.

    http://buddypress.org/forums/topic/set-default-role-of-new-user

    http://mu.wordpress.org/forums/topic/13675?replies=22

    http://mu.wordpress.org/forums/topic/11684?replies=5

    these threads are all based around similar questions and problems to mine, but some are pretty out of date and mention bugs that have now been fixed, so i’m reluctant to follow the advice until i hear from an expert.

    i would really appreciate your help with this.

    _____________________________________________________________________________________

    1. Which version of WPMU are you running?

    2.8.5.2

    2. Did you install WPMU as a directory or subdomain install?

    Subdomain

    3. If a directory install, is it in root or in a subdirectory?

    Root

    4. Did you upgraded from a previous version of WPMU? If so, from which version?

    No

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    N/A

    6. Which version of BuddyPress (BP) are you running?

    1.1.2

    7. Did you upgraded from a previous version of BP? If so, from which version?

    No

    8. Do you have any plugins other than BuddyPress installed and activated?

    Yes – EventCalendar

    9. Are you using the standard BuddyPress themes or customized themes?

    Custom

    10. Have you modified the core files in any way?

    No

    11. Do you have any custom functions in bp-custom.php?

    No

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

    1.0.2

    13. Please provide a list of any errors in your server’s log files.

    Can’t check this at work..

Viewing 1 replies (of 1 total)
  • Avatar of circuit
    circuit
    Participant

    @circuit

    i’ve made some progress by installing the community blogs plugin.

    http://wordpress.org/extend/plugins/bp-community-blogs/

    the user’s roles in blog 1 are still removed when they create their own blog, but the plugin corrects this behaviour as soon as the page is reloaded.

    this is definitely not a perfect solution but it’s all i can do.

    i still have one problem, though. this plugin will not allow me to specify ‘subscriber’ – only ‘contributor’. i tried fiddling with the code and couldn’t get this to work. if anyone could help me hack this together, i would really appreciate it.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.