Skip to:
Content
Pages
Categories
Search
Top
Bottom

Members Widget Problems

  • Avatar of Korhan Ekinci
    Korhan Ekinci
    Participant

    @korhanekinci

    I have bp 1.0.3 and wpmu 2.8.1

    Members widget on the home page shows latest 10 members and I can’t change it to 20 or to any number in /wp-admin/widgets.php page. No matter what I write and save it is fixed to 10.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of Michael Kuhlmann
    Michael Kuhlmann
    Participant

    @suchaqd

    Try this: Go to your widgets page (WPMU backend), remove your members widget and refresh your homepage (on the front end — best if you have two windows open, side-by-side) until you see that “please log in to add your widgets” wording in your sidebar). Next, add your members widget again (backend) to your sidebar with your desired amount of people and refresh your homepage. Hopefully, that’ll fix it. You might not even have to do all that refresh stuff, but I had the same problem yesterday and it fixed it, so it seems to be some sort of caching thing.

    Avatar of Korhan Ekinci
    Korhan Ekinci
    Participant

    @korhanekinci

    No Mike, it didn’t work, I did exactly as you said and I still have 10 members although I put 20 in the widget option?!?

    Avatar of Korhan Ekinci
    Korhan Ekinci
    Participant

    @korhanekinci

    Interesting is that, active and popular links do show 20 members but not new members link

    Avatar of morgansson
    Anonymous

    I’m having the same problem. Is there any walkaround to fix this? Many thanks

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    There were some issues with the new Widget API in WPMu 2.8.1. I would suggest upgrading to WPMU 2.8.3 and see if that solves the problem.

    Avatar of morgansson
    Anonymous

    I’m using WPMU 2.8.3 and BP 1.0.3, but still just getting only a max of 10 users.

    The thing is… I can tell the widget to show from 1 to 10, but if I set more than 10, there will be showed only 10. But if you hit on “new”,”active” or “popular” you’ll get the selected number of users.

    Avatar of morgansson
    Anonymous

    There is a quickfix for this:

    open /wp-content/plugins/buddypress/bp-core/bp-core-widgets.php and change the line 88.

    from this:

    <?php if ( bp_has_site_members( 'type=newest&max=' . $instance['max_members'] ) ) : ?>

    to this:

    <?php if ( bp_has_site_members( 'type=newest&max=' . $instance['max_members'] . '&per_page=' . $instance['max_members'] ) ) : ?>

    I hope this helps.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.