Skip to:
Content
Pages
Categories
Search
Top
Bottom

New to this, need some help please!

  • Avatar of shootingstar85
    shootingstar85
    Participant

    @shootingstar85

    Hello,
    I am new to this and I am trying to get the BuddyPress plugin to work correctly. I installed the plugin from the wordpress dashboard. Then I created some user profile fields. Next, I was trying to create new groups, but when I am in dashboard, I go to ‘Groups’ then push the ‘add new’ button it takes me to a page with a 404 error. Im not real sure why it is doing this or what I need to do. I am wondering if I missed something when installing. Any help will be greatly appreciated! If you need more info just let me know.

    -Jen

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Have you activated groups via the checkbox on this screen?
    /wp-admin/options-general.php?page=bp-components

    Have you assigned a page to Groups via this screen?
    /wp-admin/admin.php?page=bp-page-settings

    The same and more info:

    http://codex.buddypress.org/getting-started/configure-components/

    Avatar of shootingstar85
    shootingstar85
    Participant

    @shootingstar85

    Yes, groups have been activated and assigned a page.

    This is what I think looks off to me, but I’m not sure how it is suppose to look.
    When I go to any other page from my dashboard the address is (for example) growpinion.com/index.php/about-growpinion/ and when I click on ‘add group’ it is just growpinion.com/groups/create Not sure if this has anything to do with it but it gives me the feeling that maybe its not going to the right place.

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    The problem is the ‘index.php’ in your url.

    On this screen: /wp-admin/options-permalink.php
    Is ‘Post name’ selected?

    On this screen: wp-admin/options-general.php
    what does WordPress Address (URL) say?
    And Site Address (URL) say?

    Go to Pages > Groups and click edit.
    If you see ‘index.php’ in the permalink, remove it.

    Avatar of shootingstar85
    shootingstar85
    Participant

    @shootingstar85

    Yes “Post Name” is selected.

    WordPress Address URL says http://growpinion.com
    Site address URL says http://growpinion.com

    When I go to Pages>Groups edit, it does say ‘index.php’ but it wont let me edit that part of the permalink, it will only let me edit the ‘groups’ part on the end.

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Permanently delete the Groups page – don’t just put it in the Trash.

    Then go to /admin.php?page=bp-page-settings
    And assign or create a new page for User Groups

    If that doesn’t work, then there is some other problem with either your BP or WP install.

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Just looked at your site.
    All page url include ‘index.php’.

    I don’t know why, but suggest you do a search or ask on the WP forums.

    You’re not the first to have this problem:

    http://wordpress.org/search/remove+index.php+from+urls

    Avatar of shootingstar85
    shootingstar85
    Participant

    @shootingstar85

    I tried to permanently delete the Groups page and then create a new one but that did not work. All my pages have the index.php in the address, it is not suppose to be this way? I tried to reinstall the BP a couple of times but it did not change anything.

    Avatar of shootingstar85
    shootingstar85
    Participant

    @shootingstar85

    Ahhh, well thanks for your help. I’ll see what I can find out!

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    ‘Almost Pretty Permalinks’ ? == index.php in url paths, windows server?

    Avatar of shootingstar85
    shootingstar85
    Participant

    @shootingstar85

    Y,es Windows with IIS 7.5. Do you know how to fix this? A friend of mine hosts my site for me, is there something he needs to do on his end?

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.