Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] No button for finishing registration

  • Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    I use WordPress 3.9.2 (with Twenty Twelve 1.4 ) and BuddyPress 2.0.2. (Both installation are newly made.)

    When BuddyPress is NOT activated new users get displayed that registration form:

    http://www.1a-spielwiese.de/wp-content/uploads/2014/08/Regis_OHNE_buddypress.jpg

    including a “Weiter” (next)-Button for finishing.

    After activing BuddyPress new users get displayed the following registration form:

    http://www.1a-spielwiese.de/wp-content/uploads/2014/08/Regis_MIT_buddypress.jpg

    without any “Next”-, “Submit”-, “Send”-, “Okay”-Button. –

    The problems persits, when I try Reddle 1.3.1 as theme. – Akismet-Plugin is installed, but not activated. “Theme Junkie Custom CSS”-Plugin is installed AND activated. Is only theme-modification, I made, is to change the color and the style of the entry titles in to orange and italic.

Viewing 25 replies - 1 through 25 (of 41 total)
  • Avatar of danbp
    danbp
    Moderator

    @danbp

    Hallo @1a-spielwiese,

    when checking the source code of http://www.1a-spielwiese.de/register/ you can see that, aside the missing buttons, the footer is also missing and at least mainly of the ending tags such as body and html…

    I would try to deactivate the custom css plugin and use a child-theme to do minor css modification for entry titles.

    Read also this:

    http://codex.buddypress.org/themes/bp-theme-compatibility-and-the-wordpress-default-themes/twenty-twelve-theme/

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    Thanx.

    Unfortunately it does NOT work this way. I have deactivated and deinstalled custom css plugin.

    But nevertheless no button (and not footer) is displayed on the registration page – though the footer (“Dieses Blog läuft mit WordPress”) IS displayed on the other pages.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    Amendment:

    I guess, connected with the above described problem is another problem.

    In the meantime I have activated “Extended Profiles” and I created three profile field groups.

    But only the fields of the first group are displayed – the fields of the field groups 2 und 3 not.

    Avatar of danbp
    danbp
    Moderator

    @danbp

    Are you on a single or MS install ?
    Are your BP pages correctly set up ?
    Did you activate pretty permalinks ?

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    “Are you on a single or MS install?”

    WordPress MultiSite.

    I have already created:

    http://kampfsportlerinnenneuwied.1a-spielwiese.de

    and

    http://balletttaenzerinnenkrzbg36.1a-spielwiese.de

    But they don’t work currently. I guess, I have to wait for some settings of my web space provider. – The provider is already informed.

    “Are your BP pages correctly set up?”

    What does this mean? Where I have to do this setting up? And what is “correct” and what is “not correct”?

    “Did you activate pretty permalinks?”

    I guess, not – if it is not automatically activated.

    Avatar of danbp
    danbp
    Moderator

    @danbp

    Both URL’s goes to error pages.
    So i’m affraid that you have to check your whole installation from the begin, first on your host (by reading his documentation) and after that your sites.

    To do that, you first need to ensure that your domain has a wildcard if you want to use subdomains.
    Then follow WP network install instruction and re-read BP install.

    http://codex.wordpress.org/Create_A_Network

    http://codex.buddypress.org/getting-started/configure-components/

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    My domain has wildcard; my provider did it for me, when I requested for it. –

    But is the sequenence of creating the blogs and setting the wildcard important?

    I created the blogs already on the 14th, but my provider set the wildcard on the 15th.

    Avatar of danbp
    danbp
    Moderator

    @danbp

    But is the sequence of creating the blogs and setting the wildcard important?
    Yes because it cannot work without.
    In case of doubt, you have always to check if it’s done and if it works.
    At this time it doesn’t work.
    And your main site is bugged so far, for a yet undetermined reason.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    “Yes because it cannot work without.”

    I have created a new blog 3h right now:

    http://3h.1a-spielwiese.de/

    But it doesn’t work as well, although my provider told me, that the wildcard was set yesterday. – Does that mean, that the setting of the wildcard was not made correctly? Or could be there any other cause, why it not work? –

    “And your main site is bugged so far, for a yet undetermined reason.”

    Is there any possibility to determine that reason?

    Avatar of danbp
    danbp
    Moderator

    @danbp

    We are on the way to determine what’s happening ! Be patient ! ;-)
    You said you installed your site before the wildcard was setted.
    So i presume you installed your wordpress before too !

    Normally during the install, a htaccess file is generated. The problem is that a MS htacces and a single htaccess file doesn’t contain the same rules. And same remark for the wp-config file.

    IMHO the easiest solution is – if the wildcard exist now – to remove the wp-config file from your site via FTP and to restart the installation process.
    No need to remove plugins and themes. Simply rename the plugin folder to xxx-plugins and they all will be deactivated.
    Once re-install successfully finished, you rename the plugin folder and you reactivate them one by one from the admin dashboard > plugins.

    Don’t forget that you’re on a MS. This means that you have 2 (zwei) dashboards. One for the main site and one for the Network. And that BuddyPress should be installed on the network.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    I installed WordPress. Then I activated the MultiSite-Functionality.

    Within that process the htaccess was mentioned. Because it didn’t exist, I created such file – with the rules, which are mentioned for activating the MultiSite Version.

    Finally I uploaded the htaccess and the modfied wp-config.php; and I contacted my provider regarding the Wildcard (and regarding deleting the www. prefix).

    All this I did on Thursday, and my provider answered on Friday.

    “Don’t forget that you’re on a MS. This means that you have 2 (zwei) dashboards.”

    Yes, I have two.

    “And that BuddyPress should be installed on the network.”

    I did so.

    “IMHO the easiest solution is – if the wildcard exist now – to remove the wp-config file from your site via FTP and to restart the installation process.”

    Okay, I will try this.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    “IMHO the easiest solution is – if the wildcard exist now – to remove the wp-config file from your site via FTP and to restart the installation process.”

    I did it. But I lost my content, because I forgot using the export tool before renewing the installation. –

    However, it did not solve the problems:

    1st: A button for finishing the registration is still not displayed.

    http://www.1a-spielwiese.de/registrieren/

    2nd: The newly created blog

    http://kampfsportlerinnenneuwied.1a-spielwiese.de/

    does not work.

    Avatar of danbp
    danbp
    Moderator

    @danbp

    Do you use a wordpress copy provided by your host ?
    Do you use a child-theme ?
    Do you use any shortcode on the register page ?

    Disallow blog creation for the moment and remove all xprofile fields to get only the default name field.
    Also download a fresh copy of wordpress and upload the twenty twelve theme folder to your site. Maybe your’s is corrupted somewhere.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    “Do you use a wordpress copy provided by your host?”

    No, that version:

    http://de.wordpress.org/latest-de_DE.zip

    “Do you use a child-theme?”

    No, up to now there was no nessicity for that.

    “Do you use any shortcode on the register page?”

    No – as far as I now.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    “remove all xprofile fields to get only the default name field.”

    When I posted the comment:

    http://buddypress.org/support/topic/no-button-for-finishing-registration/#post-187032

    non xprofile field was created.

    “Also download a fresh copy of wordpress and upload the twenty twelve theme folder to your site. Maybe your’s is corrupted somewhere.”

    That’s really unlikely, because both copies worked without problems, before I installed the BuddyPress-Plugin. And I tried never to make any major change of twenty twelve theme or WordPress itself.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    And seemling there were already in former times similar problems – without solution:

    http://buddypress.org/support/topic/complete-sign-up-button-not-working-on-register-page/

    and

    http://buddypress.org/support/topic/registration-button-invisible/

    Yesterday I found other descriptions of similar problems – as well without solution.

    Avatar of danbp
    danbp
    Moderator

    @danbp

    A last try please. Remove www from the site url in the site settings.

    See here how to change it and see if yo get the button.

    I opened a ticket for this.
    Please follow it, as you will probably be invited to give some more details to solve it.
    Thxs.

    Login credentials for the Trac are the same as on this forum.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    “A last try please. Remove www from the site url in the site settings.”

    Once the MultiSite Version is activated, there are – neither on the Network-level nor on the 1a-Spielwiese-level – the lines “WordPress Address (URL)” and “Site Address (URL)” within the Generel Settings anymore.

    However, my provider removed the www prefix already on Friday for me; cfr.:

    http://buddypress.org/support/topic/no-button-for-finishing-registration/#post-187029

    “I opened a ticket for this.
    Please follow it, as you will probably be invited to give some more details to solve it.”

    Have I to do anything right now? Or have I to read it only for the moment?

    —–

    However, I have decided to re-start really from the beginning; I removed all files from my ftp-server.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    – I removed all files from my ftp-Servers. – Only a folder ‘usage’ was not removable.

    — I deleted my WordPress database. I created a new WordPress database.

    — I renamed my old 1a-Spielwiese-folder on my on computer.

    — I created a new 1a-Spielwiese-folder and there a Word-Press-subfolder.

    — I downloaded a fresh WordPress copy from http://de.wordpress.org/latest-de_DE.zip to the mentioned subfolder.

    — I extracted the zip file. Then I uploaded the extracted files to my ftp-server.

    — I inserted my database infos to the wp-config.php and renamed it to wp-config.php.

    — I surfed to http://www.1a-spielwiese.de/wp-admin/install.php

    — After finishing the installation, I logged in and activated the Twentytwelve-Theme as well as ‘Jeder kann sich registrieren.’ I checked http://www.1a-spielwiese.de/wp-login.php?action=register – everything okay. The ‘Registrieren’-button is there.

    — I inserted the line
    define(‘WP_ALLOW_MULTISITE’, true);
    into the wp-config.php and logged in again.

    — I try to remove the www prefix from the WordPress-Adresse (URL) and Site Address (URL). During saving the setting change, I was automatically logged out. To log in again is impossible. Trying to go to 1a-spielwiese results in the error message:

    ‘Fehler: Umleitungsfehler

    Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.’

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    — Again I deleted everything (except the usage-folder) from my ftp-server and uploaded the fresh WordPress-copy again.

    — As well I uploaded again the wp-config.php with the line
    define(‘WP_ALLOW_MULTISITE’, true);

    — Nevertheless I get still the same error message:

    ‘Fehler: Umleitungsfehler

    Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.’

    — It’s the same as well, when I use the wp-config.php without the MultiSite-line.

    Avatar of danbp
    danbp
    Moderator

    @danbp

    Have I to do anything right now? Or have I to read it only for the moment?

    you have nothing to do for the moment on the ticket, except to visit it regulary to see if someone has responded.

    Now, your fresh install.
    What is the /usage/ folder for ?

    Most hoster have a root folder like htdocs or wwww.
    You install WP at the root. Eg. server root/wp-content, server root/wp-admin, etc

    In the htaccess file (WP MS) you should have something like this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>

    rewrite module must be active, it’s very important.

    Now what i suppose you did wrong.

    In wp-config, put this at the end, just before the line who says: don’t touch here….

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', '1a-spielwiese.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    You can follow a similar install mistake here, with the solution.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    Your last answer I have seen right now. – I can’t answer in detail before tomorrow; I have to logout and to leave.

    Only short:

    “What is the /usage/ folder for?”

    Maybe for for statistics.

    “Most hoster have a root folder like htdocs or wwww.
    You install WP at the root. Eg. server root/wp-content, server root/wp-admin, etc”

    The highest level is not named. The wp-config.php and the .htaccess are on the highest level. The different WordPress-Folders constitute – together with the usage-folder – the second level.

    —–

    Before I did:

    — Again I started everything up form the beginning. Now it is impossible to delete the file
    .nfs00000000038a694400007603
    from the wp-admin/includes folder.

    — I delete and re-create the wordpress-database etc.

    — This time I removed NOT the www. from the general setting.

    — I inserted the indicated further lines to the wp-config.php and uploaded the .htaccess.

    — I can log in; and I have two dashboards now. I activate ‘Es können neue Seiten und Benutzer registriert werden.’ (New pages and users can be registered.)

    — I log out; check the registration page. It’s everything okay: The ‘weiter’ (next)-Button is there.

    — I log in. I installed and activated BuddyPress.

    — I de-activated ‘Extended Profiles’. I de-activated ‘Show the Toolbar for logged out users’.

    — I log out and check the register page. The submit-Button is missing again.

    However, on Friday I received the message from my provider: ‘Ich habe dir DNS Wildcard gesetzt und www entfernt.’ (I have set the Wildcard and www removed.’) –

    But of course this referred on the WordPress/Buddy-installation from Friday not from today.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    My .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>

    # END WordPress

    —–

    The lines at issue of my wp-config.php:

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define(‘WP_DEBUG’, false);

    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    define(‘DOMAIN_CURRENT_SITE’, ‘www.1a-spielwiese.de’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);

    /* That’s all, stop editing! Happy blogging. */

    —–

    I have no time for comparing them right now. Sorry.

    Avatar of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    My wp-config.php and my .htaccess are both correct, isn’t it? –

    What shall we do? –

    — Shall we try to get the button at issue visible within the current WordPress-installation (with www. in the general settings)?

    — Or shall we try to solve the “Umleitungs”-problem, which appears, when I remove the www. from the general settings (s. http://buddypress.org/support/topic/no-button-for-finishing-registration/#post-187046)?

    Avatar of danbp
    danbp
    Moderator

    @danbp

    My wp-config.php and my .htaccess are both correct, isn’t it?

    Seems to be OK, yes !

    I’m unable to answer the other question. One thing is sure: your site should load with or without www.

    That said, depending your host, your site settings for the home and site url should match what is declared in your host account.
    Read here what Dreamhost told about this. The explained principle can be applied in practically any case.

    Another explanation about “with or without wwww” here.

    You could also double check what is exactly in the wp_options table for Home and Site Url on this page yoursite/wp-admin/options.php

    Aside that, have you added salt keys in wp-config during the network setting ?
    If not, get them from here.

Viewing 25 replies - 1 through 25 (of 41 total)

The topic ‘[Resolved] No button for finishing registration’ is closed to new replies.