Skip to:
Content
Pages
Categories
Search
Top
Bottom

Only admin can not view own profile

  • Avatar of Maylene
    Maylene
    Participant

    @secondliferpblog

    I am new to BuddyPress so this may be a simple problem. I installed the BuddyPress plug in (version 1.2.2.1) on my WP website the other day and everything seems to have gone smoothly. The only problem I’m having is that I can not view my admin profile on the website. Whenever I click on my name or go to my account->Profile, it links me to the home page. I tried making another account and I am able to view and edit that user’s profile. When I tried clicking on my admin account name when signed in as a regular account, it still links to the home page.

    I tried searching for this for the last few days but I can not find anyone with a similar problem. What am I doing wrong?

    Thanks for your help,

    Maylene

    Add: I have WordPress version 2.9.2

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Did you rename your wordpress admin user account?

    Avatar of Gdub01
    Gdub01
    Member

    @gdub01

    Hi, not to hijack a thread.. but I have the exact same issue at livingwallart.com. I can view someone else’s profile but not my own.

    I did rename my wordpress admin user account. I tried renaming it back. I still have the same problem… however.. for some reason.. when I click on my profile name it shows up as http://www.livingwallart.com/members/gavin-walsh-2/ So instead of just gavin-walsh, it throws a 2 on the end.

    How could this be fixed?

    I have another problem that could possibly be related. When I go to http://www.livingwallart.com/register and try to register, it just reloads the page and no one is registered.

    I should add that I am using FastCGI for PHP and it’s the latest version of wordpress and buddypress.

    Thanks a lot!

    Gavin

    Avatar of Gdub01
    Gdub01
    Member

    @gdub01

    Just a quick update.. the second problem I mentioned in the above post relates to the theme I’m using I believe. The first problem is still an issue with seeing my member page.

    Thanks,

    Gavin

    Avatar of Maylene
    Maylene
    Participant

    @secondliferpblog

    Yes, I’ve renamed the admin user account so the name is not “Admin” at all. It just reroutes to the home page any time I try clicking on the name or go through the toolbar to get to the profile.

    If you wanted to take a look, the homepage is: http://www.secondliferp.com . I’m the only one who has posted on the site so far, so you’ll know which user name is mine.

    Avatar of Maylene
    Maylene
    Participant

    @secondliferpblog

    Is there anyone who has any ideas? I’ll bump this once and let it die if no one else responds…but I hope you do!

    Avatar of michellemybelle
    michellemybelle
    Member

    @michellemybelle

    Don’t know if this will help or if I just got lucky, but I did you happen to install WP manually?

    I had similar problems and problems with uploading avatars on WP when I used Fantastico, that I wasn’t having on a WPMU installation. Out of curiosity I installed the single WP directly, and I no longer have problems with seeing my profile or avatars. Then again, you’d have to have a fresh install, which I know isn’t possible for everyone to do, but at least for me it solved the problem.

    Nothing against Fantastico, but I had similar problems when I’d used it for a Drupal site. Lots of errors with some modules that dissapeared when I installed manually.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.